Chrome nasıl kurulur ?


(kaan) #22

Hangi Pardus sürümünü kullanıyorsunuz ve aldığınız aynı olan hata nedir?


(Salih) #23

xxx@pardus:~/Downloads$ sudo dpkg -i google-chrome-stable_current_amd64.deb
(Veritabanı okunuyor … 113389 dosya veya dizin kurulu durumda.)
Paket açılacak: google-chrome-stable_current_amd64.deb …
Paket açılıyor: google-chrome-stable (61.0.3163.91-1) üzerine (61.0.3163.91-1) …
dpkg: bağımlılık sorunları yüzünden google-chrome-stable paketi yapılandırılamıyor:
google-chrome-stable şuna bağımlı: gconf-service, ama:
‘gconf-service’ paketi kurulu değil.
google-chrome-stable şuna bağımlı: libgconf-2-4 (>= 3.2.5), ama:
‘libgconf-2-4’ paketi kurulu değil.
google-chrome-stable şuna bağımlı: libappindicator1, ama:
‘libappindicator1’ paketi kurulu değil.

dpkg: google-chrome-stable paketi işlenirken sorun yaşandı (–install):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: man-db (2.7.6.1-2) …
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) …
Tetikleyiciler işleniyor: mime-support (3.60) …
Tetikleyiciler işleniyor: menu (2.1.47+b1) …
İşleme sırasında hatalarla karşılaşıldı:
google-chrome-stable

Yukarda ki hatayi alıyorum…
Pardus 17.1 sürümü
Chrome son sürüm…


(kaan) #24

Levent beyin yukarıdaki yaptığı şekilde denedinizmi?


(Salih) #25

apt-get install google-chrome-stable
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
google-chrome-stable : Bağımlılıklar: gconf-service ama kurulabilir değil
Bağımlılıklar: libgconf-2-4 (>= 3.2.5) ama kurulabilir değil
Bağımlılıklar: libappindicator1 ama kurulabilir değil
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
hatası aldım


(Salih) #26

Başka PC de sorun olması kurdum,
Hata veren PC de tekrar kontrol edeceğim, teşekkürler


(Ahmet) #27

Paketler kısmında kurdum fakat Türkçe olmadığı için burdaki yöntemle bir daha kurayım dedim ama olmadı sürekli bir yere bağlılık hatası veriyor. Tamamen nasıl kaıdırıp yeniden kurabilirim.


(Cüneyt Ulusoy) #28

Kurduğunuz paketin ismini belirtmediğiniz için eksik kısmı tamamlayınız;

sudo apt-get remove paketadı (google-chrome-stable olabilir)

Bağımlılık hatasında aşağıdaki komutu deneyiniz.


(Ahmet) #29

Denedim ama bu hatayı verdi.

W: Translations (main/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list:1 ve /etc/apt/sources.list.d/google-chrome.list:1 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr) hedefi /etc/apt/sources.list:1 ve /etc/apt/sources.list.d/google-chrome.list:1 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-en) hedefi /etc/apt/sources.list:1 ve /etc/apt/sources.list.d/google-chrome.list:1 konumlarında birden fazla kez yapılandırılmış
root@pardus:/home/pardus# apt-get install google-chrome-stable
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
google-chrome-stable : Bağımlılıklar: libappindicator1 ama kurulabilir değil
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
root@pardus:/home/pardus#


(Cüneyt Ulusoy) #30

Sonradan eklediğiniz repoları sudo rm -rf /etc/apt/sources.list.d/* komutu ile silebilir ya da /etc/apt/sources.list.d/ dizinine girerek tek tek silebilirsiniz. Bu işlemden sonra sudo apt-get update ve sudo apt-get install -f komutunu tekrar çalıştırınız. Ayrıca işlemlerinizi her daim normal kullanıcıda gerçekleştirmenizi tavsiye ederim.


(Ufuk) #31

Gdebi gerekli bağımlılıkları kurmuyor mu?


(Ahmet) #32

gdebi yi çalıştıramadım. bakalım uğraşacagız.


(pasa postasi) #33

Merhaba,

  1. chrome dosyasını indirdim.
  2. Uç birimden sudo dpkg -i indirdiğimdosyaadı ile kurulumu tamamladım. Ancak aşağıdaki sonuçları alıyorum.

adnan@pardus:~/İndirilenler$ sudo dpkg -i google-chrome-stable_current_amd64(1).deb
(Veritabanı okunuyor … 160002 dosya veya dizin kurulu durumda.)
Paket açılacak: google-chrome-stable_current_amd64(1).deb …
Paket açılıyor: google-chrome-stable (63.0.3239.84-1) üzerine (63.0.3239.84-1) …
dpkg: bağımlılık sorunları yüzünden google-chrome-stable paketi yapılandırılamıyor:
google-chrome-stable şuna bağımlı: gconf-service, ama:
‘gconf-service’ paketi kurulu değil.
google-chrome-stable şuna bağımlı: libappindicator1, ama:
‘libappindicator1’ paketi kurulu değil.
google-chrome-stable şuna bağımlı: libgconf-2-4 (>= 3.2.5), ama:
‘libgconf-2-4’ paketi kurulu değil.

dpkg: google-chrome-stable paketi işlenirken sorun yaşandı (–install):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: menu (2.1.47+b1) …
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) …
Tetikleyiciler işleniyor: mime-support (3.60) …
Tetikleyiciler işleniyor: man-db (2.7.6.1-2) …
İşleme sırasında hatalarla karşılaşıldı:
google-chrome-stable

  1. İnternet menusu aldında Chrome 'u görüyorum.

Ancak tıkladığımda hiç bir hareket olmuyor.

Yardımcı olursanız sevinirim.

İyi Akşamlar.


(Cüneyt Ulusoy) #34

Aşağıdaki komut ile gerekli bağımlılıkların kurulmasını sağlayabilirsiniz.

sudo apt-get -f install

Bu komut sonucunda hata veriyor mu?


(pasa postasi) #35

Çalıştı çok teşekkür ederim.Bu komut tam ne işe yarıyor?


(Cüneyt Ulusoy) #36

-f install ya da --fix-broken install ile; indirdiğiniz deb uzantılı dosyaların ihtiyaç duyduğu bağımlı dosyaları kuramaması durumunda bağımlılıkların kurulmasını, bir hata ile kesilen kurulumların tamamlanmasıya da onarılmasını sağlayabilirsiniz.


(Devrim Mehmet Pattabanoğlu) #38

Eğer bu kodlarla hata alıyorsanız benim gibi, indirdiğiniz dosyanın başlangıç dizininde olup olmadığını kontrol ediniz.

Misal bende indirilenler klasöründe iken dosya kodlar çalışmadı, fakat bunu kullanıcı klasörünün içine kopyaladığımda ( masaüstü, genel, belgeler vb… dosyalarında klasörlerinin göründüğü dizin) sorun çözüldü umarım yanlış yönlendirmiyorumdur ben bu şekilde bir hata ve çözüm getirdim. Belkide rastlantıdır bilemem.

Teşekkürler Cüneyt Bey, çözüme ulaştım.