E-imza ve akis kart sorunu


(Hüseyin) #1

16 adet bilgisayara aynı şekilde kurulum yaptım ama sadece 1 bilgisayarda e imza atacakken java açılıyor, e imza şifre girme ekranında kalıyor. akia çalıştır dediğimde bir anda görünüp kayboluyor. Ne yapabilirim? Hata veren bilgisayar 32 bit. Diğer pc ler 64 bit idi. E imza kurulumunu jdk.sh dosyası ile yapıyorum. Yardımcı olabilirseniz sevinirim.


(Kemal Oktay Aktoğan) #2

Selamün Aleyküm
E-imza’nın çalıştığı ve çalışmadığı makinelerdeki Pardus sürümleri nedir acaba?
Makinelerde hangi Pardus sürümü kurulu?
Selametle…


(Hüseyin) #3

Thunar komutu ile dosya açmıştım, e imza cihazını takınca uçbirimde şöyle bir hata yazdı:

thunar-volman: “usbfs” USB aygıt türü desteklenmiyor.

Çalıştığı ve çalışmadığı makinelerde aynı sürüm yani 17,2 kurulu.


(Yunusemre Şentürk) #4

Merhaba @hciftci bey,

17 de 32 bit yok acaba nasıl çalıştırdınız, makina aslında 64 bit ve donanımsal bir sorun mu var ?


(Hüseyin) #5

Makine 32 bit. Herhangi bir sorun yok bu problem dışında.


(Kemal Oktay Aktoğan) #6

Selamün Aleykül
İşlemcinin tam modeli nedir acaba?


(Yunusemre Şentürk) #7

Hocam 64 bit çalışmaz yapmayın görüntü bile alamazsınız çünkü Xorg çalışmaz bir yanlışlık var. Çok eski ilk çıkan x86 sistemlerden olabilir mi acaba.


(Hüseyin) #8

Uçbirimde akia komutunu çalıştırdığım zaman şöyle bir çıktı alıyorum:
[EN] Checking for dependencies…
[TR] Bagimliliklar kontrol ediliyor…

(.) openjdk-8-jre
(.) libpcsclite1
(.) pcscd
(.) libccid

[EN] Dependencies are OK
[TR] Bagimliliklar TAMAM

/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
java: tpp.c:84: __pthread_tpp_change_priority: Assertion `new_prio == -1 || (new_prio >= fifo_min_prio && new_prio <= fifo_max_prio)’ failed.
Aborted

javayı tekrar yükledim ama sorun çözülmedi. İşlemcimin modeli veya 64/32 bit olması çok mu önemli? Pardus kurulu çalışıyor ve bunun dışında başka bir problemim yok.


(Hüseyin) #9

Yeni birşey daha gördüm. Akis kartı usb den çıkarıp akia komutunu çalıştırınca sorun olmuyor. Kartı taktığım anda uçbirimde aborted yazıyor. Hata mesajı da şöyle:

*** Error in `java’: free(): invalid next size (fast): 0x00007f0990158b90 ***


(Hüseyin) #10


(Kemal Oktay Aktoğan) #11

Başka kart varsa deneyebilir misiniz aynı sonucu mu veriyor acaba?


(Hüseyin) #12

Evet veriyor denedim.


(Kemal Oktay Aktoğan) #13

Bunun ile ilgili bir firma yetkilisi(galiba) yazılımlarında benzer bir sorun yaşadıklarını söylemişti. Sistem 64 bit olmasına rağmen lib64 dizini oluşturup .so dosyalarının bağlarını(link) bu dizin içine oluşturuyordu. Yazılımı bu sayede çalışıyormuş.
Belki sorun burada yazılımın kendisindedir diye düşünüyorum ama diğer bilgjsayarlarda aynı işlemde sıkıntı çıkarmamış :thinking::thinking::thinking::thinking:

Yeniden temiz bir kurulum yapma imkânınız var mı acaba?


(Hüseyin) #14

2 kere format attım ama sonuç değişmedi. 3 gündür uğraşıyorum.


(Kemal Oktay Aktoğan) #15

Donanımlar farklı mı?


(Hüseyin) #16

Evet her bilgisayarın donanımı aynı değil. Bu bilgisayarla aynı donanımda başka bilgisayar yok. Akis kartını takınca akia hata verip kapanıyor. Cihaz takılı değilken açılıyor. Öyle çözülmedi bir türlü neden olduğunu anlayamadım.


(Hüseyin) #17

Çözüm bulamıyorum tekrar Windows kuracağım.


(Kemal Oktay Aktoğan) #18

Selamün Aleyküm
Hata mesajındaki lib64 ibarelerini görünce aklıma bu geldi. Önceki mesajımda da bahsetmiştim. Bunu deneyebilir misiniz?


(Hüseyin) #19

bu kodları yazmayı denedim bir değişiklik olmadı. burada neyi yapmamı istediğinizi tam anlayamadım? linki açtım en üstteki sürümü indirdim ama birşey anlamadım yardımcı olur musunuz?


(Mesut Canatan) #20

Sağlık Bakanlığı e-imza sorununu arksigner uygulaması ile çözdü. Bu uygulamayı kurduğunuzda java vb kurmak zorunda kalmıyorsunuz. Pardus ile kurulu gelen java işinizi rahat görüyor. Selametle kalınız.