İntel + Nvidia Ekran Kartı


(Mehmet Tuğrul) #1

Merhabalar bugün Pardus kurmaya karar verdim kurulumdan sonra ekran kartı problemi yaşıyorum Dell Inspiron N5110 Dizüstü bilgisayarda İntel + NVIDIA GeForce GT 525M ekran kartı var forumda açılan konulardan yola çıkarak kurmayı denedim bir türlü kuramadım ekranda dalgalanmalar mevcut kurulum olmuyor.


(Cüneyt Ulusoy) #2

Hangi işlemleri uyguladınız?


(Yunusemre Şentürk) #3

GT 500 serisinde problem yok, görüntü mü alamıyorsunuz ekran çözünürlüğünüz de mi problem var, olaylara microsoft firması gibi bakmayın Pardus içerisinde bir çok ekran kartı driver ı yüklü geliyor saydığım problemler yoksa ekran kartı driver ını ayrıca kurmanıza lüzum yoktur.

Selamlar.


(Ertuğrul) #4

Aşağıdaki videoda ekran dalgalanma sorunu yaşamaktayım ne yapmam gerekiyor,donanım bilgim resimdeki gibidir.


(ismail) #5

linuxta nvidia optimus desteği yok sadece açık kaynak kodlu alternatifler var distro bazlı olanlar falan. benim tecrübelerime göre verimli değiller. bumblebee yanlış hatırlamıyorsam adı. onu kullanabilirsin. ya da direk nvidia kartını kullan çünkü intel kartı performas olarak zayıf. dalgalanmalar da o yüzden oluyor. yani bilgisayarın nvidia sürücülerini kullanmıyor.


(Mehmet Tuğrul) #6

Merhaba kullandığım ekran kartı Nvidia GeForce GT 525M dizüstü bilgisayar


(Mehmet Tuğrul) #7
apt-get purge nvidia* bumblebee*
apt-get install -y mesa-utils
apt-get autoremove

sonra

apt-get install bumblebee-nvidia

yükledim ama bir türlü olmadı şuan hepsini kaldırdım video izlerken ekranda yırtılmalar oluyor


(ismail) #8

nvidia optimus donanım değil teknoloji adı. tümleşik ekran kartı ile nvidia ekran kartı arasında iş yoğunluğuna göre geçiş yapan bir sistem. zaten dedim çok verimli değil diye bumblebee. sen en iyisi nvidia nın sitesinden güncel gerekli sürücüyü indirip kur. terminal ekranı üzerinden. manuel kurulum için yönergeler vardır forumda. ezberimde yok)) bende gt740m ekran kartı ile çok uğraştım ama sonunda sadece nvidia sürücüsüne geçtim.


(Ertuğrul) #9

Arkadaşlar Ekran dalgalanması sornuna kalıı çözüm bulabilen varmı gerçekten sorun halen devam ediyor.


(Mehmet Tuğrul) #10

ben bir çözüm yolu buldum;

Nvidia Kapalı Kaynak Sürücüsü Kurulumu

**UYARI: Sisteminizde meydana gelebilecek herhangi bir zarardan kesinlikle sorumlu değilim.

Şimdi bu (https://www.nvidia.com/Download/index.aspx) adrese giderek güncel Nvidia sürücüsünü indirin ve kurulum için X sunucusunu kapatın ve komut satırında oturum açın.

$sudo service lightdm stop

UYARI: X sunucusunu kapatmak için kullanılan komut dağıtımlar arasında farklılık gösterecektir. Aramaya inanın.

Oturum açtıktan sonra sürücüyü indirdiğiniz klasöre gidin. Bu klasör siz aksini yapmadıysanız İndirilenler klasörü olacaktır.

$ cd /home/YourUserName/Downloads

Şimdi indirdiğiniz kurulum dosyasına executable ( çalıştırılabilirlik) izni vermelisiniz. Bunun için chmod +x komutunu kullanın. Aşağıda bir örneğini bulabilirsiniz;

$ chmod +x NVIDIA-Linux-x86_64-361.42.run

Son olarak indirdiğiniz dosyayı aşağıda görebileceğiniz şekilde ./ komutu ile çalıştırın ve Kurulum Sihirbazı’nın size gösterdiği adımları takip ederek sürücünüzü yükleyin.

$ sudo ./NVIDIA-Linux-x86_64-361.42.run

Sisteminizi yeniden başlatmadan önce grub config dosyasına eklediğiniz “nomodeset” parametresini kaldırın ve tekrardan grub-update komutunu çalıştırın. Şimdi bilgisayarınızı yeniden başlatabilirsiniz. Eğer her şey yolunda gittiyse kurulumunuz tamamlanmış demektir. Bunu “glxinfo | grep NVIDIA” komutunu çalıştırarak test edebilirsiniz. Bu komutun size şöyle bir çıktı vermesi gerekmektedir;

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
OpenGL core profile version string: 4.3.0 NVIDIA 361.42
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL version string: 4.5.0 NVIDIA 361.42
OpenGL shading language version string: 4.50 NVIDIA

ben denedim nvidia ekran kartını yükledim. sorunsuz çalışıyor.


(Mehmet Tuğrul) #11

Ekran Dalgalanması Sorunu için çözüm;

Aşağıdaki komutlarla Nvidia sürücüsü PPA deposundan Nvidia sürücüsünü güncellemenizi öneriyoruz.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-381 nvidia-settings

Xorg 1.19…x Sürüm Yükseltme

Aşağıdaki komutla Xorg’un HWE destekli 1.19.x sürümünü sisteminize kurabilirsiniz.

sudo apt-get install --install-recommends xserver-xorg-hwe-16.04

Nvidia Sürücüsü için modeset etkinleştirme

Bunun için aşağıdaki komutu uçbirimde çalıştırınız.

sudo xed /etc/modprobe.d/zz-nvidia-modeset.conf

Açılan dosyaya aşağıdaki satırları ekleyip dosyayı kaydediniz.

options nvidia-381_drm modeset=1

Yukarıdaki satır kullanılan sürücüye göre değiştirilebilir, Örneğin Nvidia-384 sürücüsünü kurarsanız yukarıdaki satırı aşağıdaki şekilde değiştirmeniz gerekecek

options nvidia-384_drm modeset=1

Yeniden başlatma

Yukarıdaki işlemlerden sonra sisteminizi yeniden başlatınız.

PRIME Synchronization Etkinleştirme

Sisteminizi açtıktan sonra aşağıdaki komutla Nvidia sürücüsü için modeset etkinliğini kontrol ediniz.

sudo cat /sys/module/nvidia_drm/parameters/modeset

Komut “Y” olarak çıktı veriyorsa Nvidia sürücüsü için modeset etkin demektir.

Artık aşağıdaki komutla Nvidia sürücüsü için PRIME Synchronization özelliğini etkinleştirebilirsiniz.

xrandr --output eDP-1-1 --set 'PRIME Synchronization' '1'

Yukarıdaki komutda eDP-1-1 yazan kısım benim sistemimdeki bağlantı arayüzü. Bu sizin sisteminizde farklı olabilir, hangi arayüzün kullanıldığını öğrenmek için aşağıdaki komutun çıktısınıdan faydalanabilirsiniz.

xrandr

Bu şekilde düzenlediğiniz komutu Başlangıç Uygulamalarına eklerseniz, her oturum açtığınızda komutu yeniden çalıştırmanız gerekmeyecektir.

Not: Başlangıç Uygulamalarına eklerken komutu tırnak işaretleri içerinde yazmalısınız.

"xrandr --output eDP-1-1 --set 'PRIME Synchronization' '1'"

Arada farkı görebilmek için aşağıdaki komutla PRIME Synchronization özelliğini pasifleştirebilirsiniz. Tekrar etkinleştirmek için yukarıdaki komutu yeniden çalıştırmalısınız.

xrandr --output eDP-1-1 --set 'PRIME Synchronization' '0'

(Cüneyt Ulusoy) #12