Pardus'a visual studio kurulur mu


(Hakan Duran) #1

pardus’a visual studio kurulur mu


Pardus'ta Olması Gereken Yazılımlar
(Cüneyt Ulusoy) #2

Visual Studio Code kurulum dosyasını buradan indirip aşağıdaki şekilde kurulumunu gerşekleştirebilirsiniz;

sudo dpkg -i code_1.21.1-1521038896_amd64.deb
sudo apt-get -f install

Menüden > Geliştirme bölümünden Visual Studio Code ile ya da terminalden code komutu ile çalıştırabilirsiniz.


(Emin Fedar) #3

Visual Studio kurulmaz, eğer c++ geliştirecek iseniz linux için bir sürü ide ve text editor mevcut. Eğer .net ile uğraşacaksanız yol yakın iken dönün :slight_smile: gelecek Cross-Platformda.


(Ali KOCA) #4

Merhabalar;


Bu şirketin bir sürü ürünü mevcut. Ve çok da kaabiliyyetliler. Denemenizi tavsiye ederim.

Selamlar.


(Veli Ertunc) #5

.NET için Mono-Develop var. Visual Studio nun Linux C# IDE sidir. Sitesi: http://www.monodevelop.com/
eğer terminale sudo apt install mono-complete yazarsanız hem IDE yi hem de .NET Core u indirebilirsiniz.1


(Veli Ertunc) #6

Direkt olarak hayır. 2 seçenek var.

  1. Sanallaştıma Ortamı (VirtualBox-VMware) kullanmak
  2. C# için soruyorsanı Mono-Develop kullanmak

(Ömer Faruk MIZIKACI) #7

Visual Studio değilde Visual Studio Code kurulur. Kurduk çalıştırıyoruz. Git veya Svn kullanarak sürüm denetimi de yaparsın. Yaptık. çalıştırıyoruz. C#,Python programlama yapabilirsin. .Net Core kütüphaneleri ile ASP.NET Core MVC web uygulaması geliştiriyoruz ve programlaması Windows ve Pardus kullanan yazılım ekibi geliştiriyor ve Pardus üzerinde deploy ederek şuan test süreçlerini gerçekleştiriyoruz.


(Ibrahim) #8

yardimci olurmusunuz .

@****:/home//İndirilenler# sudo dpkg -i ./atom-amd64.deb
(Veritabanı okunuyor … 169701 dosya veya dizin kurulu durumda.)
Paket açılacak: ./atom-amd64.deb …
Paket açılıyor: atom (1.27.0) üzerine (1.27.0) …
dpkg: bağımlılık sorunları yüzünden atom paketi yapılandırılamıyor:
atom şuna bağımlı: git, ama:
‘git’ paketi kurulu değil.
atom şuna bağımlı: gconf2, ama:
‘gconf2’ paketi kurulu değil.
atom şuna bağımlı: gconf-service, ama:
‘gconf-service’ paketi kurulu değil.
atom şuna bağımlı: gvfs-bin, ama:
‘gvfs-bin’ paketi kurulu değil.

dpkg: atom paketi işlenirken sorun yaşandı (–install):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) …
Tetikleyiciler işleniyor: mime-support (3.60) …
İşleme sırasında hatalarla karşılaşıldı:
atom
@*****:/home//İndirilenler# apt-get install -f
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Bağımlılıklar düzeltiliyor… Tamamlandı
Aşağıdaki paketler KALDIRILACAK:
atom
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 554 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor … 169701 dosya veya dizin kurulu durumda.)
Kaldırılıyor: atom (1.27.0) …
Tetikleyiciler işleniyor: mime-support (3.60) …
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) …


(Cüneyt Ulusoy) #9

Bu dosyanın linki hangisi? Hangi Pardus’u kullanıyorsunuz?


(Muhammed YILMAZ) #10

Eğer kurmaya çalıştığınız şey Atom IDE ise şu komutla kurabilirsiniz.

sudo apt install atom

(Ibrahim) #11

pardus son surum .
bir kac gun once yazdim yazilimi.boot olarak kullaniyorum. code editor yazmak istiyorum forumda yer alan visual linkine girip visual download ediyorum kurulmuyor. atomu denedim oda olmuyor.debian olarak indiriliyor. oda kurulumda hata veriyor.


(Ibrahim) #12

Pardus 17.2 kullanıyorum. verilen linkten visual kurmaya çalışıyorum yine yapılandırma hatası veriyor.

terminalda olanlar :

bebir@pardus:~/İndirilenler$ sudo dpkg -i code_1.23.1-1525968403_amd64.deb
Daha önce seçili olmayan code paketi seçiliyor.
(Veritabanı okunuyor … 162280 dosya veya dizin kurulu durumda.)
Paket açılacak: code_1.23.1-1525968403_amd64.deb …
Paket açılıyor: code (1.23.1-1525968403) …
dpkg: bağımlılık sorunları yüzünden code paketi yapılandırılamıyor:
code şuna bağımlı: libgconf-2-4, ama:
‘libgconf-2-4’ paketi kurulu değil.

dpkg: code paketi işlenirken sorun yaşandı (–install):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) …
Tetikleyiciler işleniyor: mime-support (3.60) …
İşleme sırasında hatalarla karşılaşıldı:
code
bebir@pardus:~/İndirilenler$


(Ali KOCA) #13

Merhabalar;
Şuradaki talimatları takip ederek kurabilirsiniz. 17.2 de aynı talimatlara kurulum yaptık, kullanıyoruz.


Selamlar.