Debins | Tek tıkla .deb paketi kurun!


(Muhammed YILMAZ) #21

Önce otomatik eklenip sonra da isteyenlerin kaldırabilmesi için uygulamaya ayarlar gibi bir şey de eklenebilir. Ya da tam tersi için.


(Emin Fedar) #22

Boşluklu dosyalarda çalışmama sorunu 0.11 sürümüyle düzeltildi. @edge35’e çok teşekkürler :slight_smile:


(Muhammed YILMAZ) #23

Öncelikle şunu koyayım. :slight_smile:
Program kurarken şifre ekranı gelince eğer şifreyi girmeyip şifre ekranını kapatırsam (Error: 126) :

myilmaz@pardus:~/İndirilenler$ debins debins_0.11_amd64.deb 
OUT:  "Error executing command as another user: Request dismissed\n"
myilmaz@pardus:~/İndirilenler$

İkinci olarak sürüm yükseltirken de reinstall yazıyor, sanki Upgrade yazsa daha iyi olur gibi :slight_smile:


Son olarak “mintstick_1.3.4_all.deb” , “kolourpaint-4-8-2-es-en-ubu.deb” ve aynı konumdaki birkaç uygulamada daha kurarken (Error: 1):

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ debins mintstick_1.3.4_all.deb 
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/mintstick_1.3.4_all.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 22950 bayt: denetim arşivi=1045 bayt.\n     508 bayt,    12 satır      control              \n    1260 bayt,    17 satır      md5sums              \n Package: mintstick\n Version: 1.3.4\n Architecture: all\n Maintainer: Clement Lefebvre <root@linuxmint.com>\n Installed-Size: 148\n Depends: coreutils (>= 6.10-3), gir1.2-gtk-3.0, gir1.2-polkit-1.0, ntfs-3g, parted, policykit-1, procps, python, python-glade2, python-parted, gir1.2-udisks-2.0, util-linux\n Conflicts: usb-imagewriter\n Replaces: usb-imagewriter\n Section: misc\n Priority: optional\n Description: write .img and .iso files to USB sticks\n  A GUI to write .img or .iso files to a USB Key. It can also format them.\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 22950 bayt: denetim arşivi=1045 bayt."
L:   "    508 bayt,    12 satır      control              "
L:   "   1260 bayt,    17 satır      md5sums              "
L:   "Package: mintstick"
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/mintstick_1.3.4_all.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 22950 bayt: denetim arşivi=1045 bayt.\n     508 bayt,    12 satır      control              \n    1260 bayt,    17 satır      md5sums              \n Package: mintstick\n Version: 1.3.4\n Architecture: all\n Maintainer: Clement Lefebvre <root@linuxmint.com>\n Installed-Size: 148\n Depends: coreutils (>= 6.10-3), gir1.2-gtk-3.0, gir1.2-polkit-1.0, ntfs-3g, parted, policykit-1, procps, python, python-glade2, python-parted, gir1.2-udisks-2.0, util-linux\n Conflicts: usb-imagewriter\n Replaces: usb-imagewriter\n Section: misc\n Priority: optional\n Description: write .img and .iso files to USB sticks\n  A GUI to write .img or .iso files to a USB Key. It can also format them.\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 22950 bayt: denetim arşivi=1045 bayt."
L:   "    508 bayt,    12 satır      control              "
L:   "   1260 bayt,    17 satır      md5sums              "
L:   "Package: mintstick"
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/mintstick_1.3.4_all.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 22950 bayt: denetim arşivi=1045 bayt.\n     508 bayt,    12 satır      control              \n    1260 bayt,    17 satır      md5sums              \n Package: mintstick\n Version: 1.3.4\n Architecture: all\n Maintainer: Clement Lefebvre <root@linuxmint.com>\n Installed-Size: 148\n Depends: coreutils (>= 6.10-3), gir1.2-gtk-3.0, gir1.2-polkit-1.0, ntfs-3g, parted, policykit-1, procps, python, python-glade2, python-parted, gir1.2-udisks-2.0, util-linux\n Conflicts: usb-imagewriter\n Replaces: usb-imagewriter\n Section: misc\n Priority: optional\n Description: write .img and .iso files to USB sticks\n  A GUI to write .img or .iso files to a USB Key. It can also format them.\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 22950 bayt: denetim arşivi=1045 bayt."
L:   "    508 bayt,    12 satır      control              "
L:   "   1260 bayt,    17 satır      md5sums              "
L:   "Package: mintstick"
OUT:  "(Veritabanı okunuyor ... 287404 dosya veya dizin kurulu durumda.)\n"
OUT:  "Paket açılacak: .../mintstick_1.3.4_all.deb ...\n"
OUT:  "Paket açılıyor: mintstick (1.3.4) üzerine (1.3.4) ...\n"
OUT:  "dpkg: bağımlılık sorunları yüzünden mintstick paketi yapılandırılamıyor:\n mintstick şuna bağımlı: gir1.2-polkit-1.0, ama:\n  'gir1.2-polkit-1.0' paketi kurulu değil.\n mintstick şuna bağımlı: python-glade2, ama:\n  'python-glade2' paketi kurulu değil.\n mintstick şuna bağımlı: python-parted, ama:\n  'python-parted' paketi kurulu değil.\n mintstick şuna bağımlı: gir1.2-udisks-2.0, ama:\n  'gir1.2-udisks-2.0' paketi kurulu değil.\n\ndpkg: mintstick paketi işlenirken sorun yaşandı (--install):\n bağımlılık sorunları - yapılandırılmadan bırakılıyor\n"
OUT:  "Tetikleyiciler işleniyor: man-db (2.7.6.1-2) ...\n"
OUT:  "Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...\n"
OUT:  "Rebuilding /usr/share/applications/bamf-2.index...\n"
OUT:  "Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...\n"
OUT:  "Tetikleyiciler işleniyor: mime-support (3.60) ...\n"
OUT:  "İşleme sırasında hatalarla karşılaşıldı:\n mintstick\n"
myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$



myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ debins kolourpaint-4-8-2-es-en-ubu.deb 
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/kolourpaint-4-8-2-es-en-ubu.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 1149940 bayt: denetim arşivi=5337 bayt.\n     997 bayt,    20 satır      control              \n   17193 bayt,   167 satır      md5sums              \n     135 bayt,     7 satır   *  postinst             #!/bin/sh\n     132 bayt,     7 satır   *  postrm               #!/bin/sh\n      35 bayt,     1 satır      shlibs               \n Package: kolourpaint4\n Source: kolourpaint\n Version: 4:4.8.2-0ubuntu1\n Architecture: i386\n Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>\n Installed-Size: 2019\n Depends: kde-runtime, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libkdecore5 (>= 4:4.8.1), libkdeui5 (>= 4:4.8.1), libkio5 (>= 4:4.8.1), libkprintutils4 (>= 4:4.8.1), libqimageblitz4 (>= 1:0.0.4), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libstdc++6 (>= 4.1.1)\n Breaks: kolourpaint\n Replaces: kolourpaint\n Section: graphics\n Priority: optional\n Homepage: http://www.kde.org/\n Description: simple image editor and drawing application\n  KolourPaint is a simple drawing and image editing application for KDE.\n  It aims to be easy to use, providing a level of functionality targeted towards\n  the average user. It is ideal for common tasks such as drawing simple graphics\n  and touching-up photos.\n  .\n  This package is part of the KDE graphics module.\n Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 1149940 bayt: denetim arşivi=5337 bayt."
L:   "    997 bayt,    20 satır      control              "
L:   "  17193 bayt,   167 satır      md5sums              "
L:   "    135 bayt,     7 satır   *  postinst             #!/bin/sh"
L:   "    132 bayt,     7 satır   *  postrm               #!/bin/sh"
L:   "     35 bayt,     1 satır      shlibs               "
L:   "Package: kolourpaint4"
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/kolourpaint-4-8-2-es-en-ubu.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 1149940 bayt: denetim arşivi=5337 bayt.\n     997 bayt,    20 satır      control              \n   17193 bayt,   167 satır      md5sums              \n     135 bayt,     7 satır   *  postinst             #!/bin/sh\n     132 bayt,     7 satır   *  postrm               #!/bin/sh\n      35 bayt,     1 satır      shlibs               \n Package: kolourpaint4\n Source: kolourpaint\n Version: 4:4.8.2-0ubuntu1\n Architecture: i386\n Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>\n Installed-Size: 2019\n Depends: kde-runtime, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libkdecore5 (>= 4:4.8.1), libkdeui5 (>= 4:4.8.1), libkio5 (>= 4:4.8.1), libkprintutils4 (>= 4:4.8.1), libqimageblitz4 (>= 1:0.0.4), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libstdc++6 (>= 4.1.1)\n Breaks: kolourpaint\n Replaces: kolourpaint\n Section: graphics\n Priority: optional\n Homepage: http://www.kde.org/\n Description: simple image editor and drawing application\n  KolourPaint is a simple drawing and image editing application for KDE.\n  It aims to be easy to use, providing a level of functionality targeted towards\n  the average user. It is ideal for common tasks such as drawing simple graphics\n  and touching-up photos.\n  .\n  This package is part of the KDE graphics module.\n Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 1149940 bayt: denetim arşivi=5337 bayt."
L:   "    997 bayt,    20 satır      control              "
L:   "  17193 bayt,   167 satır      md5sums              "
L:   "    135 bayt,     7 satır   *  postinst             #!/bin/sh"
L:   "    132 bayt,     7 satır   *  postrm               #!/bin/sh"
L:   "     35 bayt,     1 satır      shlibs               "
L:   "Package: kolourpaint4"
GPN :  "dpkg --info \"/media/myilmaz/YEDEK/Programs/Linux - Debian/kolourpaint-4-8-2-es-en-ubu.deb\""
PSO:   " yeni debian paketi, sürüm 2.0.\n boyut 1149940 bayt: denetim arşivi=5337 bayt.\n     997 bayt,    20 satır      control              \n   17193 bayt,   167 satır      md5sums              \n     135 bayt,     7 satır   *  postinst             #!/bin/sh\n     132 bayt,     7 satır   *  postrm               #!/bin/sh\n      35 bayt,     1 satır      shlibs               \n Package: kolourpaint4\n Source: kolourpaint\n Version: 4:4.8.2-0ubuntu1\n Architecture: i386\n Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>\n Installed-Size: 2019\n Depends: kde-runtime, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libkdecore5 (>= 4:4.8.1), libkdeui5 (>= 4:4.8.1), libkio5 (>= 4:4.8.1), libkprintutils4 (>= 4:4.8.1), libqimageblitz4 (>= 1:0.0.4), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libstdc++6 (>= 4.1.1)\n Breaks: kolourpaint\n Replaces: kolourpaint\n Section: graphics\n Priority: optional\n Homepage: http://www.kde.org/\n Description: simple image editor and drawing application\n  KolourPaint is a simple drawing and image editing application for KDE.\n  It aims to be easy to use, providing a level of functionality targeted towards\n  the average user. It is ideal for common tasks such as drawing simple graphics\n  and touching-up photos.\n  .\n  This package is part of the KDE graphics module.\n Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>\n"
L:   " yeni debian paketi, sürüm 2.0."
L:   "boyut 1149940 bayt: denetim arşivi=5337 bayt."
L:   "    997 bayt,    20 satır      control              "
L:   "  17193 bayt,   167 satır      md5sums              "
L:   "    135 bayt,     7 satır   *  postinst             #!/bin/sh"
L:   "    132 bayt,     7 satır   *  postrm               #!/bin/sh"
L:   "     35 bayt,     1 satır      shlibs               "
L:   "Package: kolourpaint4"
OUT:  "(Veritabanı okunuyor ... 287593 dosya veya dizin kurulu durumda.)\n"
OUT:  "Paket açılacak: .../kolourpaint-4-8-2-es-en-ubu.deb ...\n"
OUT:  "Paket açılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) üzerine (4:4.8.2-0ubuntu1) ...\n"
OUT:  "dpkg: bağımlılık sorunları yüzünden kolourpaint4:i386 paketi yapılandırılamıyor:\n kolourpaint4:i386 şuna bağımlı: kde-runtime.\n kolourpaint4:i386 şuna bağımlı: libkdecore5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkdeui5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkio5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkprintutils4 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libqimageblitz4 (>= 1:0.0.4).\n kolourpaint4:i386 şuna bağımlı: libqtcore4 (>= 4:4.7.0~beta1).\n kolourpaint4:i386 şuna bağımlı: libqtgui4 (>= 4:4.8.0).\n kolourpaint4:i386 şuna bağımlı: libstdc++6 (>= 4.1.1).\n\ndpkg: kolourpaint4:i386 paketi işlenirken sorun yaşandı (--install):\n bağımlılık sorunları - yapılandırılmadan bırakılıyor\n"
OUT:  "Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...\n"
OUT:  "Rebuilding /usr/share/applications/bamf-2.index...\n"
OUT:  "Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...\n"
OUT:  "Tetikleyiciler işleniyor: mime-support (3.60) ...\n"
OUT:  "Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...\n"
OUT:  "İşleme sırasında hatalarla karşılaşıldı:\n kolourpaint4:i386\n"
myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$

(Emin Fedar) #24

Hemen bakıyorum, çok buglu bırakmışız yahu :slight_smile:


(Muhammed YILMAZ) #25

Fena mı oldu, bana da eğlence çıktı :smile: Olur öyle şeyler :smile:


(Emin Fedar) #26

Upgrade olayı Türkçe çevirinin geleceği sonraki sürüm ile gelebilir, şimdilik program bir düzgün çalışsın :slight_smile:


(Emin Fedar) #27

Çevrimiçi olan var ise düzeltilmiş bir paket yükledim. Link aynı, geribildirim verirseniz iyi olur şu geceyi de rahat uyuyalım artık :smile:


(Enes Boğaz) #28

Emin Bey, şuan telefondayım birazdan bilgisayara geçip programınızı deneyeceğim.

Sağ tık olayı için;
İki kere sağ yapıldığında olabilir.
Program yüklüyse iki kere tıklandığında kaldırabilir, yeniden yükleme yapmak için yüklü olan program normal bir şekilde (sol tık) açıldığında çıkabilir (Yüklü olmasa iki kere tıkladığımızda kuracak çünkü).

Yüklü değilse de, iki sağtık ile kurtulabilir.
İki kere sağtık yapıldığında da uyarı ekranı gelse güzel olur, “Kurmak istiyor musunuz?” şeklinde. Yoksa yanlışlıkla kurma/kaldırma yapılabilir.

Ekleme: Kurdum, gayet güzel olmuş hocam elinize sağlık.

Ayrıca, program yüklendiğinde varsayılan olsun, programa ufak bir ayarlar kısmı ekleyip içinde varsayılanlığı kapatma/açma seçeneğide bulunabilir. Ama yüklendiğinde hele son kullanıcı için direk varsayılan olmasının önemli olduğunu düşünüyorum.
Yoksa “Yükledim, bir işe yaramıyor, çalışmıyor…” gibi söylemler olabilir.

Saygıyla, kolay gelsin!


(Muhammed YILMAZ) #29

Hocam, bunda Error: 100 mesajı veriyor. Error yerine uyarı mesajı verse daha iyi olur bence :slight_smile:

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ debins mintstick_1.3.4_all.deb 
OUT:  "dpkg: hata: dpkg durum veritabanı dosyası başka bir süreç tarafından kullanılıyor\n"
OUT:  "E: /var/lib/dpkg/lock kilidi alınamadı - open (11: Özkaynak geçici olarak kullanılamaz durumda)\nE: Yönetim dizini (/var/lib/dpkg/) kilitlenemiyor, başka bir işlem tarafından kullanılıyor olmasın?\n"
myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$

(Enes Boğaz) #30

Hocam, sadece .deb leri değilde, başka dağıtımlarınınkini de açsa?
Atıyorum .rpm yide kursa olmaz mı?
Eğer olmuyorsa, program (Debins) yüklenirken kurulu değilse aliende yüklensin. Başka türlü dosya açıldığında da .deb´e çevirip kullanılsın.

(Belki abartıyorum ama) Hatta sistemin hangi türü desteklediğini algılayıp (.deb, .rpm, …) açılan dosyayı o türe çevirip kursa olmaz mı?

Saygıyla


(Emin Fedar) #31

Bunlar mümkün sadece birkaç satır değişikliği ile yapılabilir, sonuçta arkada komut çalıştırıyor, rpm içn hangi komutlar gerekiyorsa onu gireriz.

Programın adı da değişmesi lazım tabi :slight_smile:


(Emin Fedar) #32

Çevirici işi de mümkün, aslında çok güzel fikir, ileriki sürümlerde eklenebilir, şimdi çeviri ve yeni özellikler ekliyorum, yükseltme ve sürüm düşürme gibi :slight_smile:


(Muhammed YILMAZ) #33

Bu olsa efsane olmaz mı :smile: Eğer yaparsanız gerçekten çok iyi olur :smile:


(Emin Fedar) #34

Debins 0.20 Yayınlandı.

Yenilikler:

  1. Küçük buglar düzeltildi (Muhammed Yılmaz @edge35 , Kemal Oktay Aydoğan @oktay454’a geri bildirimleri için teşekkürler.)
  2. Türkçe’ye çeviri yapıldı.
  3. Paket Sürüm Yükseltme ve Düşürme eklendi.
  4. Artık .deb dosyaları otomatik olarak Debins ile açılıyor.
  5. Bilinen Hata Kodları yerine Hata ile ilgili bilgi mesajı eklendi.

Bütün fikirlerinizi dikkate almaya çalışıyorum, fikirleriniz harikalar. Destekleriniz için hepinize çok teşekkürler. Pardus’u hep birlikte geliştirmeye devam edelim :+1:

Debins 0.20 Sürüm Kontrolü ile Yükseltme veya Düşürme:

debins3debins4

EK MESAJ: Widgetci, Debins gibi yazılımları sürekli olarak .deb şeklinde github’dan indirip kurmak biraz uğraştırıcı bir iş kabul ediyorum. @edge35 PPA oluşturmam önerisinde bulundu, böylece normal apt upgrade komutu ile debins ve widgetci gibi yazılımları da güncelleyebileceksiniz. Fakat daha önce PPA oluşturma tecrübem olmadı. En kısa sürede öğrenip işinizi kolaylaştırmaya çalışacağım :))


(Muhammed YILMAZ) #36

Öncelikle elinize sağlık :slight_smile:
Yüklü olmayan Kolourpaint’i kurmayı deniyorum. Kurulum başarılı diyor ve hatta başarılı yazısının arkasında butonlar kaldır/tekrar kur olarak değişiyor. Ama program kurulmuyor. Kapatıp bir daha kuruyorum, sonuç aynı.

OUT:  "Daha önce seçili olmayan kolourpaint4:i386 paketi seçiliyor.\n"
OUT:  "(Veritabanı okunuyor ... 287521 dosya veya dizin kurulu durumda.)\n"
OUT:  "Paket açılacak: .../kolourpaint-4-8-2-es-en-ubu.deb ...\n"
OUT:  "Paket açılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...\n"
OUT:  "dpkg: bağımlılık sorunları yüzünden kolourpaint4:i386 paketi yapılandırılamıyor:\n kolourpaint4:i386 şuna bağımlı: kde-runtime.\n kolourpaint4:i386 şuna bağımlı: libkdecore5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkdeui5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkio5 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libkprintutils4 (>= 4:4.8.1).\n kolourpaint4:i386 şuna bağımlı: libqimageblitz4 (>= 1:0.0.4).\n kolourpaint4:i386 şuna bağımlı: libqtcore4 (>= 4:4.7.0~beta1).\n kolourpaint4:i386 şuna bağımlı: libqtgui4 (>= 4:4.8.0).\n kolourpaint4:i386 şuna bağımlı: libstdc++6 (>= 4.1.1).\n\ndpkg: kolourpaint4:i386 paketi işlenirken sorun yaşandı (--install):\n bağımlılık sorunları - yapılandırılmadan bırakılıyor\n"
OUT:  "Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...\n"
OUT:  "Rebuilding /usr/share/applications/bamf-2.index...\n"
OUT:  "Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...\n"
OUT:  "Tetikleyiciler işleniyor: mime-support (3.60) ...\n"
OUT:  "Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...\n"
OUT:  "İşleme sırasında hatalarla karşılaşıldı:\n kolourpaint4:i386\n"
OUT:  "Paket listeleri okunuyor..."
OUT:  "\n"
OUT:  "Bağımlılık ağacı oluşturuluyor..."
OUT:  "\nDurum bilgisi okunuyor..."
OUT:  "\n"
OUT:  "Bağımlılıklar düzeltiliyor..."
OUT:  " Tamamlandı\n"
OUT:  "Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:\n"
OUT:  "  gir1.2-polkit-1.0 gir1.2-udisks-2.0 libglade2-0 python-glade2 python-parted\n"
OUT:  "Bu paketleri kaldırmak için 'apt autoremove' komutunu kullanın.\n"
OUT:  "Aşağıdaki paketler KALDIRILACAK:\n"
OUT:  "  kolourpaint4:i386\n"
OUT:  "0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.\n1 paket tam olarak kurulmayacak ya da kaldırılmayacak.\nBu işlem tamamlandıktan sonra 2.067 kB disk alanı boşalacak.\n"
OUT:  "(Veritabanı okunuyor ... \r"
OUT:  "(Veritabanı okunuyor ... 5%\r(Veritabanı okunuyor ... 10%\r(Veritabanı okunuyor ... 15%\r(Veritabanı okunuyor ... 20%\r(Veritabanı okunuyor ... 25%\r(Veritabanı okunuyor ... 30%\r(Veritabanı okunuyor ... 35%\r"
OUT:  "(Veritabanı okunuyor ... 40%\r(Veritabanı okunuyor ... 45%\r(Veritabanı okunuyor ... 50%\r"
OUT:  "(Veritabanı okunuyor ... 55%\r"
OUT:  "(Veritabanı okunuyor ... 60%\r"
OUT:  "(Veritabanı okunuyor ... 65%\r"
OUT:  "(Veritabanı okunuyor ... 70%\r"
OUT:  "(Veritabanı okunuyor ... 75%\r"
OUT:  "(Veritabanı okunuyor ... 80%\r"
OUT:  "(Veritabanı okunuyor ... 85%\r"
OUT:  "(Veritabanı okunuyor ... 90%\r"
OUT:  "(Veritabanı okunuyor ... 95%\r"
OUT:  "(Veritabanı okunuyor ... 100%\r(Veritabanı okunuyor ... 287712 dosya veya dizin kurulu durumda.)\r\n"
OUT:  "Kaldırılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...\r\n"
OUT:  "Tetikleyiciler işleniyor: mime-support (3.60) ...\r\n"
OUT:  "Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...\r\n"
OUT:  "Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...\r\n"
OUT:  "Rebuilding /usr/share/applications/bamf-2.index...\r\n"
OUT:  "Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...\r\n"

Aynı sorun bağımlılıkları yüklü olan minstick uygulamasında gerçekleşmiyor.


(Emin Fedar) #37

mintstick uygulamasını şu iki komut ile başarıyla terminalden kurabiliyor musunuz?:

sudo dpkg -i mint.deb
sudo apt-get install -f

bu yine aynı sonuçları veriyorsa:

sudo dpkg -i mint.deb
sudo apt-get -i --fix-broken install

Deneyip hangisi oluyorsa ona göre komut çalıştırabiliriz. Debins şuan ilk gönderdiğim 2 satırı uyguluyor arkaplanda.


(Emin Fedar) #38

Ben mi adam gibi paket bulamıyorum dedim 50 Mb’lik Visual Studio Code’u indirdim.

Ve çift tık ile kurabildim şuan sorunsuz çalışıyor.


(Muhammed YILMAZ) #39

İkisi de olmuyor ne yazık ki :sweat_smile:

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ sudo dpkg -i kolourpaint-4-8-2-es-en-ubu.deb 
[sudo] password for myilmaz: 
Daha önce seçili olmayan kolourpaint4:i386 paketi seçiliyor.
(Veritabanı okunuyor ... 287547 dosya veya dizin kurulu durumda.)
Paket açılacak: kolourpaint-4-8-2-es-en-ubu.deb ...
Paket açılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...
dpkg: bağımlılık sorunları yüzünden kolourpaint4:i386 paketi yapılandırılamıyor:
 kolourpaint4:i386 şuna bağımlı: kde-runtime.
 kolourpaint4:i386 şuna bağımlı: libkdecore5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkdeui5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkio5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkprintutils4 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libqimageblitz4 (>= 1:0.0.4).
 kolourpaint4:i386 şuna bağımlı: libqtcore4 (>= 4:4.7.0~beta1).
 kolourpaint4:i386 şuna bağımlı: libqtgui4 (>= 4:4.8.0).
 kolourpaint4:i386 şuna bağımlı: libstdc++6 (>= 4.1.1).

dpkg: kolourpaint4:i386 paketi işlenirken sorun yaşandı (--install):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...
İşleme sırasında hatalarla karşılaşıldı:
 kolourpaint4:i386

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ sudo apt-get install -f
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler KALDIRILACAK:
  kolourpaint4:i386
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 2.067 kB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 287736 dosya veya dizin kurulu durumda.)
Kaldırılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...
Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...



myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ sudo dpkg -i kolourpaint-4-8-2-es-en-ubu.deb 
Daha önce seçili olmayan kolourpaint4:i386 paketi seçiliyor.
(Veritabanı okunuyor ... 287547 dosya veya dizin kurulu durumda.)
Paket açılacak: kolourpaint-4-8-2-es-en-ubu.deb ...
Paket açılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...
dpkg: bağımlılık sorunları yüzünden kolourpaint4:i386 paketi yapılandırılamıyor:
 kolourpaint4:i386 şuna bağımlı: kde-runtime.
 kolourpaint4:i386 şuna bağımlı: libkdecore5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkdeui5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkio5 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libkprintutils4 (>= 4:4.8.1).
 kolourpaint4:i386 şuna bağımlı: libqimageblitz4 (>= 1:0.0.4).
 kolourpaint4:i386 şuna bağımlı: libqtcore4 (>= 4:4.7.0~beta1).
 kolourpaint4:i386 şuna bağımlı: libqtgui4 (>= 4:4.8.0).
 kolourpaint4:i386 şuna bağımlı: libstdc++6 (>= 4.1.1).

dpkg: kolourpaint4:i386 paketi işlenirken sorun yaşandı (--install):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...
İşleme sırasında hatalarla karşılaşıldı:
 kolourpaint4:i386

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ sudo apt-get -i --fix-broken install
E: 'i' Komut satırı seçeneği [-i içinden] diğer seçeneklerle bir arada tanınmıyor.

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$ sudo apt-get --fix-broken install
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler KALDIRILACAK:
  kolourpaint4:i386
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 2.067 kB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 287736 dosya veya dizin kurulu durumda.)
Kaldırılıyor: kolourpaint4:i386 (4:4.8.2-0ubuntu1) ...
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-1) ...
Tetikleyiciler işleniyor: bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-1) ...

myilmaz@pardus:/media/myilmaz/YEDEK/Programs/Linux - Debian$

(Muhammed YILMAZ) #40

Galiba ben garip şeyler buluyorum :sweat_smile: :laughing:


(Emin Fedar) #41

acaba bağımlılıklardaki kütüphanelerin i386 sürümleri depoda mı yok?

sudo dpkg --add-architecture i386

ile 32 bit sürümleri de ekleyin.

Ya da kolourpaint’in 64 bit pakedini indirin.