Lutris kullanımı


(Kemal Oktay Aktoğan) #10

Zaten diğer dağıtımlarda da bu sorun var. Pardus’a özgü değil. Başka dağıtımlarda da bu sorunu yaşıyorlar.


(Yusuf Örtimür) #11

ben tam olarak ne yapacağımı anlamadım. Rica etsem açık bir şekilde anlatır mısınız?


(Faruk GÖLLER) #12

Hocam terminalde sudo thunar yazıp dosya yöneticinizi yetkili kullanıcı olarak açın, sonra usr/share/applications yolunu izleyerek klasör içindeki Lutris dosyasına sağ tıklayın, birlikte aç seçeneğiyle mousepad veya LibreOffice kullanarak açın, açılan metin dosyasında “exec=” ifadesinin karşısındakini silip aşağıda yazanları yapıştırın,

env LC_ALL=C /usr/bin/lutris

ardından dosyayı bu şekilde kaydedip kapatın, sonrasında menuden Lutris’e tıklayıp çalıştırın işleminiz tamamdır.


(Yusuf Örtimür) #13

@Yunusemre @efeyaryukey Allah sizden razı olsun. Giriş yaptı. Artı olarak artık oyunda yükleyebiliyorum. Şu anda LoL yükleniyor.


(Yusuf Örtimür) #14

Şimdi bir sorum birde sorunum var lutris kullanımıyla ilgili;

Sorunum LoL yükledim kurulum bitti ama çalıştır dediğimde tepki vermiyor. Lutrisin altında önce “Playing League of Legends” yazıyor. Biraz bekledikten sonrada “Game has quit” yazıyor. Bu oyunu nasıl oynayabilirim?

Sorum; Lutriste indirdiğimiz wine sürümleri sadece lutriste mi çalışıyor yoksa tüm bilgisayarda da çalışıyor mu?

Ekran%20g%C3%B6r%C3%BCnt%C3%BCs%C3%BC_2019-01-14_07-44-05


(Kemal Oktay Aktoğan) #15

League of Legends’i silip tekrar kurmayı deneyin. Dosyalarında sorun oluşmuşsa açılmayabilir.


(Yusuf Örtimür) #16

Ne yaptıysam olmadı. Oyunu silip tekrar kurdum. Lutrisi silip kurdum. Ama nafile. Ayrıca yeni oyunlarda kurulmuyor. Mesela lutris sitesinden Zula da install diyorum lutris açılıyor başkada bir şey olmuyor. Kurulum ekranı felan gelmiyor.


(Kemal Oktay Aktoğan) #17

Bilgisixarınızın yerelinde wine yüklü mü? Yüklü ise türü(stable-devel-staging) ve sürümü nedir?


(Yusuf Örtimür) #18

Bilgisayarda playonlinuxle birlikte kurulan wine var. Ayrıca lutriste resimde gösterdiğim.


(Kemal Oktay Aktoğan) #19

Burada uyarı yapıyorlar. Gerekli bazı paketlerin sistemde olması gerekiyormuş. Yerel wine sürümü bu açıdan önemli. Yerelde kurulu olan Wine sayesinde gerekli paketler sisteme yüklenmiş oluyor.


(Yusuf Örtimür) #20

Şu anda ne yapmam gerekiyor peki


(Kemal Oktay Aktoğan) #21

Bu konuda anlatıldığı şekilde winehq-staging sürümünü kurunuz.


(Yusuf Örtimür) #23

Değişen bir şey olmadı. :cry:


(Kemal Oktay Aktoğan) #24

sudo apt instal inxi
inxi -F

İkinci komutun çıktısını burada paylaşır mısınız acaba?
(Çıktıyı mesaj olarak yapıştırdıktan sonra seçip CTRL + SHIFT + C yapın.)


(Yusuf Örtimür) #25
yusuf@pardus:~$ inxi -F
System:    Host: pardus Kernel: 4.9.0-8-amd64 x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Pardus GNU/Linux 17 (onyedi)
Machine:   Device: laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0897100000304100000610100
           Mobo: Hewlett-Packard model: 2166 v: 29.42
           UEFI [Legacy]: Insyde v: F.71 date: 03/13/2017
Battery    BAT0: charge: 14.1 Wh 100.0% condition: 14.1/14.1 Wh (100%)
CPU:       Dual core Intel Core i5-4200U (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 2600 MHz 1: 2564 MHz 2: 2566 MHz 3: 1111 MHz
           4: 1206 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           Card-2: NVIDIA GK208M [GeForce GT 740M]
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.03hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 13.0.6
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card-1: Intel Wireless 7260 driver: iwlwifi
           IF: wlo1 state: up mac: 0c:8b:fd:2a:cb:9b
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: eno1 state: down mac: a0:48:1c:11:6f:e5
Drives:    HDD Total Size: 1000.2GB (28.1% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 909G used: 254G (30%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.52GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 1:18 Memory: 827.0/7921.8MB
           Client: Shell (bash) inxi: 2.3.5 
yusuf@pardus:~$

(Kemal Oktay Aktoğan) #26

Grafik yongası için hangi sürücüyü kurdunuz?
Nouveau mu kurulu yoksa Nvidia’nın sahipli sürücüsü mü?


(Yusuf Örtimür) #27

Benim bildiğim Nvidia’nın kendi sürücüsü yüklü. Nasıl bakıcam hangisinin yüklü olduğuna_


(Kemal Oktay Aktoğan) #28

Eğer bumblebee kurulu ise uçbirimde optirun lutris -d komutu ile açmaya çalışın.
Çıktıyı bir önceki gibi kod etiketi içinde paylaşın.


(Yusuf Örtimür) #29
yusuf@pardus:~$ optirun lutris -d
Özet
[  499.969389] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  499.969425] [ERROR]Aborting because fallback start is disabled.

Birde ben uygulamaları optirun ile açarken senin verdiğin komutu değil aşağıdaki komutu kullanıyorum. Çıktısı da şu şekilde.

yusuf@pardus:~$ optirun -vv lutris
Özet
[  542.610780] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  542.611253] [DEBUG]optirun version 3.2.1 starting...
[  542.611274] [DEBUG]Active configuration:
[  542.611289] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  542.611294] [DEBUG] X display: :8
[  542.611305] [DEBUG] LD_LIBRARY_PATH: 
[  542.611314] [DEBUG] Socket path: /var/run/bumblebee.socket
[  542.611318] [DEBUG] Accel/display bridge: auto
[  542.611325] [DEBUG] VGL Compression: proxy
[  542.611330] [DEBUG] VGLrun extra options: 
[  542.611338] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[  542.611411] [DEBUG]Using auto-detected bridge primus
[  543.479685] [INFO]Response: No - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  543.479704] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  543.479711] [DEBUG]Socket closed.
[  543.479727] [ERROR]Aborting because fallback start is disabled.
[  543.479734] [DEBUG]Killing all remaining processes.

Oyunlar yinede çalışmadı.


(Kemal Oktay Aktoğan) #30

Şu kısımlarda sorun var gibi :thinking:
Lutris’e -d parametresini ekleyince daha fazla detay verir.
@kaan hocam sorun grafik sürücülerinde anladığım kadarıyla. Pardus’da Nvidia Prime kurulumu ile ilgili bir anlatım yapabilir misiniz acaba?
Belki doğrudan nvidia grafik yongası ile açılırsa sorun gider gibime geliyor.