Pardus Kurumsal ÇKYS


(ibrahim) #1

Pardus 17.4 ve önceki sürümlerde ckys.jnlp dosyası çalıştırılmak istendiğinde hata vermektedir. jnlp dosyasını aşağıda belirttiğim şekilde düzenlediğimde çalıştırabildim. ekteki dosyanın uzantısını değiştirip test edebilirsiniz.

<?xml version="1.0" encoding="UTF-8"?> <jnlp spec="1.0" xmlns:jfx="http://javafx.com" codebase="https://ckys.saglik.gov.tr:443/forms"> <information> <title>Oracle Forms Services</title> <vendor>Oracle Corporation</vendor> <homepage href="http://www.oracle.com"/> <description>Oracle Forms Services with WebUtil applet launcher.</description> <description kind="short">Oracle Forms Applet with WebUtil</description> </information> <security> <all-permissions/> </security> <update check="always" policy="prompt-run"/> <resources> <!-- Application Resources --> <j2se version="1.7+" href="http://java.sun.com/products/autodl/j2se"/> <jfx:javafx-runtime version="2.2+"/> <jar href="https://ckys.saglik.gov.tr:443/forms/java/frmall.jar" download="eager" main="true" /> <jar href="https://ckys.saglik.gov.tr:443/forms/java/frmwebutil.jar" download="lazy" main="false" /> <extension name="Extensions" href="https://ckys.saglik.gov.tr:443/forms/java/extensions.jnlp"/> </resources> <applet-desc name="Oracle Forms" main-class="oracle.forms.engine.Main" height="1" width="1"> <param name="serverURL" value="/forms/lservlet?ifcfs=https://ckys.saglik.gov.tr:443/forms/frmservlet?config=ckys_jnlp&#38;ifsessid=&#38;acceptLanguage=tr-TR,tr;q=0.8,en-US;q=0.6,en;q=0.4"/> <param name="height" value="500"/> <param name="width" value="650"/> <param name="networkRetries" value="30"/> <param name="separateFrame" value="true"/> <param name="splashScreen" value="https://ckys.saglik.gov.tr:443/tsimyardimURL/sb.gif"/> <param name="background" value="https://ckys.saglik.gov.tr:443/tsimyardimURL/sb.gif"/> <param name="lookAndFeel" value="oracle"/> <param name="colorScheme" value="teal"/> <param name="customColorScheme" value=""/> <param name="serverApp" value=""/> <param name="logo" value="icons/s_icon.gif"/> <param name="imageBase" value="CodeBase"/> <param name="formsMessageListener" value=""/> <param name="recordFileName" value=""/> <param name="EndUserMonitoringEnabled" value="false"/> <param name="EndUserMonitoringURL" value=""/> <param name="heartBeat" value="25"/> <param name="MaxEventWait" value=""/> <param name="allowAlertClipboard" value="true"/> <param name="disableValidateClipboard" value="false"/> <param name="enableJavascriptEvent" value="true"/> <param name="digitSubstitution" value="context"/> <param name="legacy_lifecycle" value="false"/> <param name="JavaScriptBlocksHeartBeat" value="false"/> <param name="highContrast" value="false"/> <param name="disableMDIScrollbars" value=""/> <param name="clientDPI" value=""/> <param name="applet_stop_timeout" value="800"/> <param name="guiMode" value=""/> <param name="idleTimeout" value="12000"/> <param name="ssoLogoutRedirect" value=""/> <param name="ssoMode" value="false"/> <param name="ssoLogout" value="false"/> <param name="logoutTargetURLParamname" value=""/> <param name="mediaBase" value="codebase"/> <param name="webstartRequest" value="true"/> <param name="WebUtilLogging" value="on"/> <param name="WebUtilLoggingDetail" value="normal"/> <param name="WebUtilErrormode" value="console"/> <param name="WebUtilDispatchMonitorInterval" value="5"/> <param name="WebUtilTrustInternal" value="true"/> <param name="WebUtilMaxTransferSize" value="16384"/> </applet-desc> </jnlp>

ckys.txt (3.5 KB)


(Mesut Canatan) #2

İlk fırsatta deneyeceğim İbrahim Bey. Şimdiden teşekkür ediyorum.


(Hüsamettin SÖZ) #3

Merhaba,
Evet dediğiniz gibi ckys.saglik.gov.tr’deki ckys.jnlp hata veriyor bağlanmıyor. Gönderdiğiniz kodları ckys.jnlp ile notepad ile açıp değiştirdiğimde ÇKYS açıldı ve sorunsuz bir şekilde çkys’ye girebildim, işlem yapabildim. Ellerinize sağlık.


(Mesut Canatan) #4

Selamlar İbrahim Bey,
ckys.txt dosyasının uzantısını .jnlp olarak değiştirdim ancak ÇKYS yine de açılmadı. Aşağıdaki ileti çıkıyor. İnşallah yardımınız olur. İyi çalışmalar.


(ibrahim) #5

Sisteminizde openjdk yüklümü diğerinde hata veriyor. Uç birimde java -version yazıp çıktısını paylaşır mısınız?


(Mesut Canatan) #6

java -version çıktısı aşağıdadır İbrahim hocam.
mcanatan-p@mcanatan:~$ java -version
java version “1.8.0_181”
Java™ SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot™ 64-Bit Server VM (build 25.181-b13, mixed mode)
mcanatan-p@mcanatan:~$
Bilgisayara üç dört java versiyonu kurulu. Acaba bundan dolayı olabilir mi?


(ibrahim) #7
sudo update-alternatives --config java

komutuyla openjdk yı seçip dener misiniz? Oracle javada hata veriyor.


(Mesut Canatan) #8

Selamlar İbrahim hocam.
sudo update-alternatives --config java komutunun uçbirimdeki çıktısı aşağıda hocam. Henüç açılmadı hocam.

mcanatan-p@mcanatan:~$ sudo update-alternatives --config java
_[sudo] password for mcanatan-p: _
java alternatifi için 4 seçenek var (/usr/bin/java sağlanıyor).

_ Seçim Yol Öncelik Durum_
------------------------------------------------------------
_ 0 /usr/lib/jvm/jdk1.8.0_201/bin/java 1081 otomatik kip_
_ 1 /usr/lib/jvm/jdk1.8.0_181/bin/java 1081 elle ayarlanmış kip_
_ 2 /usr/lib/jvm/jdk1.8.0_191/bin/java 1081 elle ayarlanmış kip_
* 3 /usr/lib/jvm/jdk1.8.0_201/bin/java 1081 elle ayarlanmış kip
_ 4 /usr/lib/jvm/jre1.8.0_201/bin/java 1081 elle ayarlanmış kip_

_Mevcut seçimi[*] korumak için 'a basın ya da seçiminizin numarasını girin: _
mcanatan-p@mcanatan:~$


(ibrahim) #9

Mesut bey openjdk seçenekler arasında yok kaldırmışsınız demekki. Oracle olanda çalışmıyor maalesef ona bir çözüm yolu arıyorum bulabilirsem buraya ekleyeceğim.


(system) kapatıldı #10

Bu konu son cevaptan 30 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.