Pardus 17.2 sürekli fan çalışması


(Kaan Karaoğlu) #1

Herkese merhabalar,
Fujitsu LIFEBOOK A Serisi dizüstü bilgisayarımda fan sürekli çalışıyor. Konsola htop komutunu verdiğimde root kullanıcısında kworker işleminin %84 işlemci kullandığı (1 çekirdek için) gözüküyor. İnternette yaptığım aramalarda kernel sorunu, bios ayarları, usb bağlı olan cihaz vs. sorunlu olabilir denilmiş. root kullanıcısı ile bu işlemi durdurmaya da çalıştım ancak sonlandıramadım. Bilgiayarıma fare dışında bğlı hiç bir ürün yok, ayrıca şuan 17 güncel sürümünü kullanıyorum.
Yardımlarınız için şimdiden teşekkürler


Sürekli çalışan fan sorunu
(Yunusemre Şentürk) #2

Pardus resmi olarak KDE desteklememektedir, KDE nin şuanki versiyonundan kaynaklı bir çok stabilite ve çeviri problemi var. Son kullanıcıyı meta paket bağımlılık derdinden kurtarmak amacı ile pardus-kde-desktop paketi üretilmiştir. KDE kullanmayın demiyorum, baktınız öntanımlı kurulan sistemi değiştirmeden kullandığınızda verim alamıyorsunuz, DDE ya da XFCE deneyin.

Selamlar.


(Kaan Karaoğlu) #3

Kde ve XFCE masaüstlerinin her ikisinde de aynı sorunla karşılaşıyorum ancak bulduğum bir çözümde

grep . -r /sys/firmware/acpi/interrupts/

komutu ile dökülen listede gpe13 anormal bir değer gösteriyor, superuser olarak

echo "disable" > /sys/firmware/acpi/interrupts/gpe13

komutunu verince ise kworker hemen kapanıyor ve fan kullanılan işlemci miktarı normale dönüyor. Ancak bu çözüm yolu her bilgisayar açıldığında iptal olmakta ve yeniden iki satır da olsa bu kodları girmem gerekiyor. DDE önerinizi bir deneyeyim eğer bir çözüme ulaşabilirsem iletirim.


Pardus 17.3 sürümünde fanın sürekli çalışması
(Yunusemre Şentürk) #4

Güzel bir optimizasyon hardware inizle ilgili bir durum bunu her seferinde sisteme yaptırabilirsiniz hazırladığınız komutu bir bash scriptine dönüştürün ve system autostartına bu scripti çağıracak desktop uzantılı dosyayı koyun /etc/autostart

Kolay gelsin.


(Gökhan Gurbetoğlu) #5