Pardus yüklendi fakat grub gelmiyor


(pars) #1

UEFI tabanlı, windows 10 kurulu bilgisayarıma Pardus XFCE Sürümü nü kurmak istedim. Kurulum kılavuzunda belirtilen her şeyi yaptım. Kurulum tamamlandıktan sonra bilgisayarı yeniden başlattım ama Windows açılıyor.

Ne yapabilirim ?

Yardımcı olursanız sevinirim.


Windows 7 olan bilgisayara Pardus 17.1 kurulum sorunu
(şükrü soylu) #2

kurulumu efi olarak yaptıysanız bios dan değiştirebilirsiniz…


(pars) #3

Bıos tan nereyi değiştireceğim ? Kastınızı anlayamadım :confused:


(pars) #4

UEFI tabanlı bilgisayarlar için kurulumdan önceki BIOS ayarları nasıl olmalı ? (secure boot, fast boot, csm vs)

UEFI tabanlı bilgisayarlar için kurulumdan sonraki BIOS ayarları nasıl olmalı ?


(Hasan YALDIR) #5

Bende de aynı sıkıntı var.
Güvenli Kamu Kurumsal 5 (xfce) i uefi olarak usb diske kurdum çalıştı. Win 10 yanına kurduğumda ise direkt win 10 açılıyor. İşletim sistemi menüsü açılışta gelmiyor.

(NASIL KURDUM: RAM kadar (1.8 gb) swap bölümü oluşturdum, 20 gb / oluşturdum, uefi için win 10 un efi bölümünü gördüğü için ayrıca bir efi bölümü oluşturmadım.Grub sda ya kurulsun seçtim.)


(yavuz) #6

boot bölümünü

Fast Boot > Disable
Launch CSM > Enable
Secure Boot Control > Disable
Uefi Boot > Legacy Boot

şeklinde dener misiniz.


(pars) #7

İlginiz için teşekkür ederim Yavuz Bey,

Bahsettiğiniz ayarların isimleri aynı şekilde yok benim BIOS umda. Bendekiler ve durumları şöyle:

Secure Boot : Disable

Fast Boot : Disable

Launch CSM : Enable (Bunun altında bir sekme var: Launch PXE OpRom > Disable)

USB Configuration :
->Legacy USB Support : Enable
->XHCI Pre-Boot Mode : Enable

Boot Option : Windows Boot Manager (Başka seçenek yok zaten )

Bu durumda yine grub gelmiyor. Windows başlıyor.


(Hasan YALDIR) #8

Aynen denedim olmadı. KDE sürümünde işe yarıyor.

Boot ayarları aynen kaldığında yani UEFI Enable olduğunda;

  1. Canlı sürüm (USB) çalışıyor.
  2. USB ye kurunca (Tek disk tek OS) çalışıyor)
  3. Denemedim ama HDD sadece Pardus XFCE olursa eminim yine çalışır.
  4. İkinci OS olarak kurunca açılışta sanki yokmuş gibi…
    NOT 1: UEFI Disable olunca hiç bir durum çalışmıyor.
    Galiba sorun Grub’un kurulması ile ilgili. Boot-Repair Disk indirdim. İndirme sırasında sıkıntı oldu galiba, disk çalışmadı. Tekrar deneyeceğim.

(Hasan YALDIR) #9

XFCE efi kurulumunda sıkıntı yok. ikinci OS olunca açılmıyor…


(Hasan YALDIR) #10

@pars grub gelmemesinin bios yada bootla alakası yok. Grub düzgün kurulmadığından…
Boot-Repair Disk iSO indir,
USB ye yaz,
bilgisayarı bu USB ile aç
ve bilgisayarın bootunu düzenle.
Bu kadar basit.
Takılırsanız yazınız.


(pars) #11

Haklı olabilirsin Hasan. Ben de disk yapılandırmamda sorun olduğunu düşünüp PC yi yeniden ele almayı düşündüm ama önce senin yöntemi denemek isterim açıkası.

Boot-Repair Disk İSO için tavsiye ettiğin indirme linki var mı?


(yavuz) #12

Merhaba aşağıdaki adımları deneyerek tekrar yükleme yapabilir misiniz? Ayrıca özelden mailinizi verebilirseniz boot repair programını size mail ile yollayabilirim.

Yükleme sırasında bölümleri düzenlemede (Gparted) pardus kurulu bölümü biçimlendirdikten sonra >>> Aygıt > Yeni bölüm oluştur > gpt seçerek yeni dosya sistemini yerleştirdikten sonra diski biçimlendirip yükleme işlemini başlatıp dener misiniz.


(Hasan YALDIR) #13

zaten bir tane var. Ubuntu tabanlı. Arama motorlarında arayınca çıkıyor.


(Samet) #14

Merhaba, usb ile bağladığım harici diskte ubuntu linux kullanıyordum. USB harddisk bağlı olmadığında Direk windows çalışıyordu. Usb disk takılıyken açtığımda group geliyordu. Aynı şekilde pardus yükledim. Direk pardus açılıyor. Grup çıkmıyor. Usb disk takılıdeğilken;

error: no such device: edb88f51- …
grub rescue>

hatası veriyor.

Harici harddisk takılı olmadığında windows un, Takılı ikende pardusun çalışmasını istiyorum. Ne yapmalıyım?


(Samet) #15

Sorunu çözdüm. Grub u yanlışlıkla sda ya kurmuşum. :grin: Tekrar pardusu kurmaya başladım bu sefer grub u sdc1 e kurdum. Pardus usb harddis takılıyken sorunsuz çalışıyor ama window hala çalışmıyordu.

win7 cd si ile başlatıp komut satırına;

bootrec/fixmbr komutunu verdiğimizde windows un ön yükleyicisini onardı.

Şimdi USB harddis takılı değilken window, takılı iken pardus çalışıyor.


(pars) #16

Boot -Repair Disk ile işimi hallettim. Şu an Pardus un XFCE sürümünden yazıyorum. İlginiz için çok teşekkür ederim arkadaşlar.


(yusufgo123) #17

ubuntunun orijinal GRUB’unu kullan yada çare yok.yanlış yapmış olabilirsin.


(Hamza) #18

Pars Kardeşim bendede aynı sorun var. yerel disk c de windows kurulu , d ye pardusu kurdum. (kurulum kılavuzunu takip ederek) her şey güzeldi buraya kadar. kurulum bittikten sonra yeniden başlattım. ama hep windows açılıyo. pardusun kurulu olduğu diski görmüyo bile ? yaptıklarınızı paylaşabilirseniz çok memnun olurum. şimdiden teşekkürler.


(M.Nihat) #20

Merhaba,

pardus son sürüm 3 kez kurdum ama her şeyi denememe rağmen (en azından ben öyle düşünüyorum) grubta sadece pardus geliyor, windows son sürüm yüklüydü ama görünmüyor, biostan UEFI öncelik yapınca direk windows açılıyor pardus yok, legacy yapınca pardus grub geliyor windows yok, sürekli biostan değiştirmek zorun da mı kalacağım, yoksa bir çözümü var mı?


(Cüneyt Ulusoy) #21