Açılışta Initramfs siyah ekranda kalması (çözümüm)


(doğan) #1

Sistemimde 3 adet harddisk ve 2 adet dvd rom mevcut.
Pardus açılışında Initramfs komut satırı yazan siyah ekranda kalıyor ve masaüstü açılmıyordu, araştırmalarım sonucunda bunu şu şekilde çözdüm.

Bilgisayara reset atıp Pardus ilk açılış ekranında e tuşuna basarak linux yazan satırdaki root=/dev/sda1 yazan yerdeki sda1 kısmını sdd1 yaparak sistemimin masaüstünü görmesini sağladım, kalıcı hale getirmek içinse:

terminalden sudo nano /boot/grub/grub.cfg komutu ile grub.cfg dosyasını açtım linux yazan satırdaki root=/dev/sda1 yazan yerdeki sda1 kısmını sdd1 yaparak ctrl+x ile çıkış yapıp e ile kaydederek kalıcı hale getirdim.

Şu an sorunsuz çalışmakta.


(doğan) #2

Bu sabah açarken yine Initramfs ekranı geldi, üstte anlattığım sdd1 yazan yeri sdc1 yapınca düzeldi.

Hiç bir harddiskin yada dvdromların sırasını değiştirmedim, neden kendi kendine böyle olmuş olabilir?


(Adil) #3

ben sda4 yazıyordu tek tek hem sayıları degıstırdım hem a ları d yaptım… ne yapsam da duzelmedi. masaustunu goremıyorum sıyah ekranda kalıyor. dıger baslıkalrdakı uygulamaları da yaptım, tekrar tekrar da yukledım ama çözemedim…


(doğan) #4

sudo fdisk -l yazınca disk bölümleri görünecektir, buradaki disk bölümlerini not ederek açılışta değiştirerek deneyebilirsiniz.


(Davuthan YAMAN) #5

Disklerin bağlantı yollarını kullanmak yerine blok id numaraları ile mount etmeniz, bağlantı yolları değişse bile çalışmasını sağlayacaktır. AŞağıda kendi bilgisayarımın fstab çıktısı bulunuyor.

#<file system> <dir> <type> <options> <dump> <pass>
# /dev/sda7
UUID=e76adfc2-f493-48b1-824f-25ebdde9aaaf / ext4 rw,relatime 0 1

/dev/sdb6

UUID=3be404cb-1f32-42a2-8e84-52bd91cce216 /home ext4 rw,relatime 0 2

Aşağıdaki komut ile kullandığınız bölümlerin uuid adreslerini bulup fstabı güncellerseniz. Birdaha sıkıntı çıkarmaz.

sudo blkid /dev/sda1
/dev/sda1: LABEL=“System Reserved” UUID=“60C86209C861DDB2” TYPE=“ntfs” PARTUUID=“f3f6ce75-01”

bu çıktıtan sadece uuid olan kısmı aldıktan sonra bunu /etc/fstab dosyasında ki uygun yere yazmanız gerekiyor.

Bununla birlikte grub ayarlarınızında buna göre düzenlenmesi gerekiyor. Bunuda aşağıdaki makalede bulabilirsiniz.

https://askubuntu.com/questions/171446/how-to-fix-the-uuid-in-grub-after-restore-from-another-machine

Kolay gelsin.


(Faruk GÖLLER) #6

Bu problemle ben de masaüstü cihazımda karşılaştım. Komutlarla çözmek yerine farklı bir yöntem denedim ve benim cihazımda sorun düzeldi. Anakartımın üzerinde harddiske giden kablo için SATA1 ve SATA2 şeklinde iki soket bulunuyor. Harddiske bağlı olan kablo SATA2 soketindeydi. Kabloyu SATA2’den SATA1’e taktıktan sonra cihazı başlatınca sorunum düzeldi. Bu da bir kenarda yazılı dursun. :smiley: