Ati Radeon x1200 ekran kartı sürücüsü

(Kadir Yükselci) #1

Merhaba, ekran kartı sürücüsünü nasıl güncelleyebileceğim konusunda yardımcı olursanız sevinirim.

Advanced Micro Devices, Inc. [AMD/ATI] RS690 [Radeon X1200]

0 Likes

(Mahmut Elmas) #2

Ati acik aynak suruculer sagladigi icin sistemde ön yuklu geliyor diye biliyorum. Yani herhangi bir surucu yuklemeniz gerekmiyor. (Sanırım)

0 Likes

(Kemal Oktay Aktoğan) #3

Selamün Aleyküm
Bu model ekran kartlarına AMD desteğini 2013 yılında kesti maalesef.
Mevcut radeon sürücüleri ile devam etmekten başka durumumuz yok. :slightly_frowning_face:
AMD’nin açık kaynak sürücü geliştirmediği zamanlardı.
Benim eski bilgisayarımın grafik yongası da ATI Radeon X1500 idi. Aynı sorunu yaşıyordum.
Şuan AMD’nin desteğini kestiği bu grafik yongalarına sadece Microsoft güncelleme veriyor. AMD ile anlaşma yapmıştı diye hatırlıyorum.

1 Like

(Kadir Yükselci) #4

Maalesef daha önce kullandığım Windows 8 ve Windows 10 işletim sistemleri için dahi güncel sürücü yayınlanmadı. Ben farklı forumlarda bulduğum ATI Catalyst 12.11 B11 HotFix 11.09 V6 BETA yazılımı ile sorunumu çözmüştüm. AMD nin resmi sitesinde ATI Catalyst™ 9.3 Proprietary Linux x86_64 Display Driver paylaşılmış ancak güncel linux sürümleri ile uyumlu değil sanırım. Amacım ekran kartının sağladığı monitörüm için ideal 1400x900 çözünürlük yakalamak. Şuan Windows ve Pardus aynı bilgisayarda kurulu. Windows 10 da çözünürlük sorun olmazken Pardus’ta sevimsiz bir hale dönüşüyor. Çözüm bulduğunu söyleyenler olmuş ancak ben yeterli bilgiye sahip değilim. Henüz iki günlük Pardus kullanıcısıyım ve bu sorun yüzünden Pardus’u bırakmak istemiyorum. Lütfen yardım edin.

0 Likes

(Mahmut Elmas) #5

Masaüstünüz Gnome ise eğer.

Gnome değilse

xrandr -s 1400x900

işe yarıyor mu ?

0 Likes

(Kadir Yükselci) #6

“Size 1400x900 not found in available modes” uyarısı çıktı. Mümkün olmadı.

0 Likes

(Mahmut Elmas) #7

xrandr -q

çıktısıyla kullanılabilecek çözünürlükler listelenebilir. Ordan en uygununu seçip uygulayabilirsin yada

bu başlığı bi incele

1 Like

(Kadir Yükselci) #8

Maalesef kodlamaya hakim değilim ne yapacağımı anlamadım. Kusuruma bakmayın lütfen. Ancak şu konuda yazılanları uyguladım ve sonuç alamadım.


Bilgisayarıma uzaktan erişim ile yardımcı olmak isteyen var mı? Ben işin içinden çıkamadım. Yardımcı olursanız çok memnun olurum.

0 Likes

(Kemal Oktay Aktoğan) #10

Selamün Aleyküm
Öncelikle söyleyeyim ki, aşağıdaki çözümleri denemedim.
Xenial depoları Pardus 17 ile daha uyumludur.

https://forum.ubuntu-tr.net/index.php?topic=23261.0

https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa

0 Likes

(Kadir Yükselci) #11
kadir@pardus:~$ sudo add-apt-repository ppa:xorg-edgers/ppa
[sudo] password for kadir: 
 == Xorg packages fresh from git ==

Currently supported releases are Xenial/16.04 and Yakkety/16.10

* WARNING: Do not use this PPA with enabled HWE stack.

Be sure to revert this PPA before doing a release upgrade or the upgrade will not succeed. To revert to official packages, install the ppa-purge package and run "sudo ppa-purge xorg-edgers".

== Important notice ==

This PPA is currently meant to be used as a whole. Please do _not_ individually install packages from it, add it to your sources and let your package manager pull in every update. The packages here build against each other and compile different features based on whats available at build time. Do not assume that because it lets you install a DDX with just the driver and libdrm update that it will work.  These packages are made with scripts that use the the current packages as the base, so some dependencies can be wrong and your package manager will not resolve that for you.  If you want to individually install something from here, grab the source and rebuild it in your current environment instead.

** Please do not publish instructions for how to install from this archive without linking to this page! Anyone using packages from this archive is expected to read this page first and it is recommended to check back occasionally for notice on problems that may arise. **

** Please use ppa-purge to remove this PPA. It is *particularly* recommended to do this before upgrading to a new ubuntu release! **
 More info: https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpbgiqqj7e/pubring.gpg' created
gpg: failed to start the dirmngr '/usr/bin/dirmngr': Böyle bir dosya ya da dizin yok
gpg: connecting dirmngr at '/tmp/tmpbgiqqj7e/S.dirmngr' failed: Böyle bir dosya ya da dizin yok
gpg: keyserver receive failed: No dirmngr
kadir@pardus:~$ sudo apt-get update
Aynı:  1 http://depo.pardus.org.tr/pardus onyedi InRelease
Yoksay:2 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan InRelease        
Aynı:  3 http://depo.pardus.org.tr/guvenlik onyedi InRelease                   
Yoksay:4 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan Release           
Yoksay:5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages 
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Yoksay:5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Yoksay:5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Yoksay:5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Yoksay:5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Hata:  5 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main i386 Packages
  404  Not Found
Yoksay:6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main all Packages
Yoksay:7 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main amd64 Packages
Yoksay:8 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr
Yoksay:9 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-tr_TR
Yoksay:10 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan/main Translation-en
Paket listeleri okunuyor... Bitti
N: '/etc/apt/sources.list.d/' dizinindeki 'xorg-edgers-ubuntu-ppa-eoan.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
W: 'http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu eoan Release' deposunda Release dosyası yok.
N: Böyle bir depodan gelen verilerin kaynağı doğrulanamayacağı için bu deponun kullanımı olası tehlike arz etmektedir.
N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
E: http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/dists/eoan/main/binary-i386/Packages alınamadı 404  Not Found
E: Bazı indeks dosyaları indirilemedi. Bu dosyalar yok sayıldılar ya da önceki sürümleri kullanıldı.

Durum bu şekilde ancak bir sonuç elde edemedim.

0 Likes

(Kemal Oktay Aktoğan) #12

Depo imzası eklenirken sorun oluşmuş. Şu komutu çalıştırıp dener misiniz?

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8844C542

0 Likes

(Kadir Yükselci) #13
kadir@pardus:~$ sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8844C542
[sudo] password for kadir: 
Executing: /tmp/apt-key-gpghome.pLBR9JRjKl/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8844C542
gpg: failed to start the dirmngr '/usr/bin/dirmngr': Böyle bir dosya ya da dizin yok
gpg: connecting dirmngr at '/tmp/apt-key-gpghome.pLBR9JRjKl/S.dirmngr' failed: Böyle bir dosya ya da dizin yok
gpg: keyserver receive failed: No dirmngr

Ayrıca Pardus mağaza zaman zaman sorun çıkarmaya başladı o komutlardan sonra.

0 Likes

(Faruk GÖLLER) #14

Aşağıdaki komutu uyguladıktan sonra daha önce bahsedilenleri uygulayınız lütfen.

sudo apt-get install dirmngr

0 Likes

(Kadir Yükselci) #16

Bu kodu uyguladıktan sonra yukarıdaki hatalar oluşmadı ama ekran çözünürlüğü maalesef değişmedi.


AMD nin resmi sitesinde ATI Catalyst™ 9.3 Proprietary Linux x86_64 Display Driver paylaşılmış. Bu dosya .run uzantılı ve ben bunu sh ati-driver-installer-9-3-x86.x86_64.run olarak uçbirimde çalıştırınca

kadir@pardus:~/İndirilenler$ sh ati-driver-installer-9-3-x86.x86_64.run
Created directory fglrx-install.JTDKuA
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib::none:4.9.0-9-amd64; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.JTDKuA

sonucuyla karşılaşıyorum. Ben de Pardus 17.5 XFCE sürümü var. Paket yöneticisine baktım. X.org 7.8 sürüm paket yüklü. X.org 7.4 sürümünü yükleyebilirsem sorun çözülecek sanırım. Çünkü AMD nin sitesinde şu şekilde bilgi var:

Automated installer and Display Drivers for X.Org 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, 7.3, or 7.4

Ancak X.org 7.4 sürümünü nasıl yükleyeceğimi bilmiyorum.
Windowsta sürücü güncel değilse bile yüklemeye zorlayabiliyorduk. Pardusta ati-driver-installer-9-3-x86.x86_64.run dosyasını kurmaya zorlayamaz mıyız? Bir yolu var mı acaba?


X.org 7.4 depoyu buldum. https://www.x.org/releases/X11R7.4/src/

Pardus’a yükleyebilirsem sorun çözülür mü?

0 Likes