Cisco PaketTracer 7.2'yi Pardus 19.5'de Kurulum Sonrası çalışmıyor

Merhaba Cisco Pakettracer 8’i kurmaya çalıştım ama bağımlılıkları konusunda sıkıntı yaşadım. Daha düşük sürüm olan 7.2 versiyonunu /opt/pt/ altına kurdum. Pakettracer’ı çalıştırdığımda aşağıdaki gibi konsol çıktısı alıyorum.

nahita@nahita:/opt/pt/bin$ ./PacketTracer7 
./PacketTracer7: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Ubuntu depolarından “libpng12-0_1.2.50-2+deb8u3_amd64.deb” paketini indirip kurmaya çalıştığımda aşağıdaki hatayı alıyorum.

nahita@nahita:~/İndirilenler$ sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb [sudo] password for nahita: 
(Veritabanı okunuyor ... 303726 dosya veya dizin kurulu durumda.)
Paket açılacak: libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
Paket açılıyor: libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: libpng12-0_1.2.50-2+deb8u3_amd64.deb arşivi işlenirken sorun yaşandı (--install):
 '/usr/lib/x86_64-linux-gnu/libpng12.so.0' dosyasının yeni sürümü kurulamadı: Böyle bir dosya ya da dizin yok
İşleme sırasında hatalarla karşılaşıldı:
 libpng12-0_1.2.50-2+deb8u3_amd64.deb

Aşağıdaki şekilde kontrol ettiğimde sistemde libpng’nin daha üst versiyonu olduğunu gördüm. Geriye dönük olarak desteklemesi gerekmiyor mu bu kütüphanenin.

sudo dpkg -l | grep "libpng"
,ii  libpng16-16:amd64                       1.6.36-6   

Pardus 19.4 de denedim.
Download Cisco Packet Tracer 8 (Latest version 2021) linkinden 8 sürümünü indirdim ve aşağıdaki komutlar ile yükledim sorunsuz yüklendi:

sudo dpkg -i PacketTracer_800_amd64_build212_final.deb 
sudo apt -f install
1 Beğeni

Merhaba cevabınızdan sonra versiyon 8’i tekrar denedim yükleniyor ama çalışmıyor. 7.2 versionda da öyle. /opt7pt/bin dizini altında ./Pakettracer komutu verdiğimde aşağıdaki şekilde çıktı alıyorum.

root@nahita:/opt/pt/bin# ./PacketTracer 
./PacketTracer: error while loading shared libraries: libQt5QmlModels.so.5: cannot open shared object file: No such file or directory

LLD komutu ile bağımlıklılara baktığımda şu çıktıyı alıyorum.

root@nahita:~# ldd /opt/pt/bin/PacketTracer | grep no
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/pt/bin/PacketTracer)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /opt/pt/bin/PacketTracer)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /opt/pt/bin/PacketTracer)
	libQt5QmlModels.so.5 => not found

Bu çıktıdaki bağımlılıkları yüklemeye çalıştığım zaman depo da olmayanların dep paketlerini indirip kurmaya çalıştığımda başka bağımlıkları var ve bağımlılıklarında bağımlılıkları oluyor ve bazıları bağımlılığının daha güncel sürümünü istiyor derken silsile devam edip gidiyor ve çıkmaza giriyorum.

Sıfır kurulu Pardus 19.5 de sürüm 8i denedim. Kurulumda ve çalışmasında herhangi bir problem çıkartmıyor.

1 Beğeni

Şu an sistemi yeniden kurma şansım yok. Yukarıda eksik dediği pakatleri apt-get ile kurmaya çalıştım paketin olmadığı bilgisini aldım. Nasıl bir çözüm üretebiliriz.

Evet arayüzü çalıştırmak için birçok bağımlılık gerektiriyormuş. Ben sudo ./packettracer şeklinde çalıştırıyordum.

Bu bağımlıkları nasıl yükleyebilirim. QT5 ile ilgili bağımlıkların çoğunu yükledim ama özellikle c/c++ derleyecisi sanırım sistemde yüklü olduğu halde hata veriyor.

nahita@nahita:/opt/pt/bin$ ./PacketTracer 
./PacketTracer: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./PacketTracer)
./PacketTracer: /lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by ./PacketTracer)
./PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by ./PacketTracer)
./PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /lib/x86_64-linux-gnu/libQt5QmlModels.so.5)

sudo apt install libqt5webkit5 libqt5multimedia5 libqt5printsupport5 libqt5script5 libqt5scripttools5 libqt5webenginewidgets5 libqt5webenginecore5 libqt5websockets5 

Yukarıdaki paketler yükleniyor bir çok bağımlılık gideriliyor. Ama libQt5QmlModels paketi sorunlu.

1 Beğeni

sudo apt install qtdeclarative5-dev libqt5qml5 libqt5core5a

Şunu bi denesene bunlarda var galiba o paketin biri.

maalesef değişen bir şey olmadı. Sanırım bu sorun çıkaran paketin ayrı bir kaynak kodu yok. Tekrar derlenebilir mi acaba diye düşündüm ama .

Sorunlu paketi buradan indirip programı çalıştırmayı yeniden deneyebilir misiniz?

http://ftp.filearena.net/pub/ubuntu/pool/universe/q/qtdeclarative-opensource-src/libqt5qmlmodels5_5.14.2+dfsg-3ubuntu1_amd64.deb

merhaba daha önce denemiştim aslında. Yinede tekrar kurdum arkasından da sudo apt install -f de dedidim ama değişen bir şey yok.

sudo dpkg -i libqt5qmlmodels5_5.14.2+dfsg-3ubuntu1_amd64.deb 
[sudo] password for nahit: 
Daha önce seçili olmayan libqt5qmlmodels5:amd64 paketi seçiliyor.
(Veritabanı okunuyor ... 320253 dosya veya dizin kurulu durumda.)
Paket açılacak: libqt5qmlmodels5_5.14.2+dfsg-3ubuntu1_amd64.deb ...
Paket açılıyor: libqt5qmlmodels5:amd64 (5.14.2+dfsg-3ubuntu1) ...
dpkg: bağımlılık sorunları yüzünden libqt5qmlmodels5:amd64 paketi yapılandırılamıyor:
 libqt5qmlmodels5:amd64 şuna bağımlı: libqt5core5a (>= 5.14.1), ama:
  Sistemde mevcut olan libqt5core5a:amd64 paketinin sürümü 5.11.3+dfsg1-1+deb10u4.
 libqt5qmlmodels5:amd64 şuna bağımlı: libqt5qml5 (>= 5.14.1), ama:
  Sistemde mevcut olan libqt5qml5:amd64 paketinin sürümü 5.11.3-4.
 libqt5qmlmodels5:amd64 şuna bağımlı: qtbase-abi-5-14-2, ama:
  'qtbase-abi-5-14-2' paketi kurulu değil.
 libqt5qmlmodels5:amd64 şuna bağımlı: qtdeclarative-abi-5-14-2, ama:
  'qtdeclarative-abi-5-14-2' paketi kurulu değil.

dpkg: libqt5qmlmodels5:amd64 paketi işlenirken sorun yaşandı (--install):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: libc-bin (2.28-10) ...
İşleme sırasında hatalarla karşılaşıldı:
 libqt5qmlmodels5:amd64

Buna dependency hell deniyor galiba. Bunun çözümü var mı bilmiyorum o bağımlılığı yazıyorsun indir diyorsun, o da 500 tane daha bağımlılık çıkartıyor. Ben çözememiştim.

1 Beğeni