"Dependency is not satisfiable:libicu48" hatası

Merhabalar, ETAP 19 a Antropi Teach yüklemeye çalışırken “Dependency is not satisfiable:libicu48” hatası alıyorum. GDebi ile denedim olmadı, uçbirimden denedim olmadı. Nasıl çözebilirim yardımcı olabilirmisiniz?

Buradan antropi teach indirin ve bir dizine açın. (Linki buradan buldum: fatih projesi antropi kurulumu – Yeni Başlayanlar – Archman GNU/Linux)

Daha sonra http://launchpadlibrarian.net/91039680/libicu48_4.8.1.1-3_amd64.deb ve http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb adreslerinden deb dosyalarını indirin ve arşiv yöneticisi ile açın. Arşivlerin içindeki data.tar.gz dosyalarını açın ve ./usr/lib/ ve ./lib/ içerisindeki dosyaları antropi teach içine atın.

suite.sh dosyasını terminalden çalıştırdığınızda program açılacaktır.

1 Beğeni

Ali Rıza hocam çok teşekkür ederim söylediğiniz şekilde antropi’yi çalıştırdım sorun yok. Antropi bu şekilde çalışıyor. Masaüstüne kısayolunu alayım öyle çalıştırayım dedim olmadı. Bunun bir yolu varmıdır?

Ama aslında ben bu programı Etap 19’a kurmayı da denedim. Bağımlılık hatası veren dosya paketlerini sırasıyla indirip yükledim. libicu48… paketini yükledim gstreamer0.10-plugin-good paketini istedi onuda yükledim libgstreamer-plugins-base0.10 paketini istedi onuda indirip yükledim daha sonra lippng12-0 paketini istedi onuda indirdim ancak onu yüklerken hata veriyor. o hatayıda bir türlü aşamadım.

dpkg: /home/etapadmin/İndirilenler/libpng12-0_1.2.50-2+deb8u3_amd64.deb arşivi işlenirken sorun yaşandı (--install):
 '/usr/lib/x86_64-linux-gnu/libpng12.so.0' dosyasının yeni sürümü kurulamadı: Böyle bir dosya ya da dizin yok
İşleme sırasında hatalarla karşılaşıldı:
 /home/etapadmin/İndirilenler/libpng12-0_1.2.50-2+deb8u3_amd64.deb

yukarıdaki hata da istenen libpng12.so.0 dosyasını /usr/lib/x86_64-linux-gnu içerisine kopyalıyorum tekrar kur diyorum yine aynı Böyle bir dosya ya da dizin yok hatasını veriyor. Baktım /usr/lib/x86_64-linux-gnu klasöründe libpng16.so.16 dosyası var, bu dosya olduğu için libpng12.so.0 dosyasını kabul etmiyor ve her yüklemeye çalıştığımda siliyor.

Bunu kurmanın bir yolu yokmudur? Yoksa önceki mesajınızda söylediğiniz yöntemle çalılştırdığım suite.sh dosyasının kısayolunu masaüstüne alabilirmiyim?

uygulama eski olduğu için ve yeni sürümde düzgün çalışmadığı için paketleri kursanız bile açılamaz. Fakat biz so dosyalarını indirip içine attığımızda eski sürümlerini içine kopyaladığımız için sorun olmuyor.

Kısayol atmak için kullandığınız desktop uzantılı dosyanın içeriğini buraya gönderme imkanınız var mı?

hocam maalesef herhangi bir .desktop uzantılı dosyam yok, oluşturamadım.
suite.sh dosyasını desktop uzantılı hale getirebilirmiyiz? Yada çalıştırılabilir bir kısayol oluşturabilirmiyiz?

[Desktop Entry]
Version=1.0
Name=Antropy
Comment=white board
Categories=Education;
Icon=simge-konumu-yada-adı
Exec=çalıştırılacak-dosyanın-tam-yolu
Type=Application

Icon ve Exec kısmını düzeltip ~/.local/share/applications/ içerisine atın

1 Beğeni

Çok teşekkür ederim Ali Rıza hocam, diğer kullanıcı izinlerini de ayarlayınca tüm kullanıcılarda Antropi gayet güzel çalışıyor. Emekleriniz için tekrar teşekkür ederim.

Bu konu son cevaptan 30 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.