Depo ekleme sorunu

merhaba.
bir kamu kurumu olarak pardus 17.5 sürümünü kurduk. kuruma özel imajı yükledik.
ancak mevcut depoda php 7.0 sürümü var. benim en az 7.2 sürümünü kurmam gerekiyor.
https://ayesh.me/Ubuntu-PHP-7.2 bu siteye göre php 7.2 sürümünü kurmaya çalışıyorum.
ancak
sudo add-apt-repository ppa:ondrej/php
depoyu eklemiyor
çıktısı şu şekilde
`LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php
More info: https://launchpad.net/~ondrej/+archive/ubuntu/php
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmplhwr51f4/pubring.gpg' created
gpg: /tmp/tmplhwr51f4/trustdb.gpg: trustdb created
gpg: key 4F4EA0AAE5267A6C: public key "Launchpad PPA for Ondřej Surý" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.`

Selamün Aleyküm
Sorunuza doğrudan bir cevap değil lakin Pardus 19 kurarsanız depodaki sürüm 7.3 olduğu için sorunsuz bir şekilde çalışabilirsiniz.

aleykum selam.
19 sürümünü kursak bile kurumun pardusa özel imajını yükleyince yine 17.5 oluyor.

xampp kurabiliyorum. php 7.4 kurulmuş oluyor, ama bu sefer http://localhost girmeye çalışınca hiç bir tepki vermiyor. hata da vermiyor. bağlanıyor diyor dönüp duruyor.
yani 19 kurmak çözüm değil.

© 2020 TÜBİTAK