Firebird 2.1 kurulumu


(Sadik Acar) #1

arkadaşlar firebird 2.1 kurmak istiyorum
aşağıdaki linkden 64 bit olan amd64.tar.gz dosyayı indirdim klasör açıldı içinde “install.sh” diye dosyayı kullanarak kurmak istiyorum aynı yerde terminal açıp “sh install.sh” diyerek yüklemeye çalıştıgımda hata alıyorum

sadikacar60@pardus:~/İndirilenler/FirebirdCS-2.1.7.18553-0.amd64$ sh install.sh

— Stop ----------------------------------------------

You need to be 'root' user to do this change

sorun ne olabilir acaba saygılarımla

download linki:

https://sourceforge.net/projects/firebird/files/firebird-linux-amd64/2.1.7-Release/FirebirdCS-2.1.7.18553-0.amd64.tar.gz/download


(Mehmet AKDEMİR) #2

“Bu değişikliği yapmak için ‘root’ kullanıcısı olmanız gerekir.” der google translate. Komutun başına
sudo komutunu ekleyin.


(Sadik Acar) #3

evet hocam denemiştim olmamıştı ama denemeler devam ederken oldu çalıştı ama bu sefer aşağıdaki hatayı alıyorum.

elle klasörmü oluşturmalıyım saygılarımla

sadikacar60@pardus:~/İndirilenler/FirebirdCS-2.1.7.18553-0.amd64$ sudo sh install.sh
[sudo] password for sadikacar60:

Firebird classic 2.1.7.18553-0.amd64 Installation

Press Enter to start installation or ^C to abort
Extracting install data
grep: /etc/xinetd.d/*: Böyle bir dosya ya da dizin yok

— Warning ----------------------------------------------
The installation target directory: /opt/firebird
Already contains a prior installation of InterBase/Firebird.
This and files found in /usr/include and /usr/lib64 will be
archived in the file : /opt/firebird_20190211_2002.tar.gz

Press return to continue or ^C to abort

birde hangi programı indireceğim neye göre seçiyoruz acaba 64 bit pardus kurulu


(Enes Boğaz) #4

Bana kalırsa ilk bölmedeki ikinci seçeneği kullanın. Çünkü alt taraftaki bölmede Superserver yazıyor, (o zaman sunucular içindir diye düşündüm.) İndirince eccük el deıirmeniz gerekecek.
Dosya indikten sonra uçbirimi açıp Alien’i yükleyelim. Yüklüyse boş verin ve ikinci (2.) adıma geçiniz.

  1. Uçbirime sudo apt install alien yazınız ve şifrenizi girip indirin. (Belki mağazada vardır. Eğer varsa uçbirime gerek yok.)

  2. Sonra dosyanızın bulunduğu dizine sudo alien -d dosyaismi.tar.gz yazıp yollayın.
    (dosyaismi.tar.gz’li yeri değiştermeyi unutmayınız.)

  3. Dosyanın bulunduğu dizinde bir .deb dosyası beliriciktir.

  4. Gdebi, Debins gibi yazılım yada komutlar vasıtasıyla .deb’i kurabilirsiniz.
    Gdebi’yi mağazada bulabilirsiniz.
    Debins’i ise Bkz. bağlantı
    Komutla ise sudo dpkg -i dosyaismi.deb şeklinde kurabilirsiniz.

Saygıyla


(Sadik Acar) #5

çok teşekkürler hocam aşagıdaki aşamaya kadar ilerledik
komut satırından firebird server kurulmuş mu devredemi kontrol edebilirmiyiz

saygılarımla

adikacar60@pardus:~/İndirilenler/FirebirdCS-2.1.7.18553-0.amd64$ sudo dpkg -i firebird217_1-2_all.deb
Daha önce seçili olmayan firebird217 paketi seçiliyor.
(Veritabanı okunuyor … 225003 dosya veya dizin kurulu durumda.)
Paket açılacak: firebird217_1-2_all.deb …
Paket açılıyor: firebird217 (1-2) …
Ayarlanıyor: firebird217 (1-2) …
sadikacar60@pardus:~/İndirilenler/FirebirdCS-2.1.7.18553-0.amd64$ service firebird status
Unit firebird.service could not be found.
sadikacar60@pardus:~/İndirilenler/FirebirdCS-2.1.7.18553-0.amd64$


(Enes Boğaz) #6

Programı fazla bilmiyorum ama konsola fireb yazın ve (göndermeden) tab tuşuna basın. Eğer firebird diye yazdığınızı tamamlıyorsa olmuştur tahminimce. Birde arayüzü varmış. İsterseniz arayüzüde yükleyin çünkü eğer Firebird yüklüyse arayüzde çalışır.
Bkz. Bağlantı buradan indirebilirsiniz.
Fakat nasıl kullanıldığını biliyorsanız kullanmaya çalışın kurulduysa çalışır. (Fazla mı düz mantık oldu? :slight_smile:)

Saygıyla


(Enes Boğaz) #7

Bağımlılıklar için de sudo apt -f install yazabilirsiniz.


(Sadik Acar) #8

msql de

mysql --version
service mysqld status
yaptığınızda mysql in durumu hakkında bilği edinebildiğimizi öğrendim

benzer bir konsol komutu varmı firebird devrede mi değil mi kontrol etmek için
ben aradım ama bulamadım.

saygılarımla
DBeaver ile veritabanına bağlanmaya çalışıyorum


(Enes Boğaz) #9

Maâlesef bilmeyorum hocam ama gönderdiğiniz fotoıraftaki Synaptic Paket Yöneticisine göre kurulmuş gösteriyor.


(Ali KOCA) #10

Merhabalar;
Veritabanı sunucusunu depodan kursanız olmuyor mu?

$ sudo apt-get update
$ sudo apt-get install firebird3.0-server

Kurulumdan sonra da yüklenen paketleri görebilirsiniz:

$ sudo dpkg-query -l | grep firebird-server*

Selamlar.


(Sadik Acar) #11

hocam depoda yüklü olan firebird ü kaldırdım

verdiğiniz komutları uyguladım dosyalar kuruldu sorun yok son maddeyi uyguladım

sudo dpkg-query -l | grep firebird-server*

herhangi bir sonuç alamadım
firebird yükledik ama gerçekten yükledik ve devredemi? mysqlde olduğu gibi “mysql --versiyon” komutuyla server hakkında bilği alabiliyorduk.
firebirdü devredemi nasıl kontrol edeceğiz veya konsoldan firbird durdur veya
çalıştır gibi komutlar yok mu acaba.

saygılar sunarım.

sadikacar60@pardus:~$ sudo apt-get update
Aynı: 1 http://depo.pardus.org.tr/pardus onyedi InRelease
Aynı: 2 http://depo.pardus.org.tr/guvenlik onyedi InRelease
Aynı: 3 http://linux.teamviewer.com/deb stable InRelease
Paket listeleri okunuyor… Bitti
sadikacar60@pardus:~$ sudo apt-get install firebird-dev
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
libaec0 libarmadillo7 libarpack2 libctemplate3 libdap23 libdapclient6v5
libdapserver7v5 libepsilon1 libfreexl1 libgeos-3.5.1 libgeos-c1v5
libgeotiff2 libgtkmm-2.4-1v5 libhdf4-0-alt libhdf5-100 libjson-c3
libkmlbase1 libkmlconvenience1 libkmldom1 libkmlengine1 libkmlregionator1
libkmlxsd1 libnetcdf11 libodbc1 libogdi3.2 libproj12 libqhull7
libspatialite7 libsuperlu5 libsz2 libtinyxml2.6.2v5 liburiparser1
libvsqlitepp3v5 libxerces-c3.1 libzip4 odbcinst odbcinst1debian2 proj-bin
proj-data python-cffi-backend python-cryptography python-enum34 python-idna
python-ipaddress python-paramiko python-pexpect python-pkg-resources
python-ptyprocess python-pyasn1 python-pyodbc python-pysqlite2
python-setuptools python-six
Bu paketleri kaldırmak için ‘sudo apt autoremove’ komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
firebird3.0-common firebird3.0-common-doc libfbclient2 libib-util
libtommath1
Önerilen paketler:
firebird3.0-examples
Aşağıdaki YENİ paketler kurulacak:
firebird-dev firebird3.0-common firebird3.0-common-doc libfbclient2
libib-util libtommath1
0 paket yükseltilecek, 6 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
614 kB/730 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 3.626 kB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
İndir: 1 http://depo.pardus.org.tr/pardus onyedi/main amd64 libtommath1 amd64 1.0-4 [56,0 kB]
İndir: 2 http://depo.pardus.org.tr/pardus onyedi/main amd64 firebird3.0-common-doc all 3.0.1.32609.ds4-14 [36,3 kB]
İndir: 3 http://depo.pardus.org.tr/pardus onyedi/main amd64 firebird3.0-common all 3.0.1.32609.ds4-14 [13,7 kB]
İndir: 4 http://depo.pardus.org.tr/pardus onyedi/main amd64 libfbclient2 amd64 3.0.1.32609.ds4-14 [505 kB]
İndir: 5 http://depo.pardus.org.tr/pardus onyedi/main amd64 libib-util amd64 3.0.1.32609.ds4-14 [3.346 B]
3 sn.'de 614 kB alındı (166 kB/s)
Daha önce seçili olmayan libtommath1:amd64 paketi seçiliyor.
(Veritabanı okunuyor … 227326 dosya veya dizin kurulu durumda.)
Paket açılacak: …/0-libtommath1_1.0-4_amd64.deb …
Paket açılıyor: libtommath1:amd64 (1.0-4) …
Daha önce seçili olmayan firebird3.0-common-doc paketi seçiliyor.
Paket açılacak: …/1-firebird3.0-common-doc_3.0.1.32609.ds4-14_all.deb …
Paket açılıyor: firebird3.0-common-doc (3.0.1.32609.ds4-14) …
Daha önce seçili olmayan firebird3.0-common paketi seçiliyor.
Paket açılacak: …/2-firebird3.0-common_3.0.1.32609.ds4-14_all.deb …
Paket açılıyor: firebird3.0-common (3.0.1.32609.ds4-14) …
Daha önce seçili olmayan libfbclient2:amd64 paketi seçiliyor.
Paket açılacak: …/3-libfbclient2_3.0.1.32609.ds4-14_amd64.deb …
Paket açılıyor: libfbclient2:amd64 (3.0.1.32609.ds4-14) …
Daha önce seçili olmayan libib-util:amd64 paketi seçiliyor.
Paket açılacak: …/4-libib-util_3.0.1.32609.ds4-14_amd64.deb …
Paket açılıyor: libib-util:amd64 (3.0.1.32609.ds4-14) …
Daha önce seçili olmayan firebird-dev paketi seçiliyor.
Paket açılacak: …/5-firebird-dev_3.0.1.32609.ds4-14_amd64.deb …
Paket açılıyor: firebird-dev (3.0.1.32609.ds4-14) …
Ayarlanıyor: libtommath1:amd64 (1.0-4) …
Ayarlanıyor: firebird3.0-common-doc (3.0.1.32609.ds4-14) …
Ayarlanıyor: firebird3.0-common (3.0.1.32609.ds4-14) …
Ayarlanıyor: libfbclient2:amd64 (3.0.1.32609.ds4-14) …
Ayarlanıyor: libib-util:amd64 (3.0.1.32609.ds4-14) …
Tetikleyiciler işleniyor: libc-bin (2.24-11+deb9u3) …
Tetikleyiciler işleniyor: man-db (2.7.6.1-2) …
Ayarlanıyor: firebird-dev (3.0.1.32609.ds4-14) …
sadikacar60@pardus:~$ sudo dpkg-query -l | grep firebird-server*
sadikacar60@pardus:~$


(Ali KOCA) #12

Merhabalar;
Yukarıda sehven dev paketinin ismi geçmiş yukarıda düzelttim. Kurulum yapılırken şifreyi soruyor.
Servisi kontrol etmek için aşağıdaki komutları kullanabilirsiniz:

$ sudo systemctl status firebird3.0 service
$ sudo systemctl restart firebird3.0 service
$ sudo systemctl start firebird3.0 service
$ sudo systemctl stop firebird3.0 service

Selamlar.


(Enes Boğaz) #13

Haklısınız hocam,
İndirmek için resmi sunucuları kullanmak daha uygun olur sanırım.


(Sadik Acar) #14

depodan 3.0 kurdum sonra kaldırıp mauel 2.1 kurdum sonra onuda kaldırıp depodan 3.0
kurdum. benim ihtiyacım

sudo systemctl status firebird3.0 service

komutuydu çıktısını aşagıda aldım artık firebird kurulu devrede oldugunu anlamış oldum
pardus hizmetler stabil çalışmıyor anladığım kadarıyla yanıltıcı kodla daha emin oldum.
çok teşekkür ederim saygıar sunarım

sadikacar60@pardus:~$ sudo systemctl status firebird3.0 service
[sudo] password for sadikacar60:
Unit service.service could not be found.
● firebird3.0.service - Firebird Database Server ( SuperServer )
Loaded: loaded (/lib/systemd/system/firebird3.0.service; enabled; vendor pres
Active: inactive (dead)
lines 1-4/4 (END)


(Cüneyt Ulusoy) kapatıldı #15