Firefox and Thunderbird by default

Hi !
On Pardus 19.5, I checked in Firefox/Thunderbird preferences that they are default and in “favorite apps” also.
I use Thunderbird for read RSS flux.
The links (mail and RSS) I click in Thunderbird opened in Firefox.
But at some point, don’t opened in Firefox.
In addition Firefox changes status to “is no longer my default browser”.

I have already tried to delete Evolution but without result.

_Do you think it’s a “hidden” browser make conflict ?
exo-open --launch WebBrowser %u ?
Browser sensible debian ?

_ Do you think RSS flux make conflict ?

Hi, I suggest you to use Pardus 21. On the other hand, you need to select Firefox as a default program, if RSS gives you problem, just set it to thunderbird and don’t care about Firefox’s default browser error. Because Firefox in Pardus 19 is so old.

Hi ! Suleyman Poyraz
Yes indeed I should switch to Pardus 21.
But Pardus 19 is supported up to May 2023, he still does the job well.

Hello, what do you mean by "Firefox changes status to “is no longer my default browser””? Can you set it to “set as default”? If so is it rolling back your setting? What do you have when you enter Settings > Default Applications? Please clean Firefox and Thunderbird.

  • Clean history
  • Disconnect from the net permanently
  • Reboot your device
  • While the programs are closed, using your file manager enter /home/USERNAME
  • Show hidden files at the menu, enter .mozilla/firefox
  • Rename and delete the folders which were automatically created (Ex: 0x1y3z.default)
  • Rename and delete install.ini and profiles.ini
  • Clean your system using a cleaner software or delete your trash content.
  • Connect to the network

If this works fine do the same for Thunderbird if you don’t have important things saved (Ex: Pop3 mails)

It’s always recommended to use the newest version.

Hi ! can.
I follow and do exactly your process for clean Firefox and Thunderbird.
Without check/change anything, I can see…

Thunderbird and Firefox are closed.
_I open Firefox (its preferences indicate is the default browser).
_I close Firefox.
_I open Thunderbird.
_I click a link in Thunderbird mail that opens in Firefox (but its preferences indicate is not the default browser).

OR

Thunderbird and Firefox are closed.
_I open Thunderbird.
_I click a link in Thunderbird mail that opens in Firefox (but its preferences indicate is not the default browser).

Hello, there’s a way to reset your Linux.

Try configuring unconfigured packages:

sudo dpkg --configure -a

Update the contents of the repositories

sudo apt update

Fix the missing dependencies:

sudo apt -f install

Update all packages with the new versions available:

sudo apt full-upgrade

Reinstall your desktop:
sudo apt install --reinstall your-desktop-name
Edit:

sudo apt install --reinstall task-xfce-desktop

Remove unnecessary packages:

sudo apt autoremove

Delete downloaded packages already installed:

sudo apt clean

Reboot the system to see if the problem resolved:

sudo reboot

Quote