Flathub Repository Ekleme - TLS Sertifika Hatası

Flatpak—the future of application distribution bağlantısındaki adımlara göre laboratuvardaki bilgisayarlara yükleme yapmaya çalışıyorum. 3. adımda uç birimde aşağıdaki çıktıyı alıyorum.

Note that the directories 

'/var/lib/flatpak/exports/share'
'/home/btr/.local/share/flatpak/exports/share'

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

hata: Can't load uri https://flathub.org/repo/flathub.flatpakrepo: Kabul edilemez bir TLS sertifikası

Selamün Aleyküm Üstad
Muhtemelen MEB ağı üzerinden çıkış yapıyorsunuz. MEB, şifreli bağlantıların arasına girdiği için muhtemelen TLS hatasını o sebepten veriyor. Gözardı etmek için --no-gpg-verify argümanını kullanabilirsin.

1 Beğeni

A. slm hocam.

(base) ogrt@pardus:~$ flatpak remote-add --no-gpg-verify --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
hata: Can't load uri https://flathub.org/repo/flathub.flatpakrepo: Kabul edilemez bir TLS sertifikası

Hocam tek bilgisayar olsa evde halledecem de labdaki bilgisayarları komple eve taşımam mümkün değil. Lab bodrumda olduğu için telefon interneti de çekmiyor.

Bu arada uç birimde kullanıcı adı ve makine adı önünde (base) yazmasının sebebi nedir?

Hakkınızı helal edin. Paylaştığım argümanı tekrardan araştırdım lakin TLS ile ilgili değilmiş. Kusura bakmayın.

Sistemdeki kök sertifikaların kullanımı henüz flatpak’a kazandırılmamış galiba.
Konu ile ilgili çözüme kavulmamış birçok konu başlığı var.

1 Beğeni

Estağfurullah kardeşim ilgin için çok teşekkürler. Peki s4a’yı yükleyebiliyor musunuz? Baktım Synaptic’te var fakat yükleme yapmama rağmen çalıştıramadım. Aşağıdaki adresten debian için kurulum dosyasını indirip yükleme yapmaya çalıştım. Programı yine çalıştıramadım. Wisker menüde görünmesine rağmen başlamıyor. Flatpak’ı Scratch 3 ve s4a’yı çalıştırabilirim umuduyla denedim.

http://s4a.cat/

Flatpak depoları MEB internetinde çalışmıyor hocam. Vakt-i Salah programını bilgisayara indirememiştim .Telefonun internetini bağlayınca indi. Sonrasında her güncelleme geldiğinde de yeniden telefonu bağlayıp güncellemek durumunda kalıyorum.

1 Beğeni

libsm6:i386 paketini yüklerseniz çalışabilir. Bende de çalışmadı. İnceleyince bu pakete ihtiyacı olduğu gözüktü.
i386 paketleri sistemde açık değilse sudo dpkg --add-architecture i386 ile açabilirsiniz.
sudo apt update ile depoları güncelledikten sonra sudo apt install libsm6:i386 komutu paketi yükleyebilirsiniz.

1 Beğeni