Flutterın vlc eklentisi cmake verisiyonumu yanlış görüyor

Selamunaleyküm
flutterda linux/gnu için olan uygulamada sesle alaklı basit bir uygulamanın çıktısını almaya çalışırken kullanmaya çalıştığm bir paket cmake versiyonumu yanlış görüyor veya ben öyle sanıyorum. ne yapabilirim

eklenti

hata mesajı

Launching lib/main.dart on Linux in debug mode…
lib/main.dart:1
CMake Error at flutter/ephemeral/.plugin_symlinks/dart_vlc/linux/CMakeLists.txt:9 (cmake_minimum_required):
CMake 3.13 or higher is required. You are running version 3.10.2

Exception: Unable to generate build files

hata çıkaran kod

`

dart_vlc: A media playback library for Dart & Flutter. Based on libVLC & libVLC++.

Hitesh Kumar Saini

https://github.com/alexmercerind

alexmercerind@gmail.com

GNU Lesser General Public License v2.1

cmake_minimum_required(VERSION 3.13)
set(CMAKE_CXX_STANDARD 17)

set(PROJECT_NAME “dart_vlc”)
set(PLUGIN_NAME “dart_vlc_plugin”)
project(${PROJECT_NAME} LANGUAGES CXX)

add_subdirectory(…/dartvlc “${CMAKE_BINARY_DIR}/${PROJECT_NAME}_core”)

add_library(${PLUGIN_NAME} SHARED
dart_vlc_plugin.cc
)

apply_standard_settings("${PLUGIN_NAME}")
set_target_properties(
“${PLUGIN_NAME}” PROPERTIES
CXX_VISIBILITY_PRESET hidden
)
target_compile_definitions(
“${PLUGIN_NAME}” PRIVATE
FLUTTER_PLUGIN_IMPL
)

target_include_directories(${PLUGIN_NAME} INTERFACE
“${CMAKE_CURRENT_SOURCE_DIR}/include”
)

target_include_directories(${PLUGIN_NAME} PRIVATE
“${DARTVLC_CORE_PATH}”
)

target_link_libraries(${PLUGIN_NAME} PRIVATE
flutter
PkgConfig::GTK
dart_vlc_core
)

target_link_options(${PLUGIN_NAME}
PRIVATE -Wl,–whole-archive $<TARGET_FILE:dart_vlc_core> -Wl,–no-whole-archive
)

set(
dart_vlc_bundled_libraries
PARENT_SCOPE
)
`

cmake versiyonum önceden 3.18.4tü, olmayınca yüselttim

cmake --version 
cmake version 3.23.0-rc2

CMake suite maintained and supported by Kitware (kitware.com/cmake).

benzer bir hata burda da karşılaşılmış

flutterı snaple yüklemiştim ondan kaynaklanabilir mi

snap --version
snap    2.54.3
snapd   2.54.3
series  16
pardus  21.1
kernel  5.10.0-11-amd64

flutter --version
Flutter 2.10.2 • channel stable •
https://github.com/flutter/flutter.git
Framework • revision 097d3313d8 (11 gün önce) • 2022-02-18
19:33:08 -0600
Engine • revision a83ed0e5e3
Tools • Dart 2.16.1 • DevTools 2.9.2

manuel olarak yükleyince çözüldü başkası karşılarsa altaki şekilde çözebilir inşaAllah
fluttırı manuel yüklemek için

burdan stabil olanı indirip istediğimiz bir yere çıktartıyoruz

export PATH="$PATH:/home/bismih/flutter/bin"

ev dizinideki .bashrc dosyasına bunu ekliyoruz

flutter/bin klasörüde terminali açıp echo $PATH ile olup olmadığını kontrol ediyoz

bazen bağımlılık hataları çıkıyor

sudo apt install clang cmake ninja-build

bunları yüklemek gerekibilyor
en son fluterda bi eksik var mı diye

flutter doctor 

çalıştırıyoruz

Bu konu son yanıttan 30 gün sonra otomatik olarak kapatıldı. Yeni yanıt girilmesine izin verilmiyor.