Hangisini kurmalıyım?

Windows 10 yüklü dizüstü bilgisayarıma yavaşladığı için Pardus kurmak istiyorum ama hangi işletim sistemini kurmalıyım karar veremiyorum. Pardus 17.0 kurmayı düşünüyorum çünkü 256 MB RAM kullanımı var ama 17.5 geçtiğimizde iki kat fark oluyor. 4 GB RAM’i olan bir dizüstü bilgisayarda temel işler ve yazılım geliştirme işini hangisinde daha rahat yapabilirim?

Not: Pardus 19.3 XFCE kurmak istiyorum aslında ama sistemim yeterli mi bilemiyorum. Bu yüzden sisteminin yeteceğini düşündüğünüz en üst işletim sistemini önerebilir misiniz?

Şimdiden teşekkürler :pray:t3: :pray:t3:

1 Beğeni

Pardus 19.3 XFCE (64-bit)

Sistem gereksinimleri:

  • 1024MB+ RAM,
  • 8GB+ disk alanı,
  • en az 800×600 çözünürlüğü destekleyebilen grafik işlemci,
  • 64-bit destekli 1.0GHz+ işlemci.

Hocam herşeyden önce ssd almanız lazım. Ssd’ler eski cihazları resmen şahlandırıyor. Ssd’ye terfi ettikten sonra istediğini kur. Hepsi güzel çalışır.

1 Beğeni

19.3 XFCE kurabilirsiniz. Bende de bir tane 3. nesil i3 ve 4 GB RAM’i olan dizüstü bilgisayar vardı, özellikleri tam ezberimde değil. Windows 10’u kaldırmakta zorlanıyordu. Pardus 19.3 ile çok hızlandı. Özellikleri düşük olduğu için açılması normalden 5-10 saniye uzun sürüyor ama açıldıktan sonra performans sorunu olmuyor. Ondan daha düşük özellikli bir bilgisayarda da sorunsuzca kullanmıştım. Sanal makinede denerken de daha ağır olan GNOME sürümü 2 GB RAM ile rahatça çalışıyordu.

Sisteminizin diğer özelliklerini bilmediğim için net bir şey diyemem ama RAM’iniz yeterli. Pardus Ondokuz sürümlerini rahatça kullanırsınız. Günlük kullanımda hiç sıkıntı çıkarmaz.

Yazılım geliştirme konusunda iş değişebilir çünkü birçok farklı alanı var yazılım geliştirmenin. O bilgisayarda Windows ile yaptığınız bütün yazılım geliştirme işlerini Pardus’ta daha hızlı yaparsınız.


Onyedi’nin UVD sürümü 17.5 ve diğer sürümlerinin desteği bitti. Yani 17.0 kurarsanız, düzgün bir deneyim alabilmek için 17.5’e yükseltmeniz gerekecek. 17.5 ile 19.3 arasında bir tercih yapacaksanız da 19.3’ü öneririm. Çünkü hem kaynak tüketiminde büyük bir artış olmadı hem de 19.3, UVD sürümü olmadığı hâlde çok daha kararlı bir deneyim sunuyor.

4 gb ram ile sorun olmaz.
ama illa düşük ram kullanımı istiyorsan

Pardus 19.3 Sunucu (64-bit) olanı kur.

aşağıdaki linkte debian için anlatılmış.aynı işlemleri pardus için yapınca ram tüketimi düşüyor.Ben pardus için biraz değişiklik yaptım.

bilgisayar komut satırı ile başlayacak.

sudo apt install xfce4 xorg network-manager synaptic firefox-esr komutunu çalıştır.

yükleme bitince xfce olarak başlayacak.Diğer gerekli uygulamaları synaptic uygulamasında arayıp bulur yüklersin.

Bu şekilde pardus yüklersen boşta iken ram kullanımını 250-300 mb civarında oluyor.

1 Beğeni

Güzelmiş. Diğer kaynaklar (CPU, GPU, depolama vb.) için de benzer tasarruf sağlar mı?

1 Beğeni

Dizüstü bilgisayarımın SSD desteği olup olmadığını nasıl öğrenebilirim?

1 Beğeni

Peki ben bunu kurarsam bana ne gibi avantaj sağlar?

1 Beğeni

karakter sınırı bir türlü dolmadığı için yazdım.

1 Beğeni

Sunucu sürümü grafik arayüz ile gelmediği için Pardus’un diğer sürümlerine göre daha az önyüklü yazılım gelecektir. Masaüstü ortamı da dahil olmak üzere birçok uygulamadan sadece ihtiyacınız olanları yükleyeceğinizden dolayı sisteme daha az yük biner.
Sizin durumunuzda günlük işlerde büyük bir etki yapmaz. Bilgisayara ağır işler yaptırmayacaksanız, boş RAM gerektiren başka bir durumunuz yoksa veya 1-2 GB gibi küçük miktarda RAM kullanmıyorsanız uğraşmaya değeceğini sanmıyorum. XFCE veya GNOME sürümünü yüklemeniz sizin için daha rahat olacaktır.

Bilgisayarınızın içini açabiliyorsanız, bir bakın. HDD’si ayrılabiliyorsa (muhtemelen öyledir) SSD de kullanabilirsiniz. HDD ile aynı bağlantıyı kullanan ve aynı yuvalara girebilen birçok SSD modeli var.

grafik içeren uygulamalarda oyunlarda ram için boş yer kalır.
arka planda mümkün olduğunca az program çalıştır.
birde benim dediğim gibi yapmadan normal pardusu yükle yap.
pardus ile yüklü gelen bu evolution uygulamayı kaldır.aşırı ram ve işlemci harcıyor arka planda.
ram tüketimin 1024 mb altına düşüyor.
https://help.gnome.org/users/evolution/stable/

4gb ram kapasitesine sahip bilgisayarın var.sorun çıkarmaz.Direk yükle.
Benim bilgisayar 2 gb ram olduğu bu yola başvuruyorum.
piyasadaki eski bilgisayarlar için önerilen linux dağıtımları bile aşırı ram harcıyorlar.

1 Beğeni

cpu için avantaj sağlamıyor.depolama için ise pardus yükleyeceğin disk bölümünü xfs olarak biçimlendir.
ext4 dosya sistemi xfs ye göre diskte daha çok kaplıyor.

1 Beğeni

Eğer yazılım geliştirecekseniz bence xfce iyidir. Ben 19.3 kurdum. İyi çalışıyor.
Ben çok kurcaladığım için birkaç defa bozdum ve yeniden yüklemek zorunda kaldım :sweat_smile:
(Hatta python’u kaldırınca ne oluyor diye merak edip onu dahi yaptım)

Tabii bu yazılım geliştirme ortamına da bağlı. vscode Bende sanki biraz kasıyor gibiydi. Ben de atom kullanmaya başladım.
Ama yine de 19.3 XFCE iyidir. Tavsiye ederim.
Şu an benim boşta 400-600 mb arası ram kullanıyor. Bilgisayarın toplam ram ise 4GB.

2 Beğeni

Hocam makinanın diskini sökeceksiniz. Sonra diskin girişleri sata mı değil mi ona bakacaksınız. Makina 10 yaşından eski değilse girişi sata dır. Ssd lerin girişi de sata. Google dan fotolarına bakabilirsiniz. Disklerin girişi ya ide dir ya da sata (sunucu kısmı hariç) . İde tarih oldu. Yani sonuç olarak soketi aynı ise takar kullanırsınız. Başka bir uyumluluğa bakılmaz.

1 Beğeni

Dizüstü bilgisayarıma hangi işletim sistemini kurmaya çalıştıysam kurulumdan sonra bilgisayarı açtığımda “No Bootable Device” hatası ile karşılaşıyorum. Sistemi yeniden başlatıp F12 ile boot menüyü açtığımda sadece takılı olan flash belleğimi algılıyor.
İnternette biraz araştırdım ama kesin bir çözümü bulamadım.
Not: Herhangi bir Linux işletim sistemini kurmadan flash bellekten çalıştırdığımda sorunsuz çalışıyor sistem ama kurduktan sonra hata alıyorum.

son sürümü kur 19-3 her zaman daha günceldir.

Bu konu son cevaptan 10 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

© 2020 TÜBİTAK