Lazarus lcl hatası -Çözüldü

(Sadik Acar) #1
arkadaşlar paket yöneticisnde lazazus yazan ne varsa seçip yükledim

ide çalışıyor ançak projeyi çalıştırdığımda aşagıdaki hatayı alıyorum web de aradım çok bilği var ama bir şey anlamadım türkçe bilği bulamadım gerçi bu sorunu nasıl çözebiliriz acaba

saygılarımla

The project does not use the LCL unit interfaces, which is required by LCLBase.
You will get strange linker errors if you use the LCL without interfaces.

0 Likes

(𝗄𝖺𝖺𝗇) #2

Kurduğunuz paketlerin hepsini kaldırın ve Lazarus'u kuramadım, kaldıramıyorum da linkindeki adımları uygulayınız.

0 Likes

(Ali KOCA) #3

Merhaba;
Sorunu çözebildiniz mi?

Selamlar.

0 Likes

(Sadik Acar) #4

hcam şu anda
lazarus-project_2.0.0-0_amd64.deb
fpc-laz_3.0.4-1_amd64.deb
fpc-src_3.0.4-2_amd64.deb

paketlerini indiriyorum sonra linkde anlatılan gibi sıralamayla kurmaya çalışacağım

Daha sonra aşağıdaki sıra ile kurunuz.
sudo dpkg -i fpc-laz_3.0.4-1_amd64.deb
sudo dpkg -i fpc-src_3.0.4-2_amd64.deb
sudo dpkg -i lazarus-project_2.0.0-0_amd64.deb

gelişmeleri yazarım saygılar

0 Likes

(Sadik Acar) #5

sanırım fpc paketlerini tam kaldıramamışım hepsinin kaldırıp yeniden başlatıp tekrar deneyeceğim saygılar

sadikacar60@pardus:~/İndirilenler$ sudo dpkg -i fpc-laz_3.0.4-1_amd64.deb
dpkg: fpc-laz_3.0.4-1_amd64.deb dosyası, fpc-laz paketi:
fpc-laz, fpc paketi ile çakışır
fpc (sürüm 3.0.0+dfsg-11+deb9u1) mevcut ve kurulu.
fpc-3.0.0, fpc paketini sağlıyor, mevcut ve kurulu.

dpkg: fpc-laz_3.0.4-1_amd64.deb arşivi işlenirken sorun yaşandı (–install):
paketler çakışıyor - fpc-laz kurulmayacak
İşleme sırasında hatalarla karşılaşıldı:
fpc-laz_3.0.4-1_amd64.deb
sadikacar60@pardus:~/İndirilenler$ ^C
sadikacar60@pardus:~/İndirilenler$

sadikacar60@pardus:~/İndirilenler$ sudo dpkg -i fpc-src_3.0.4-2_amd64.deb
Daha önce seçili olmayan fpc-src paketi seçiliyor.
dpkg: fpc-src_3.0.4-2_amd64.deb dosyası, fpc-src paketi:
fpc-src, fpc-source paketi ile çakışır
fpc-source-3.0.0, fpc-source paketini sağlıyor, mevcut ve kurulu.

dpkg: fpc-src_3.0.4-2_amd64.deb arşivi işlenirken sorun yaşandı (–install):
paketler çakışıyor - fpc-src kurulmayacak
İşleme sırasında hatalarla karşılaşıldı:
fpc-src_3.0.4-2_amd64.deb
sadikacar60@pardus:~/İndirilenler$ ^C
sadikacar60@pardus:~/İndirilenler$

0 Likes

(𝗄𝖺𝖺𝗇) #6

Sürüm uyumsuzlukları oluşmuş. Önceki kurduğunuz tüm paketleri kaldırınız.

0 Likes

(Sadik Acar) #7

pakat yöneticisinde lazarus diye aradım çıkan tüm paketleri kaldırdım
pakat yöneticisinde fpc diye aradım ilğili tüm pascal paketlerini kaldırdım
pakat yöneticisinde fp diye arayıp paskalla ilğili paketleride kaldırdıktan sonra

sudo dpkg -i fpc-laz_3.0.4-1_amd64.deb
sudo dpkg -i fpc-src_3.0.4-2_amd64.deb
sudo dpkg -i lazarus-project_2.0.0-0_amd64.deb

sıralamaya göre kurdum lazarus kuruldu
sadece lazarusa ait online paket maneger kurulu gelmesi lazımdı hata verdi onun haricinde bir problem yok ide hata vermeden çalışıyor.

çok teşekkürler saygılar sunarım

0 Likes

(𝗄𝖺𝖺𝗇) #8
0 Likes

(Ali KOCA) #9

Merhaba;
Aşağıdaki şekilde kuruyorum. Sorun yaşamıyorum.

dpkg -i fpc_3.0.4-2_amd64.deb
dpkg -i fpc-src_3.0.4-2_amd64.deb
dpkg -i lazarus-project_1.8.0-1_amd64.deb
apt-get install libgtk2.0-dev
apt-get -f install
dpkg -i lazarus-project_1.8.0-1_amd64.deb

Selamlar.

0 Likes

(emrah) #10

LCL problemini ve daha fazlasını bende iki gün önce yaşadım.
Thread lar ile ilgili bir program yazmak istedim, fakat bir türlü başarılı olamamistim. Sonra kendime dedim ki neden codetyphoon da demiyorsun dedim. Ve yükledim bundada başarısız olunca tekrar lazarusu kurdum ve LCL , compiler ,ppcx64 gibi hatalar aldım en son kızdım lazaruz ve codetyphoon bunlara dair ne varsa sildim.ve lazarusu depodan kurdum. (‘neden Pardus mağaza da hala yok anlamış değilim’) ve sonuç başarılı. Bu arada thread konusunda bir başarı daha elde ettim.Bunda ise UseCThreads define eklememiz gerekiyor.linux sistemlerde yapılması lazım.

1 Like

(system) kapatıldı #11

Bu konu son cevaptan 30 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

0 Likes