MYSQL bağlantı hatası


(Sadik Acar) #1

arkadaşlar pardusla kullanımı daha kolay olacağı ve yaygın kullanıldığı için firebird yerine mysql
kullanmaya karar verdim
depodan server ve workebnch yükledim
hizmetlere baktığımda mysql server seçilmiş görünüyor anladığımkadarıyla devre demek
sonra workbench çalıştırdım.

Local Instance 3306
root
localhost:3306

yazan menüye tıkladığım anda resimdeki hatayı veriyor
anlayabildiğim kadarıyla mysql server devrede değil diyor ama hizmetlerde devrede görünüyor
neyi yanlış yapıyorum acaba.
kurulum esnasında ben hiç şifre falan vermedim. şifre girmek gerekiyor mu acaba
saygılarımla


(Eren Hatırnaz) #2

Merhaba,

Kurulumdan sonra terminalde mysql_secure_installation komutunu çalıştırdınız mı? Bildiğim kadarıyla MYSQL’de root şifresi boş olamıyor. Bu komutu çalıştırarak root şifrenizi belirleyebilirsiniz. Daha sonra şifrenizle ile tekrar bağlanmayı deneyebilirsiniz.

İyi günler.


(Sadik Acar) #3

hocam komutu çalıştırdım ama root şifresi istiyor yeni şifre için onu bilmediğim için değişiklik yapamıyorum

mysql dosyalarını yeniden yükledim belki şifre ekranını atlamışımdır diye ama şifre sormadan direkt kurdu.

default root şifresi vermiş olabilirmi webden baktım çözemedim.

yeni mysql bağlantısı oluşturmak istediğimde gene benzer problem karşımda.

saygılarımla


(Eren Hatırnaz) #4

Aynı komutu sudo mysql_secure_installation olarak çalıştırmayı deneyebilir misiniz? Bu şekilde çalıştırdıktan sonra şu anki şifrenizi istediği ekranda birşey yazmadan ENTER tuşuna basarsanız, o ekranı geçebilirsiniz. Daha sonra Set root password? [Y/n] sorusunu soracaktır. Y tuşuna basın ve şifrenizi belirleyin. Kurulumun diğer aşamalarındaki sorulara da kendinize göre yanıt verirsiniz.

İyi günler.


(Sadik Acar) #5

sordugu her şeye yes dedim değişen bir şey olmadı hocam bir şeyi atlıyorum ama neyi

sadikacar60@pardus:~$ sudo mysql_secure_installation

[sudo] password for sadikacar60:

Özet

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
SERVERS IN PRODUCTION USE! PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we’ll need the current
password for the root user. If you’ve just installed MariaDB, and
you haven’t set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): y

OK, successfully used password, moving on…

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

You already have a root password set, so you can safely answer ‘n’.

Change the root password? [Y/n]

Change the root password? [Y/n] y
New password:
Re-enter new password:
Password updated successfully!
Reloading privilege tables…
… Success!

By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them. This is intended only for testing, and to make the installation
go a bit smoother. You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n]

Remove anonymous users? [Y/n] y
… Success!

Normally, root should only be allowed to connect from ‘localhost’. This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] y
… Success!

By default, MariaDB comes with a database named ‘test’ that anyone can
access. This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] y

  • Dropping test database…
    … Success!
  • Removing privileges on test database…
    … Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] y
… Success!

Cleaning up…

All done! If you’ve completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!

https://i.hizliresim.com/mMX3BZ.png


(Eren Hatırnaz) #6

O zaman şu yöntemi deneyelim:

  1. Öncelikle Hizmetler penceresinden mysql hizmetini durduralım ya da terminal üzerinden sudo service mysql stop yazarak da durdurabilirsiniz.
  2. Şimdi bir terminal penceresi açalım ve sudo mysqld --skip-grant-tables & komutunu çalıştıralım. Bu komutu çalıştırdıktan sonra [1] 5803 gibi bir çıktı vermesi gerekiyor (sizde 5803 yerine başka bir sayı yazacaktır). Bu terminal penceresi açık kalsın.
  3. Başka bir terminal penceresinde mysql komutunu çalıştıralım.
  4. Sırasıyla aşağıdaki sorguları yazıp çalıştıralım:
truncate table user;
flush privileges;
grant all privileges on *.* to root@localhost identified by 'BURAYASIFRENIYAZ' with grant option;
  1. mysql konsolundan çıkmak için quit; komutunu çalıştıralım.
  2. İlk açtığımız terminal penceresine gelip, sudo kill 5803 (sizdeki sayı farklı olacaktır) komutunu çalıştıralım.
  3. Şimdi tekrar Hizmetler penceresinden mysql servisini çalıştırın ya da terminal üzeirnden sudo service mysql start komutu ile de çalıştırabilirsiniz.
  4. Son olarak MySQL Workbench’i çalıştıralım ve bağlantı yapmayı deneyelim. Bu sefer size şifrenizi soruyor olması gerek.

Umarım işe yarar.


(Sadik Acar) #8

sıralamayı biraz karıştırdım ama çalıştı şifre istedi hocam .
şimdi yeni şifre belirleyip bağlanmaya çalışacağım


(Eren Hatırnaz) #9

Hocam kusura bakmayın yazarken yanlış yazmışım:
sudo mysql --skip-grant-tables komutunda mysql yerine mysqld yazmak gerekiyor. Yazarken fark edememişim.


(Sadik Acar) #10

sagolun hocam o şekildede işe yaradı şifre sorma aşamasına geldik gerçi verdiğim hiç bir şifreyi kabul etmedi şimdi yeni şifre vermeye çalışıyorum bakalım becerebilecekmiyim
saygılarımla


(Sadik Acar) #11

şifreyle uğraşırken workbench i kaldırıp tekrar kurdum direkt bağlandı sorun çözüldü
zaman ayırıp cevap yazan hocalarıma saygılar sunarım