Paket Güncelleyicide Hata Alıyorum

Paketleri Güncellemeye Çalıştığımda Bu Hatayı Veriyor:

Error while installing package: açılmış ‘./usr/bin/perl’ verisi ‘/usr/bin/perl.dpkg-new’ konumuna kopyalanamıyor

Çözümü Bulamadım Yardım Eder Misiniz?

1 Beğeni

Selamün Aleyküm

Uçbirimde sırasıyla aşağıdaki komutları çalıştırıp tüm çıktılarını paylaşabilir misiniz?

sudo apt update
sudo dpkg --configure -a
sudo apt -f install
apt upgrade -y
1 Beğeni

Aleyküm Selam

yusuf@YUSUF:~$ sudo apt update
[sudo] password for yusuf:
Aynı: 1 Index of /pardus/ onyedi InRelease
İndir: 2 Index of /tomtomtom/woeusb/ubuntu jammy InRelease [18,0 kB]
Aynı: 3 Index of /guvenlik/ onyedi InRelease
İndir: 4 Index of /nilarimogard/webupd8/ubuntu bionic InRelease [15,4 kB]
Hata: 2 Index of /tomtomtom/woeusb/ubuntu jammy InRelease
Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY B90E9186F0E836FB
Hata: 4 Index of /nilarimogard/webupd8/ubuntu bionic InRelease
Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY 531EE72F4C9D234C
Paket listeleri okunuyor… Hata!
N: ‘/etc/apt/sources.list.d/’ dizinindeki ‘webupd8.list.save’ dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
W: GPG hatası: Index of /tomtomtom/woeusb/ubuntu jammy InRelease: Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY B90E9186F0E836FB
E: ‘Index of /tomtomtom/woeusb/ubuntu jammy InRelease’ deposu imzalanmamış.
N: Böyle bir depodan güvenli bir şekilde güncelleme yapılamaz, bu nedenle depo devre dışı bırakılmıştır.
N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
W: GPG hatası: Index of /nilarimogard/webupd8/ubuntu bionic InRelease: Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY 531EE72F4C9D234C
E: ‘Index of /nilarimogard/webupd8/ubuntu bionic InRelease’ deposu imzalanmamış.
N: Böyle bir depodan güvenli bir şekilde güncelleme yapılamaz, bu nedenle depo devre dışı bırakılmıştır.
N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
E: Okuma hatası - read (5: Girdi/Çıktı hatası)
E: Okuma hatası - read (5: Girdi/Çıktı hatası)
W: Bu sorunları gidermek için apt-get update komutunu çalıştırabilirsiniz
E: Paket önbelleği dosyası bozulmuş
yusuf@YUSUF:~$ sudo dpkg --configure -a
Tetikleyiciler işleniyor: cracklib-runtime (2.9.2-5) …
dpkg: bağımlılık sorunları yüzünden perl paketi yapılandırılamıyor:
perl şuna bağımlı: perl-base (= 5.24.1-3+deb9u5), ama:
Sistemde mevcut olan perl-base paketinin sürümü 5.24.1-3+deb9u4.
perl şuna bağımlı: perl-modules-5.24 (>= 5.24.1-3+deb9u5), ama:
Sistemde mevcut olan perl-modules-5.24 paketinin sürümü 5.24.1-3+deb9u4.
perl şuna bağımlı: libperl5.24 (= 5.24.1-3+deb9u5), ama:
Sistemde mevcut olan libperl5.24:amd64 paketinin sürümü 5.24.1-3+deb9u4.

dpkg: perl paketi işlenirken sorun yaşandı (–configure):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: libc-bin (2.24-11+deb9u3) …
Tetikleyiciler işleniyor: man-db (2.7.6.1-2) …
İşleme sırasında hatalarla karşılaşıldı:
perl
yusuf@YUSUF:~$ sudo apt -f install
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Bağımlılıklar düzeltiliyor… Tamamlandı
Aşağıdaki ek paketler kurulacak:
libperl5.24 perl-base perl-modules-5.24
Aşağıdaki paketler yükseltilecek:
libperl5.24 perl-base perl-modules-5.24
3 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 261 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/7.568 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 5.120 B ek disk alanı kullanılacak.
N: ‘/etc/apt/sources.list.d/’ dizinindeki ‘webupd8.list.save’ dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
Devam etmek istiyor musunuz? [E/h] E
dpkg-deb (alt süreç): arşiv üyesi ‘/var/cache/apt/archives/perl-base_5.24.1-3+deb9u5_amd64.deb’ arşivinden kopyalanamıyor: okuma başarısız (Girdi/Çıktı hatası)
dpkg-deb (alt süreç): sıkıştırılmış arşiv üyesi açılıyor: lzma hatası: beklenmeyen girdi sonu
dpkg-deb: hata: alt süreç <aç> 2 çıkış kodu ile sona erdi
dpkg-deb (alt süreç): arşiv üyesi ‘/var/cache/apt/archives/libperl5.24_5.24.1-3+deb9u5_amd64.deb’ arşivinden kopyalanamıyor: okuma başarısız (Girdi/Çıktı hatası)
dpkg-deb (alt süreç): sıkıştırılmış arşiv üyesi açılıyor: lzma hatası: beklenmeyen girdi sonu
dpkg-deb: hata: alt süreç <aç> 2 çıkış kodu ile sona erdi
Reading changelogs… Done
N: ‘/etc/apt/sources.list.d/’ dizinindeki ‘webupd8.list.save’ dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
(Veritabanı okunuyor … 172153 dosya veya dizin kurulu durumda.)
Paket açılacak: …/perl-base_5.24.1-3+deb9u5_amd64.deb …
Paket açılıyor: perl-base (5.24.1-3+deb9u4) üzerine (5.24.1-3+deb9u5) …
dpkg-deb (alt süreç): arşiv üyesi ‘/var/cache/apt/archives/perl-base_5.24.1-3+deb9u5_amd64.deb’ arşivinden kopyalanamıyor: okuma başarısız (Girdi/Çıktı hatası)
dpkg-deb (alt süreç): sıkıştırılmış arşiv üyesi açılıyor: lzma hatası: beklenmeyen girdi sonu
dpkg-deb: hata: alt süreç <aç> 2 çıkış kodu ile sona erdi
dpkg: /var/cache/apt/archives/perl-base_5.24.1-3+deb9u5_amd64.deb arşivi işlenirken sorun yaşandı (–unpack):
açılmış ‘./usr/bin/perl’ verisi ‘/usr/bin/perl.dpkg-new’ konumuna kopyalanamıyor: beklenmeyen dosya ya da akış sonu
İşleme sırasında hatalarla karşılaşıldı:
/var/cache/apt/archives/perl-base_5.24.1-3+deb9u5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
yusuf@YUSUF:~$ apt upgrade -y
N: ‘/etc/apt/sources.list.d/’ dizinindeki ‘webupd8.list.save’ dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
E: Kilit dosyası /var/lib/dpkg/lock açılamadı - open (13: Erişim engellendi)
E: Yönetim dizini (/var/lib/dpkg/) kilitlenemiyor, root kullanıcısı mısınız?
yusuf@YUSUF:~$

Sorun eklemiş olduğunuz ubuntu ve webupd8 depolarından kaynaklanmaktadır.
sudo mousepad /etc/apt/sources.list komutu ile açılan editör içerisinden ubuntu depo adreslerini ve varsa webupd8 depo adreslerini silin. Aynı şekilde sudo thunar /etc/apt/sources.list.d komutu ile açılan dosya yöneticisinden ubuntu depo adreslerinin bulunduğu dosyaları ve webupd8 dosyalarını silin.
sudo apt autoremove && sudo apt clean && sudo apt update komutunu çalıştırın.

Not: Bu komutu çalıştırmadan önce açık olan Pardus Mağaza, Pardus Yazılım Merkezi, Synaptic Paket Yöneticisi gibi paket yönetici programları kapatın. Başka bir pencerede apt komutu kullan uç birim var ise işleminin bitmesini bekleyin.

1 Beğeni

Yaptım Bu Seferde En Son Çalıştırdığım Komut Böyle Bir Hata Veriyor

Paket listeleri okunuyor… Hata!
W: Sources (non-free/source/Sources) hedefi /etc/apt/sources.list:6 ve /etc/apt/sources.list:9 konumlarında birden fazla kez yapılandırılmış
W: Sources (contrib/source/Sources) hedefi /etc/apt/sources.list:6 ve /etc/apt/sources.list:9 konumlarında birden fazla kez yapılandırılmış
W: Sources (main/source/Sources) hedefi /etc/apt/sources.list:6 ve /etc/apt/sources.list:9 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-amd64/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-i386/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-all/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-en) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (contrib/binary-amd64/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (contrib/binary-i386/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (contrib/binary-all/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (contrib/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (contrib/i18n/Translation-tr) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (contrib/i18n/Translation-en) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (non-free/binary-amd64/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (non-free/binary-i386/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Packages (non-free/binary-all/Packages) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (non-free/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (non-free/i18n/Translation-tr) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
W: Translations (non-free/i18n/Translation-en) hedefi /etc/apt/sources.list:5 ve /etc/apt/sources.list:8 konumlarında birden fazla kez yapılandırılmış
E: Okuma hatası - read (5: Girdi/Çıktı hatası)
W: Bu sorunları gidermek için apt-get update komutunu çalıştırabilirsiniz
E: Paket önbelleği dosyası bozulmuş

sources.list dosyanızın içeriğini düzenlerken fazla-eksik ya da hatalı karakterler kalmış.
sudo mousepad /etc/apt/sources.list komutu ie açılan editörde yeniden düzenleme yapınız.
Dosya içeriğini de paylaşabilirsiniz.

Eksik Olduğunu Düşünmüyorum

The Official Pardus Package Repositories

deb Index of /pardus/ onyedi main contrib non-free
deb-src Index of /pardus/ onyedi non-free contrib main

deb Index of /guvenlik/ onyedi/updates main non-free contrib
deb-src Index of /guvenlik/ onyedi/updates main non-free contrib

This section generated by Pardus Store at 23:13:47 - 11.01.2022

Dosyayı aşağıdaki şekilde kopyala yapıştır ile düzelttikten sonra sudo apt update komutu ile indexleri güncelleyiniz.

deb http://depo.pardus.org.tr/pardus onyedi main non-free contrib
#deb-src http://depo.pardus.org.tr/pardus onyedi main non-free contrib

deb http://depo.pardus.org.tr/guvenlik onyedi main non-free contrib
#deb-src http://depo.pardus.org.tr/guvenlik onyedi main non-free contrib

Aşağıdaki komutları sırası ile çalıştırın.

sudo rm -rf /etc/apt/sources.list.d
sudo mkdir -p /etc/apt/sources.list.d
echo "deb http://depo.pardus.org.tr/pardus yirmibir main non-free contrib" | sudo tee /etc/apt/sources.list
echo "deb http://depo.pardus.org.tr/guvenlik yirmibir main non-free contrib" | sudo tee -a /etc/apt/sources.list
sudo rm -rf /var/lib/apt/lists/*
sudo apt update
sudo apt full-upgrade -yq