Paket Güncelleyicisi İsteğin İlerlemesi başarısız oldu

Merhaba Paket Güncelleyicisinde 9 güncelleme mevcut. Güncellemeleri kurmak istediğimde aşağıdaki hatayı alıyorum.

Hata:
Error while installing package: paket çok tutarsız bir durumda; yapılandırmaya teşebbüs etmeden önce paketi yeniden kurmanız daha iyi olur

1 Beğeni

Merhaba,
Aşağıdaki komutun tamamını kopyala yapıştır biçiminde Uçbirimden çalıştırarak güncellemeyi deneyebilir misiniz?

sudo apt -f install && sudo apt update && sudo apt upgrade 
1 Beğeni

Merhaba Kaan Bey,

Aşağıdaki hatayı alıyorum.
dpkg: nano paketi işlenirken sorun yaşandı (–configure):

Teşekkür ederim.

sudo dpkg --configure -a
komutundan sonra diğer komutu çalıştırarak deneyebilir misiniz?

Merhaba Kaan bey,

Ne yazık ki olmadı.

Tersini de denedim olmadı

sudo apt install --reinstall nano komut ile nanoyu yeniden kurmayı deneyebilir misiniz?
Ayrıca farklı bir depo adresi kullanarak program yükleme yaptınız mı?

Merhaba,

Farklı bir depoya kurulum yapmadım. Bu şekilde tüm paketler güncellendi sanırım. Paket Güncelleyici’ye baktığımda “Tüm Paketler Güncel” uyarısı gelmekte.

Yardımlarınız için teşekkür ederim.

kazim@KAZIM:~$ ~sudo apt install --reinstall nano
'~sudo' komutu bulunamadı, şunu mu demek istediniz:
  'sudo' komutu deb'den sudo
  'sudo' komutu deb'den sudo-ldap
Dene: sudo apt install <deb name>
kazim@KAZIM:~$ sudo apt install --reinstall nano
[sudo] password for kazim: 
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket yeniden kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/657 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
(Veritabanı okunuyor ... 149705 dosya veya dizin kurulu durumda.)
Paket açılacak: .../nano_5.4-2+deb11u2_amd64.deb ...
Paket açılıyor: nano (5.4-2+deb11u2) üzerine (5.4-2+deb11u2) ...
Ayarlanıyor: nano (5.4-2+deb11u2) ...
Tetikleyiciler işleniyor: man-db (2.9.4-2) ...
kazim@KAZIM:~$ sudo dpkg --configure -a
kazim@KAZIM:~$ sudo apt -f install && sudo apt update && sudo apt upgrade
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
Aynı:  1 http://depo.pardus.org.tr/pardus yirmibir InRelease
Aynı:  2 http://depo.pardus.org.tr/guvenlik yirmibir InRelease
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
Tüm paketler güncel.
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
Yükseltme hesaplanıyor... Bitti
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
kazim@KAZIM:~$ 


İşlemler sorunsuz tamamlanmış. Problem yok.