Pardu 19 wi-fi realtek 8821ce problemi

merhaba

realtek 8821ce wi-kartım var bi türlü etkinleştiremedim kablolu olarak bağlanıyorum bütün güncellemeleri yaptım sonuç alamadım.

pc@pardus:~$ lspci
00:00.0 Host bridge: Intel Corporation Device 9b53 (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 9bc5 (rev 05)
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation Device a3af
00:14.2 Signal processing controller: Intel Corporation Device a3b1
00:15.0 Signal processing controller: Intel Corporation Device a3e0
00:15.1 Signal processing controller: Intel Corporation Device a3e1
00:16.0 Communication controller: Intel Corporation Device a3ba
00:17.0 SATA controller: Intel Corporation Device a382
00:1d.0 PCI bridge: Intel Corporation Device a39a (rev f0)
00:1d.3 PCI bridge: Intel Corporation Device a39b (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a3da
00:1f.2 Memory controller: Intel Corporation Device a3a1
00:1f.3 Audio device: Intel Corporation Device a3f0
00:1f.4 SMBus: Intel Corporation Device a3a3
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

Aşağıdaki komutları terminalden sırayla çalıştırınız:

sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)

git clone https://github.com/tomaspinho/rtl8821ce

cd rtl8821ce

chmod +x dkms-install.sh

chmod +x dkms-remove.sh

sudo ./dkms-install.sh
1 Beğeni

bu şekilde çıkıyor

pc@pardus:~$ sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 linux-headers-5.8.0-1-amd64 : Bağımlılıklar: linux-headers-5.8.0-1-common (= 5.8.7-1) ama kurulabilir değil
                               Bağımlılıklar: linux-kbuild-5.8 (>= 5.8.7-1) ama kurulabilir değil
                               Bağımlılıklar: linux-compiler-gcc-10-x86 ama kurulabilir değil
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
pc@pardus:~$ ^C

Çekirdek yükseltmesi yaptığınız için linux-headers- paketini seçemiyor.
Yükseltme yapmanızdaki sebep herhangi bir sorun değilse önceki çekirdekten açarak yükselterek kullanmanızı tavsiye ederim.

tekrar baştan kurulum yaptım durum yine aynı

pc@pardus:~$ sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 linux-headers-5.8.0-1-amd64 : Bağımlılıklar: linux-headers-5.8.0-1-common (= 5.8.7-1) ama kurulabilir değil
                               Bağımlılıklar: linux-kbuild-5.8 (>= 5.8.7-1) ama kurulabilir değil
                               Bağımlılıklar: linux-compiler-gcc-10-x86 ama kurulabilir değil
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
pc@pardus:~$

Backports sürümünü kuruyorsunuz sanırım. Normal sürümü kurunuz.

bu sürümü kullanmak zorundayım , diyanet işlerinin sürümü

Çekirdeği 5.9 yada 5.10 olarak yükselterek deneyebilirsiniz:

sudo nano /etc/apt/sources.list

Komutuyla açılan editöre aşağıdaki depo adresini girin:

deb http://deb.debian.org/debian buster-backports main

CTRL+O ENTER CTRL+X ENTER tuşları ile kadedin.

İndexleri güncelleyin:

sudo apt update

Çekirdek güncellemesi yapın:

sudo apt install linux-image-5.10.0-0.bpo.5-amd64
sudo apt install linux-headers-5.10.0-0.bpo.5-amd64

Yeniden başlatın:

sudo reboot now

Not: Yüklenen çekirdek ile açılış olmazsa, ilk açılışta bulunan gelişmiş seçeneğini seçerek 4.19 olan seçenekle açılışı yapabilirsiniz.

Terminalden aşağıdaki komut ile yüklenen çekirdeği kaldırabilirsiniz:

sudo apt remove linux-image-5.10.0-0.bpo.5-amd64
sudo apt remove linux-headers-5.10.0-0.bpo.5-amd64
sudo reboot now
1 Beğeni

teşekkürler sorunum çözüldü.

Rica ederiz. Çözüm olarak işaretleyebilirsiniz.

1 Beğeni

Bu konu son cevaptan 10 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.