Pardus 17'ye Nasıl Gnome yüklerim?


(Muhammed YILMAZ) #1

Gnome masaüstünü yükleyip denemek istiyorum. Nasıl yükleyebilirim? sudo apt-get install gnome komutunu verince bu çıktıyı alıyorum.

myilmaz@pardus:~$ sudo apt-get install gnome
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 gnome : Bağımlılıklar: gnome-core (= 1:3.22+3) ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
myilmaz@pardus:~$

(Cüneyt Ulusoy) #2

sudo apt-get -f install komutu ile bozuk paketlerin düzeltilmesini sağladıktan sonra ;

sudo apt-get install gdm3 şeklinede kurunuz.


(Ahmet) #3

Son verdiğiniz komut ile yükleme yaptım, sistemi yeniden başlattım. Masaüstü açılmadı. Karşıma siyah ekranda bu hata çıktı:

/dev/sda1: clean, 197838/30269440 files, 5026288/121068032 blocks


(𝗄𝖺𝖺𝗇) #4

Canlı sistemde açarak, sistemin kurulu olduğu diske girip, /home/kullanıcıadı/.xsession-errors dosyasını gönderebilirmisiniz. Bu dosya gizli dosyadır. Dizine girip CTRL+H tuşları ile görünür hale getirin.


(Muhammed YILMAZ) #5

gdm3'ü kurmayı denedim, zaten en yeni sürümde dedi. Belki gnome-shelli daha önceyüklediğim içindir, bilemiyorum. Tekrar oturumu kapatıp diğer gnome masaüstüne geçmeyi denedim. Fakat seçeneklerde “default” ve “XFCE” var.


(Ahmet) #6

Xsession: X session started for ahmett at Pzt Ağu 14 14:14:05 +03 2017
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/ahmett/.Xauthority
localuser:ahmett being added to access control list
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
gpgconf: warning: can not open config file /home/ahmett/.gnupg/gpg-agent.conf: Böyle bir dosya ya da dizin yok
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
OpenGL version: 3.
dbus-update-activation-environment: setting USER=ahmett
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/ahmett
dbus-update-activation-environment: setting DESKTOP_SESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_STYLE_OVERRIDE=gtk
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=ahmett
dbus-update-activation-environment: setting GTK_OVERLAY_SCROLLING=0
dbus-update-activation-environment: setting CLUTTER_BACKEND=x11
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/usr/local/games:/usr/games:/home/ahmett/.local/bin:/home/ahmett/bin
dbus-update-activation-environment: setting GDM_LANG=tr_TR.utf8
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=tr_TR.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=lightdm-xsession
dbus-update-activation-environment: setting XAUTHORITY=/home/ahmett/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/ahmett
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/ahmett
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg/pardus:/etc/xdg
/usr/bin/x-session-manager: X server already running on display :0
xfce4-session: GNOME compatibility is enabled and gnome-keyring-daemon is found on the system. Skipping gpg/ssh-agent startup.

(xfce4-session:741): xfce4-session-WARNING **: xfsm_manager_load_session: Something wrong with /home/ahmett/.cache/sessions/xfce4-session-pardus:0, Does it exist? Permissions issue?

(xfwm4:769): xfwm4-WARNING **: Error opening /dev/dri/card0: Böyle bir dosya ya da dizin yok

** (wrapper-1.0:836): WARNING **: No outputs have backlight property

(wrapper-2.0:837): Gtk-WARNING **: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:831): Gtk-WARNING **: Theme parsing error: :1:47: The style property GtkWidget:focus-padding is deprecated and shouldn’t be used anymore. It will be removed in a future version

(wrapper-2.0:831): Gtk-WARNING **: Theme parsing error: :1:79: The style property GtkWidget:focus-line-width is deprecated and shouldn’t be used anymore. It will be removed in a future version

(wrapper-2.0:831): Gtk-WARNING **: Theme parsing error: :1:109: The style property GtkButton:default-border is deprecated and shouldn’t be used anymore. It will be removed in a future version

(wrapper-2.0:831): Gtk-WARNING **: Theme parsing error: :1:137: The style property GtkButton:inner-border is deprecated and shouldn’t be used anymore. It will be removed in a future version

(wrapper-2.0:831): Gtk-WARNING **: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(xfce4-terminal:911): Gdk-CRITICAL **: gdk_window_get_window_type: assertion ‘GDK_IS_WINDOW (window)’ failed

(wrapper-1.0:836): GLib-GObject-WARNING **: g_object_notify: object class ‘UpClient’ has no property named ‘g-name-owner’

(xfsettingsd:777): GLib-GObject-WARNING **: g_object_notify: object class ‘UpClient’ has no property named 'g-name-owner’
xfwm4: Fatal IO error 4 (Sistem çağrısı kesme ile engellendi) on X server :0.0.
xfdesktop: Fatal IO error 4 (Sistem çağrısı kesme ile engellendi) on X server :0.0.


(𝗄𝖺𝖺𝗇) #7

Temiz yükleme yapmanız gerekecek, Yükleme işleminden sonra yeni bir tty (Text only console) açarak lightdm e çıkış yapıp (ctrl +alt + F2 gibi) Xfce açık değilken yüklemeyi gerçekleştiriniz.

sudo apt-get update
sudo apt-get install gdm3 gnome-shell
Yükleme sırasında gdm / lightdm seçiminde gdm seçiniz.


(Muhammed YILMAZ) #8

Bu cevap benim için mi? Temiz yüklemeden kastınız Pardus’u değil sadece o iki paketi sanırsam.
Ben yükleme sırasında lightdm’yi seçiyordum, onunla mı alakalı bir durum?
Normalde de lightdm ile gnome çalışmıyor mu yoksa Pardus’a özel bir sorun mu?


(𝗄𝖺𝖺𝗇) #9

Pardus 17 için gnome yüklemede sorun çıkanlar için. Pardus 17 yi yeniden yükleyerek, yukarıdaki şekilde kurulum yaparak deneyiniz.


(Muhammed YILMAZ) #10

O zaman vazgeçtim ben :slight_smile:
Yardımınız için teşekkürler…


(Tufan2017) #11

Ubuntu arayüzü kurmak mümkün mü?:grinning:


(𝗄𝖺𝖺𝗇) #12

Terminalden sudo apt-get install mate-* komutu ile yükleyebilirsiniz.


(Tufan2017) #13

Kaan Bey

Yükledim. fakat mate arayüzü ubuntu ile aynı değil. Ben tamamen ubuntu desktop arayüzü ve kullanımına sahip bir masaüstünü kastetmiştim.

Mümkün mü acaba?


(Muhammet Kara) #14

Merhabalar,

Ubuntu artık GNOME masaüstü ortamını kullanıyor.

Saygılarımla.


(Aydın Yakar) #15

DDE ubuntu arayüzüne (toolbar için) daha yakın :slight_smile: veya xfce ile de bir çok farklı görsel düzenleme şansınız var…


(Tevfik Ozden) #16
  • Pardus 17.1 deposundan,
  • Gnome masaüstü kurmak mümkün ve sorunsuz çalışıyor,
  • "synaptic " Paket yöneticisi ile,
  • " gnome " arayın, ( Full GNOME Desktop Environment, with extra components )
  • kurun. işletim sistemini yeniden başlatın,
  • kullanıcı girişi penceresi sağ üst köşede,
  • " gnome masaüstünü seçin, kullanıcı şifresi ile giriş yapın,
  • gnome masaüstünüzü kullanın .

(system) #17