Pardus 19.1 e mBlock kurulum hk

(Berkant) #1

Merhabalar ,
mBlock çalışması sorunun üstesinden gelemedim yardımcı olursanı sevinirim.
mBlock programını kuruyorum menüden ikonunu görüyorum, açılsın diye basıyorum menü kapanıyor program açılmıyor ne yaptıysam olmadı,17.3 sürümünde acıyordu kulandım da 19.1 yükleyince açamadım , 17.3 te de hata veriyordu oracle-java8 şimdi onu da yüklüyorum yine olmuyor nerede yanlış yapıyorum bilemedimmBlock .Yardımlarınız için şimdiden teşekkür eder iyi günler dilerim.

0 Likes

(𝗄𝖺𝖺𝗇) #2

Terminalden sudo apt install libgconf-2-4 komutunu çalıştırıp mblocku çalıştırtın.

2 Likes

(Berkant) #3

Kaan bey Allah Razı olsun Uzun zaman sonunda oldu Teşekkürler.Peki bu hata haricinde bu konuda da bana yrdımcı olabilirmisiniz? Arduino UNO ile baglantıyı sağlıyorum kodumu yazıyorum Arduino bağlı iken koduArduinoya gönder dediğimde başarısız oluyor Resimde ki gibi bir hata alıyorum.Aynı kodu Arduino nun kendi proramına kopualayıp yapıyorum Karta yükleyip çalıştırıyor.Yardımcı olursanı sevinirim.mBlok%20Kod%20G%C3%B6nderme%20Hatas%C4%B1

0 Likes

(𝗄𝖺𝖺𝗇) #4

1- Yükleme tam başlama sırasında arduinoya reset atarak deneyin.
2- Arduinoya takılı olan bir haberleşme bileşeni varsa pinlerini çıkartın. (rx,tx)
3- Programın sağ üst köşesinden bağlan menüsünden usb yi seçin.
4- /dev/USB* ya da /dev/AMC* olarak görünen bağlantı noktarısına tüm izinlerini verin (sudo chmod 777 /dev/xxx)

0 Likes

(Berkant) #5

Merhaba Kaan bey , Dediğiniz gibiyaptım yalnızca mBlock ve Arduino ya baglanırken dikkat ettim bağlantı yerinde /dev/ttyUSB0 yazıyor aynı yermi oluyor orası bilemedimmBlock%20usb%20baglant%C4%B1s%C4%B1 /dev klasörüne girdim usb klasörün içinde hiddev0 dosyası var sağ altında çarpı işareti vardı izinlerini açtım bilgisayarı restart edip tekrar programı açıp denedim olmadı :frowning: biraz araştırdım ch340 cipi bazen driver istiyormuş onu bulup yüklicem inşallah olur.Teşekürler.

0 Likes

(𝗄𝖺𝖺𝗇) #6

Yer doğru. Hangi arduinoyu kullanıyorsunuz?
Terminalden izin vericeksiniz komutu yazmıştım.

0 Likes

(Berkant) #7

Kulandığım Arduino UNO (klon) . Verdiğiniz kodu girdim tüm izinler verildi baktım hepsi açıktı , denedim gene olmayınca akşamakadar birsürü daha birşeyler yaptım denedim olmadı sonra baktım usb dosyası kayboldu /dev klasöründen, bende sistemi yeniden kurdum.Sıfır iken sistemde neden /dev klasöründe /dev/ttyUSB0 klasörü yok sonradan mı oluşuyor? Birde benim id gruplarım hepsi sıfır ve hepsi root yanlış mı yükledim?

0 Likes

(𝗄𝖺𝖺𝗇) #8

/dev/ttyUSB0 , usb kablosunu taktınızda otomatik oluşur, kabloyu çıkarttığınızda otomatik silinir.

0 Likes

(Berkant) #9

Evet verdiğiniz komutu Yaptım yalnız olmadı yine gün içinde bisürü şey denedim akşam da artık /dev dosyasında artık usb dosyasını sildim herhalde ve yok oldu. Bende Pardüsü yeniden kurdum galiba seri port yapılandırılması olmuyor. Arduino uno (klon) kartim. dmesg kodunu girince kartin ttyUSB portunu kulandığını gösteriyor ama ls -l /dev/ttyUSB* yazınca böyle dizin yok diyor. Baya kafam karıştı şimdi sıfırladım herşeyi sakin sakin güncelemeleri yaptıktan sonra bidaha deniyeceğim.:slight_smile:

0 Likes

(Serkan Gündoğdu) #10

Bende bembeyaz ekran şeklinde açılıyor 17.1 de de aynıydı hiçbir şekilde çalıştıramadım.

0 Likes

(Bekir Uzun) #11

mblock hiç kullanmadım.
oluşturduğunuz kodu arduino kendi programı üzerinden göndermeyi denediniz mi?

0 Likes

(Serkan Gündoğdu) #12

Arduino ide var kullanıyorum fakat öğrencilere ders anlatırken mblock çok faydalı oluyor

0 Likes

(Berkant) #13

Arduino ya yükle dediğinizde mi oluyor böyle? Bende birtürlü orayı aşamadım Arduino ya direkt kodları gönderemiyorum Windows olanlar yüklemeden önce programı yükle seçenekleri var Ubuntu versionunda çıkmıyor bu menüler.Arduino BGO ile yükle dediğimde yüklüyor ama mBlok üzerinden bende kod gönderemedim hala bi çözümünü bulamadım :neutral_face:

0 Likes

(Serkan Gündoğdu) #14

İlk açılırken böyle oluyor takılı kalıyor beyaz ekranda

0 Likes

(Berkant) #15

Merhabalar , Dün mBlock destek ekibine sorulmuş aynı sıkıntıdan kaynaklanan problem hakkında soru buldum , soran kişiye cevap olarak şuan bununla ilgilenemeyeceklerini belirtmişler,çünkü mBlock 5 versiyonuna odaklanmış durumundan dolayı bir çözüm bulunamayacak üst versiyon çıkıyor çünkü . buda okuduğum site adresi : https://forum.makeblock.com/t/uploading-code-to-arduino-uno-from-mblock-4-0-4-software-ubuntu-16-04-3-lts-64bits/14111.

0 Likes

(Cüneyt Ulusoy) kapatıldı #16

Bu konu son cevaptan 10 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

0 Likes