pardus 19.3 nodejs ve npm uyumsuz

merhaba. pardus 19.3 sürümününde depodaki nodejs versiyonu 10.2.10
npm versiyonu ise 5.8.0
bu iki versiyon birbirine uyumsuz. npm komutları çalışmıyor.
yaptığım araştırmalarda nodejs 10.x versiyonu için npm 6.x veriyonu olması gerekiyormuş ancak depoda yok. npm 6.x versiyonu nasıl kurabilirim?

Buradan el ile Linux x64 sürümünü indirip /usr/ dizinine açabilirsiniz.

(yani klasör içindeki:

  • node-v12.18.3-linux-x64/include/node -> /usr/include/node
  • node-v12.18.3-linux-x64/bin/node -> /usr/bin/node

  • şeklinde açılmış olacak)

Bu komutla kopyalayabilirsiniz. Önce node-v12 klasöründen README.md gibi dosyaları silmeyi unutmayın.

sudo cp -R node-v12.18.3-linux-x64/* /usr/
© 2020 TÜBİTAK