Pardus 21 Nvidia Sürücü Yükleme Sorunu

Herkese merhabalar,

Pardus 21 sürümü gerçekten çok başarılı olmuş. Emeği geçenlere teşekkür ediyorum. Uzun zamandır Ubuntu kullanıyordum, Pardus’a geçtim ve böyle devam etmek istiyorum ancak Nvidia ile ilgili sıkıntılarım var.

Yaptığım işlemler şunlar:

  1. Öncelikle nividia-detect paketini kurdum. Ardından çalıştırdım.
nvidia-detect
  1. Bana 3 farklı driver sundu ve nvidia-driver komutunu çalıştırmamı önerdi. Ben de çalıştırdım.
It is recommended to install the
    nvidia-driver
package.

  1. Bilgisayarı yeniden başlattıktan sonra Nvidia X-Server Setting programı açıldı. Ancak daha önce Ubuntu’da gelen “X Screen 0” gibi menüler gelmedi. Bunun nedeni nedir? Open GL ayarlarının bulunduğu seçenekler de gelmiyor.

Not: Terminalde nvidia-smi yazdığım zaman aşağıdaki çıktıyı alıyorum.

  1. Aşağıdaki komut çalışmıyor.
sudo prime-select nvidia

Sizlerden aşağıdaki konularda yardım bekliyorum.

a) Neden X Screen 0, Open GL gibi menüler gelmiyor?
b) Nvidia ile Intel arasında geçiş yapmak için ne yapmam gerekiyor? Çünkü prime-select komutu çalışmıyor, komut bulanamadı diyor.
c) Steam’i kurup CS Go oynadım. Performans çok iyi ama ekranın ortasında dalgalanma oluyor. Bu sorunu nasıl düzeltebilirim?

Yardım edenlere şimdiden teşekkür ederim. Pardus, Ubuntu’ya göre çok daha hızlı ve stabil çalışıyor. Geri dönmek istemiyorum.

Ubuntudaki nvidia sürücüsü yamalı olduğu için ek ayarlar gelmektedir. (Debian ve diğer tabanlarda bulunmuyor.)

Bir uygulamayı nvidia ile kullanmak için aşağıdaki gibi komut kullanın:

__NV_PRIME_RENDER_OFFLOAD_PROVIDER=NVIDIA-G0 __GLX_VENDOR_LIBRARY_NAME=nvidia __NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only MANGOHUD=0 gamemoderun <komut>

Dalgalanma sorunu için ayarlardan vsync açmalısınız. Bu ayar biraz fps düşüşüne neden olabilir.

2 Beğeni

Cevabınız için teşekkür ederim. İnternetteki Debian kurulumlarında bahsettiğim menüler geliyor. Daha önce Manjaro gibi farklı tabanlı dağıtımlara kurmuştum, orada da geliyordu.

Bir de Nvidia ile Intel arasında nasıl geçiş yapabilirim? Bazı Gnome eklentileri var ama sürümleri uyuşmadığı için çalışmıyor.

Merhabalar , konuyla ilgili çözüm buldunuzmu ,bende aynı prbolemi yaşıyorum hDmi çalışmıyor forumlarda yazan bir çok şeyi denedim , olmadı maalesef …