Raspberry pi4 hdmi ve ses sorunu

Merhaba. Raspberry pi 4 e Pardus beta sürümünü kurdum. Ancak iki problemle karsılaştım. Goruntu ve ses için Raspbery deki 1. Hdmi cıkısını kullanınca yalnızca 640x480 cozunurlukte görüntü veriyor. 2. Hdmi cıkışında çözünürlüğü ayarlayabilme imkanı veriyor. (her iki cıkışında farklı monitorlerde denedim) Ama ses için her iki çıkıştada ses alamıyorum. Karıstırıcı ayarlarında hdmi ses cıkış secenegi hiç görünmüyor. Yardımcı olabilirseniz sevinirim (varsayılan tanımlı olarak açılan xfce arayüzünü kullanıyorum)

1 Beğeni

sudo nano /boot/firmware/config.txt
dosyasındaki şu satırı böyle bir deneyiniz
#dtparam=audio=on
ctrl+x y kaydedin ve tekrar başlatin

1 Beğeni

Tesekkur ederim ama yine olmadi. Sistemde hic ses driveri yok gorunuyor. Halbuki alsa ve pulseaudio yuklu.

Tesekkur ederim ama işe yaramadı

Birde bunu denermisiniz
Sudo apt - - purge remove pulseaudio pavucontrol

Sudo apt install pulseaudio pavucontrol

Merhabalar;
Ses kartının aktif olabilmesi için config.txt içine aşağıdaki satırın olması gerekmektedir.

dtparam=audio=on

sonrasında mpv, mplayer, vlc vb gibi bir programla ses yada video dosyalarını test edebilirsiniz. Ses hala gelmiyorsa pavucontrol programını çalma işlemi devam ediyorken açıp ayarlara bakın. Normal şartlarda raspi 4 üzerinde çalışan pardusta ses sorunu ile karşılaşmadım. mpv programını kurup aşağıdaki komut çıktısını paylaşırmısınız.
mpv --audio-device=help

Birde hdmi çözünürlüğünün düşük oldugunu belirtmişsiniz. Grafik ekranda iken bir terminal açıp xrandr komut çıktısınıda paylaşabilirmisiniz.

Merhaba. Dediginiz duzeltmeden sonra sorun cozuldu, fakat sistemi guncelleyince hem hdmi ses hemde broadcam wifi gitti. Pavucontrol kisminda hdmi gorunmuyor, ayni sekilde ag kisminda kablosuz ag secenegi hic yok. Gerekli suruculeri yuklememe ragmen duzelmedi. Wifi icin surucu yukleme sirasinda linux header ile ilgili bir hata veriyor ve internetten butun onerilen yontemleri denememe ragmen duzelmedi. Buradan raspberry pi 4 e pardus beta surumunu kuracak arkadaslarida bilgilendirmek icin bunu yaziyorum. Sudo apt-get update/upgrade ile sistemi guncelleyince yada dist-upgrade ile cekirdek guncelleyince sistemde yukarida bahsettigim ayarlar bozuyor. Onerisi/bilgisi olan arkadaslar yardimci olabilirlerse sevinirim. İyi calismalar dilerim.

Hüseyin bey, konuyla ilgisi yok gibi ama USB portlarını kontrol edebilir misiniz? Ben ve bir arkadaş güncelleme aldırdıktan sonra normal PC versiyonda USB’lerimiz gitti. Sizde de öyle olduysa sorunun nereden kaynaklandığına dair bir fikir ve tesbit oluşabilir. Cihazınıza bir USB bellek takıp erişebiliyor musunuz, test edebilir misiniz?

sudo rpi-update komutu ile rpi karnele geciş yapabilirsiniz.

merhaba. dediginiz gibi usb portlarda calısmıyor. ayrıca sudo rpi-update komutuda lsblk: /dev/root: not a block device hatasını veriyor. cozum bulamadım. ilginiz icin tesekkur ederim.

Rasgele konuşmak istemiyorum ancak öyle anlıyorum ki bu durum pardusla ilgili değil; kernel ile ilgili. Ekibin linux kernel ekibiyle iletişim kurması gerekebilir.

Daha önce de farenin orta tekerine basıp aşağı-yukarı çekerek gerek tarayıcılarda gerekse pdf, ofis belgeleri gibi belgelerde sayfayı aşağı yukarı yumuşak kaydırma yapabiliyorduk. Bir kernel güncellemesiyle bu özellik uçtu maalesef. I zamanlar lubuntu 16.03 kullanıyordum hangi kernel olduğunu unuttum.

Sizin sorununuz da doğrudan kernelle ilgili olabilir.