RTL8723BE Sürücüsü Sinyal Zayıf Sorununu Çözme

(Enderali) #1

Herkese merhaba değerli Pardus kullanıcıları ve sistem geliştiricileri. Daha önce, bu kablosuz kartı (RTL8723BE) kullanan dizüstü bilgisayarımda sinyal düşüklüğünden dolayı internet bağlantısı sorunu yaşamaktaydım. Sinyal zayıf olarak görünüyor, modem yanında olmadığım sürece kablosuz bağlantı yapamıyordum. Forumda birçok arkadaşın da aynı sorundan şikayetçi olduğunu görmekteyim. Bununla ilgili bir rehber hazırladım ve sorunu çözebiliyoruz.

Öncelikle sorunun, bu kartın üzerinde yer alan 2 adet anten girişinden kaynaklandığını belirtmek isterim. Kartın üzerinde 2 tane anten girişi bulunuyor fakat yalnızca bir tanesinde anten mevcut dolayısıyla anten takılı olan girişi keşfedip, sistemimize tanıtıp sinyal güçlendirme yapmış oluyoruz.

  1. Öncelikle “Ev” dizinini açıp sağ tıkla “Burada Terminal Aç” diyoruz.
    Açılan ekranda aşağıda verdiğim işlemleri tekrarlamanızı rica ediyorum.

  2. Açılan komut ekranında şu kodu yapıştırmanız gerekiyor. Bu ise, yeni sürücüleri indirmenizi sağlayacaktır.

git clone https://github.com/lwfinger/rtlwifi_new/

  1. “Ev” dizinine indirdiğinizi varsayarak yeniden aynı dizindeki komut satırına sırasıyla şu kodları yapıştırıyoruz. Bir işlem bitmeden diğer kodu yazmayınız.

cd rtlwifi_new
make
sudo make install

  1. Yükleme işlemi tamamlandıktan sonra aşağıdaki kod ile kablosuz kartımızı devre dışı bırakıyoruz.

sudo modprobe -r rtl8723be

  1. Bu işlemin ardından sıra anten seçimi işlemine geliyor. Aşağıdaki kodu komut sistemine yapıştırın.

sudo modprobe rtl8723be ant_sel=1

  1. Sİsteminizi yeniden başlatın.

Burada dikkat edilmesi gereken husus, sondaki ant_sel=1 ya da 2 ibaresi “antenin bulunduğu girişi temsil ediyor” girdiğimiz kod ise bunu bilgisayara tanıtmak anlamına geliyor. 1 olarak deneyip bilgisayarınızı yeniden başlatın. Eğer sinyal düşüklüğü hala devam ediyorsa aşama 4 ve 5’i yeniden yapıyoruz fakat bu sefer ant_sel=2 olarak değiştirip, hangisinden verim alıyorsanız onu kullanmaya başlayabilirsiniz.

Eğer 1 veya 2 deneyip her ikisinde de sorun yaratıyorsa 0 ibaresini koymayı deneyin. Sorununuz mutlaka çözülecektir.

Not: Kernel güncellemelerinde büyük boyutlu sistem güncellemelerinde bu işlemleri tekrardan yapmanız gerekebilir. Hepinize iyi günler dilerim.

4 Likes

(Enderali) #2

Yukarıdakilere ek olarak;

echo “options rtl8723be ant_sel=1” | sudo tee /etc/modprobe.d/rtl8723-ant-sel.conf

echo “options rtl8723be ant_sel=2” | sudo tee /etc/modprobe.d/rtl8723-ant-sel.conf

Komutları daha kalıcı bir çözüm sağlayacaktır.

0 Likes