Sudo modrobe wl hata

Pardus’ a BCM43142 kuracaktım.
Ama modpro de hata vermeye başladı kernel güncellemesi de yaptım.

BIOS’a girip Secure Boot’u bulun ve bunu enable hâlinden Disable yapıp bahsi geçen komutu yeniden çalıştırın.

Legacy.
Uefi desteklemiyor.

UEFI olmasına gerek yok. BIOS ayarlarınızda Secure Boot diye bir yer olmalı. Bulduğunuzda Enable olduğunu göreceksiniz onu disable şeklinde ayarlayın.

Yok.
Boot sekmesinin atında olması gerekiyor.
Ama yok. uefi’ ye aldığımda geliyor.
Ama bu seferde no bootable device diyor.
Pardon security nin altındaymış
Ama yine yok. UEFİ’de geliyor.

Kernel güncelleme yaptınız mı?

Evet. Yukarıda yazmıştım zaten.

Çekirdek (kerel) güncellemesi yapmadan önce bu komutları denemişmiydiniz?

Denemediyseniz, bilgisayarın açılışında Pardus’u seçme ekranında gelişmiş seçeneklerine basıp düşük çekirdeği seçebilir misiniz?

Ayrıca legacyde görünmüyorsa sanırım secure boot kapalı oluyor emin değilim ama biz bir bilgisayarda öyle çalıştırmıştık, bilgi bilgidir.

Evet. Denemiştim.Sıfırdan kurup önce kerneli yapsam düzelir mi?

Sıfırdan kurun ama yükseltme yapmayın. İsterseniz direk çekirdek yükseltilmiş sürümünü kurun:
bkz. Pardus Backports Sürümleri
İsterseniz de normal sürümü kurun.
Bu çekirdek güncellemesinden kaynaklı olabilir çünkü.
Normalde bu komutların çalıştırması lazım, kaç kere çalıştırdık. Dediğiniz gibi secure boot, legacy modda görünmeyen bir bilgisayarda bile. Sanırım çekirdek güncellemesinden kaynaklanıyor.

1 Beğeni

Sağol. Kernel güncellemeli bulamamıştım.
Bunu deneyeyim.

http://ftp.de.debian.org/debian/pool/non-free/b/broadcom-sta/broadcom-sta-dkms_6.30.223.271-5_all.deb

Şu paketi indirip sudo dpkg -i isim ile kurmanız lazım. Ondan sonra modprobe.

https://wiki.debian.org/wl

Burdaki mevcut dkms li paket üstteki linktekiyle aynı ama linkteki daha yeni. Eskisi kurarken sorun çıkarıyor.

Olmadı yine :frowning:

Pardon ya ben eskisini atmışım. Şursan yenisini seçer misin mayıs 2021 olan vardı şurdaki driverlarda. Dkms li olan, büyük ihtimalle all yazan olacaktır. Olmazsa sudo apt purge broadcom-sta-dkms yaz işlemi geriye alır.

http://ftp.de.debian.org/debian/pool/non-free/b/broadcom-sta/

1 Beğeni

Hocam wifi sorununuz için sudo modprobe wl komutundan önce başka komut girdiniz mi?
Eğer bu komuttan önce başka komut girmeyip direk bu komutu yazdıysanız şöyle yapınız:

sudo apt purge broadcom-sta-common broadcom-sta-dkms dkms

sudo apt update && sudo apt full-upgrade -yq

sudo apt install linux-headers-$(uname -r) build-essential dkms broadcom-sta-common broadcom-sta-dkms

sudo modprobe wl

Önce bunları yazmıştım zaten.
Bu arada abackports indirdim ama ine aynı.

Yarın deneyeyim. Şu an kuramam

Olduuuuu. Çok sağolllllllllllll. Kaç zamandır bulamıyordum. :heart_eyes: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:
Çok sağol ne kadar teşükkür etsem azdır.

1 Beğeni

Bu konu son cevaptan 30 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.