.tar.xz, tar.gz Gibi Dosyaların Kurulumu


(Enes Boğaz) #1

Hocam iyi günler,
Ben internetten bir program indirdim dosya uzantısı “.tar.xz” bunu nasıl kurarım?
NOT: .tar.xz gibi dosyaların birer .rar gibi sıkıştırılma dosyalar olduğunu biliyorum, sadece içindeki dosyaları nasıl kuracağımı bilmiyorum.
Allah razı olsun


(Cüneyt Ulusoy) #2

Şu konuda değinmiştik;


(Enes Boğaz) #3

Hocam şöyle hata verdi:
Unknown type of package, Python-3.6.4.tar.xz.


(Cüneyt Ulusoy) #4

Dosyayı arşivden çıkararak deneyebilir misiniz?


(Enes Boğaz) #5

çıkardıktan sonra ne yapayım hocam?


(Cüneyt Ulusoy) #6

çıkan dosyaların uzantıları? ya da çalıştırılabilir dosya var mı?


(Enes Boğaz) #7

Hocam buyrun siz bakın:


(Cüneyt Ulusoy) #8

sudo sh ./install-sh

yükleme işlemini çalıştırması gerekiyor.


(Enes Boğaz) #9

Hocam böyle hata veriyor;

./install-sh: no input file specified


(Cüneyt Ulusoy) #10

sudo apt-get install gcc make

./configure
make
sudo make install


(Ali KOCA) #11

Merhaba hocam;
Eğer python paketi ise depodan kur, veya pip de güzel bir araçtır. Bununla zaman harcama derim.

Selamlar.


(Enes Boğaz) #12

Hocam her şey hüzel gisiyordu en son komutun en son 3 satırında böyle bir hata verdi (Tabi hataysa):

zipimport.ZipImportError: can’t decompress data; zlib not available
Makefile:1099: recipe for target ‘install’ failed
make: *** [install] Error 1


(Cüneyt Ulusoy) #13

Dosyanın linkini gönderebilir misiniz?


(Enes Boğaz) #14

https://www.python.org/ftp/python/3.6.4/Python-3.6.4.tar.xz


(Cüneyt Ulusoy) #15

Merhaba,

zlib paketlerini yükleyerek son işlemi tekrar çalıştırınız. Kurulum tamamlanıyor.

sudo apt-get install zlib*


(Enes Boğaz) #16

Sağolun hocam yüklendi. Hangi gönderinizi çözüm olarak işaretliyeyim?


(Cüneyt Ulusoy) #17

:slight_smile: konunun başladığı ve bittiği yer çok farklı


(Enes Boğaz) #18

Haklısınız o zaman ilk gönderinizi işaretliyeyim.
Bkz.


(Enes Boğaz) #19

Hocam kurulumda sıkıntı olmuyor fakat uçbirime “python 3.6.4” yazdığımda girmiyor. Neden olabilir?


(Enes Boğaz) #20

Hocam kusura bakmayın araştırınca buldum, komut;

python3.6

buymuş. :smiley: