Vmware Workstation Kurulum Hatası

Merhaba,

Vmware Workstation yükleme esnasında hata aldım. İnternetten araştırdım fakat çözüm bulamadım. Aşağıdaki komutları çalıştırdım. Aldığım hatayı da görebilrisiniz.

Pardus 21.0 kullanıyorum.

Ekran Görüntüsü - 2021-10-10 03-17-32

beri@pardus:~/Masaüstü$ uname -r
5.10.0-8-amd64

beri@pardus:~/Masaüstü$ sudo apt install linux-headers-$(uname -r)

Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor… Bitti
Durum bilgisi okunuyor… Bitti
E: linux-headers-5.10.0-8-amd64 paketi bulunamadı
E: ‘linux-headers-5.10.0-8-amd64’ ifadesine eşleşen herhangi bir paket bulunamadı

beri@pardus:~/Masaüstü$ sudo apt-get install build-essential

Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor… Bitti
Durum bilgisi okunuyor… Bitti
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
g++ : Bağımlılıklar: cpp (= 4:8.3.0-1) ama 4:10.2.1-1 kurulacak
Bağımlılıklar: gcc (= 4:8.3.0-1) ama 4:10.2.1-1 kurulacak
libc6-dev : Bağımlılıklar: libc6 (= 2.28-10) ama 2.31-13 kurulacak
Bağımlılıklar: libc-dev-bin (= 2.28-10) ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

beri@pardus:~/Masaüstü$ dpkg -l | grep linux-headers

ii linux-headers-4.19.0-17-amd64 4.19.194-3 amd64 Header files for Linux 4.19.0-17-amd64
ii linux-headers-4.19.0-17-common 4.19.194-3 all Common header files for Linux 4.19.0-17
ii linux-headers-amd64 4.19+105+deb10u12 amd64 Header files for Linux amd64 configuration (meta-package)

Teşekkürler şimdiden.

Merhabalar önçelikle vmwareyi kaldırın ardındın

terminale sudo apt-get update yapdıktan sonra
sudo apt-get install linux-headers-$(uname -r) kurun ve vmwareyi sitesinden indirip

https://www.vmware.com/go/getworkstation-linux
indirdikten sonra indirilenlere gelince orda
terminal açıp
chmod +x VMware-Workstation-Full-16.1.2-17966106.x86_64.bundle
sudo ./VMware-Workstation-Full-16.1.2-17966106.x86_64.bundle
yapınca sorunsuz kurmanız gerekmektedir.

Öncelikle önceki linux kernellerine ait Linux Headers paketlerini KALDIRMANIZ GEREKMEKTEDİR.
Synaptic Paket yöneticisinden eski kernellere ait linux headers paketlerini kaldırın

Pardus 21 kullanıyorsanız
linux çekirdeğinizle ilgili Linux headers 5.10.x.x.x paketini
Pardus 19 ise Linux headers 4.19.x.x.x paketini Synaptic Paket yöneticisini açarak kolay bir şekilde kurun.

linux kernel sürümünüz ne ise onunla ilgili headers sürümünü kurmanız gereklidir

Synaptic Paket yöneticisinden arama kısmına headers yazarak linux headers paketlerini kolayca bulabilirsiniz

Ardından,
Sisteminize daha önce vmware’ı kurmadıysanız kurun. Sisteminizde VmWare yüklüyse doğrudan uçbirimi açıp

sudo vmware-modconfig --console --install-all

komutunu girip işlemin tamamlanmasının ardından

sudo /etc/init.d/vmware status

komutuyla kontrol edin.

Herşey Ok ise VmWare’ı kullanmaya başlayabilirsiniz.

Ayrıca ekte atmış olduğum linux header’ları yükledim.

sizin headerslarda neden bpo çıkıyor? Pardus değil mi kullandığınız sistem?

Bakın, Bendeki paketler şu şekilde:

beri@pardus:~/Masaüstü$ sudo /etc/init.d/vmware status
Module vmmon not loaded
Module vmnet not loaded

Bu şekilde çalışmaz çünkü modülleri derlememiş. Eksik bir şey var. linux headers paketlerinden doğru olanı kurduğunuza emin misiniz?

Kullandığım sistem Pardus 21 gnome

Bende sizin gibi çıkmıyor sanırım. sorun sanırım burdan kaynaklanıyor temelde.

evet asıl sorun bu. sizde paketler farklı çıkıyor ve bundan dolayı derleme yapmıyor