Wine Kurulumu Nasıl?

bu komutları denedim olmadı… .exe uzantılı dosyayı birlikte aç’a basıyorum wine yazıyorum çıkmıyor.

lütfen başka bir çözüm yolu varsa yardımcı olur musunuz…

Saygıyla…

1 Beğeni

XFCE kullandığınızı varsayarak.

Konsolu açın ve sudo apt-get remove wine yazın.
Ardından ;

  • Konsola sudo thunar yazın.

  • Açılan dosya yöneticisinde sol üstteki (en üstteki) “Dosya Sistemi” yazan yere gelin.
    Bkz. 2

  • Buradan “etc” klasörünü buyun ve girin ve ardından “apt” klasörünü bulun ve girin. Buradaki “sources.list.d” dizinine girin ve buradakilerin hepsini temizleyin (Seçin ve silin).

  • Dosya yöneticisini sağ üstteki "x"e basarak kapatın ve konsala geri dönün.

  • Konsola sudo nano /etc/apt/sources.list yazın. Buradaki depo adresleri aşağıdakinden farklı ise hepsini silin ve aşağıdaki depo adreslerini kopyalayıp konsola yapıştırın.

deb http://depo.pardus.org.tr/pardus onyedi main non-free contrib
deb-src http://depo.pardus.org.tr/pardus onyedi main non-free contrib

deb http://depo.pardus.org.tr/guvenlik onyedi/updates main non-free contrib
deb-src http://depo.pardus.org.tr/guvenlik onyedi/updates main non-free contrib

  • Eğer Pardus 17 ve üzeri sürümler kuruluysa 2. paragrafı yazmanıza gerek yoktur.

  • Bu şekilde ayarladıktan sonra uçbirimden (konsoldan) kaydetip çıkmak için
    sırasıyla CTRL+X sonra “e” tuşuna basın ve “Enter” tuşuna basın.

  • Şimdi uçbirime (konsola) sırasıyla;
    sudo dpkg --add-architecture i386
    sudo apt update
    sudo apt upgrade
    sudo apt install wine wine64 wine32:i386
    sudo apt -f install

  • Artık bitti, .exe´li dosyaya çift tıkladığınızda açılacaktır.
    Eğer ki açılmazsa
    dosyaya sağ tıklayıp "Birlikte Aç"ın üstüne fare imlecini getirip "Diğer Uygulama ile Aç…"a basın.
    En alttaki "Bu tür dosyalar için öntanımlı olarak kullan."a basıp bir üstündeki "Özel bir komut kullan:"a basın. Boş yere “wine” yazın ve hemen sağ tarafındaki “Görüntüle” seçeneğine basın.
    Buradaki sadece “wine” yazan dosyayı seçin (bkz. 5) ve sağ alttaki “Aç” düğmesine basın.
    Şimdi özel komut kullan yerinde “/usr/bin/wine” olmuş olması gerekiyor. Şimdi de sağ alttaki "Aç"a basın.

Bu kadar! Kolay gelsin.

Saygıyla, Hayırlı günler

3 Beğeni

****BUNLAR SİLİNMİYOR DOSYALAR….

@RizeLiEnes53 Hocam onların silinmesini gerek yok gibi görünüyor.
Ama yine de silmek isterseniz, bulunduğunuz dizinde sudo rm -rf dosya_adı yazabilirsiniz.

sudo apt autoremove komutu ile de gerek duyulmayan paketleri kaldırabilirsiniz.

Bu arada çalıştı mı?

Saygıyla

1 Beğeni

**yok çalıştıramadım.**wine çalıştır diye birşey var başlatta :open_mouth:

Ben de depodan wine kurulumunu yaptım. Ancak kurduğum halde program görünmüyor. Acaba sistemsel bir sorun mu söz konusu ki ? Yardımcı olabilecek var mı ?

@adnanozkan Wine´dan mı bahsediyorsunuz?
Görünmesine gerek yok yani hata değil.

Saygıyla

1 Beğeni

@RizeLiEnes53 Hocam o zaman Wine kurulamamış.
Tekrar kurmayı deneyebilir misiniz?
Hatta bir de böyle deneyin: (Sırayla)
sudo apt update sudo dpkg --add-architecture i386 sudo apt install wine*

Eğer yine çalışmazsa sudo apt remove wine* yazarak az önceki komut ile kurmuş olduğunuz paketleri silebilirsiniz.
Bir deneyin, olmazsa yazarsınız.

Saygıyla

1 Beğeni

Teşekkürler. Eskiden fiziki olarak yer alıyordu. Aklımda öyle kalmış sanırım.

1 Beğeni

uçbirimde aşağıdaki komutu çalıştırarak wine kurulumu görebilir. ayar yapabilirsiniz

winecfg

1 Beğeni

Arkadaşlar Merhaba, Pardus ailesine yeni katıldım. İşim gereği bazı exe programları çalıştırmam lazım. Yorumlardaki çözümleri sürekli denedim lakim bi çözüme varamadım.Yani kuramadım veya çalıştıramadım. sürekli uyarılar alıyorum terminalde veya paket yöneticisinde. Ne yapmam gerekir eksik atladığım bir alanmı var anlamadın bilgisi olan arkadaşım yazabilir mi? Şunuda farkt ettim windows’tan alıdığım exe dosyalar Pardusta eksik gösteriyor tam göremedim bütün dosyaları.
Şimdiden teşekkürler.

1 Beğeni

Merhaba, ya paket yöneticisinden ya da uçbirimden yüklemeniz gerekmektedir. Uçbirimde, arkada paket yöneticisi olduğu için hata vermiş.
Kusura bakmayın, şu komut çalışmıyormuş:
sudo apt install wine*

Onun yerine Cüneyt Bey’in dediği;
sudo apt install wine wine64 wine32:i386
Yazınız ve önceki komutlarıda yazmayı unutmayın.
Ardından sudo apt -f install de yazınki bağımlılık eksikse yüklesin.

Saygıyla

1 Beğeni

Desteğiniz için teşekkür ederim Enes Bey,

Ben çözümü buldum depodam kanaklı olduğunu anladım. Kısa şöyle işlem yaptım.

konsol açarak aşağıdaki komutu uygulayınız;

sudo nano /etc/apt/sources.list

bir editör açılacaktır editöre aşağıdaki satıraları yapıştırınız

 deb http://depo.pardus.org.tr/pardus onyedi main non-free contrib
 deb-src http://depo.pardus.org.tr/pardus onyedi main non-free contrib

 deb http://depo.pardus.org.tr/guvenlik onyedi/updates main non-free contrib
 deb-src http://depo.pardus.org.tr/guvenlik onyedi/updates main non-free contrib

Sonra depoyu günceledim.

sudo apt-get update

Wine kurumuna geçiş yaptım ister paket yöneticisi ister uçbirimden size kalmış ;

sudo apt-get install --install-recommends winehq-stable

Eyebeam 1.5 Windowsda kullanmış olduğum çagrı merkezi uygumasını çalıştırdım :slight_smile:

1 Beğeni

napcaz bu wine’yi :frowning:

ogretmen@pardus:~/Masaüstü$ sudo dpkg --add-architecture i386
ogretmen@pardus:~/Masaüstü$ sudo apt update
Aynı: 1 Index of /pardus/ onyedi InRelease
Aynı: 2 Index of /guvenlik/ onyedi/updates InRelease
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Tüm paketler güncel.
ogretmen@pardus:~/Masaüstü$ sudo apt upgrade
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Yükseltme hesaplanıyor… Bitti
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
ogretmen@pardus:~/Masaüstü$ sudo apt install wine wine64 wine32:i386
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
** wine32:i386 : Bağımlılıklar: libwine:i386 (= 1.8.7-2) ama kurulmayacak**
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
ogretmen@pardus:~/Masaüstü$ sudo apt -f install
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
ogretmen@pardus:~/Masaüstü$ winecfg
bash: /usr/bin/winecfg: Böyle bir dosya ya da dizin yok
ogretmen@pardus:~/Masaüstü$`

Önceden winecfg açılıyordu şimdi o da yok

Selamün Aleyküm

Sırasıyla şu komutları deneyebilir misiniz acaba?

  1. Tüm wine paketlerini kaldıralım
    sudo apt purge wine*

  2. Sorun çıkaran depoları temizleyelim
    sudo rm -rf /etc/apt/sources.list.d/*

  3. Pardus’un resmi depolarını ekleyelim. (Aşağıdakinin tümü tek komuttur.)
    su -c "printf '### Official Pardus Repositories ###\n\ndeb http://depo.pardus.org.tr/pardus/ onyedi main non-free contrib\n# deb-src http://depo.pardus.org.tr/pardus/ onyedi main non-free contrib\n\ndeb http://depo.pardus.org.tr/guvenlik/ onyedi main contrib non-free\n# deb-src http://depo.pardus.org.tr/guvenlik/ onyedi main contrib non-free\n' | sudo tee /etc/apt/sources.list"

  4. Depoları güncelleyelim.
    sudo apt update

  5. Güncel Wine Kurulumu rehberindeki anlatıma göre wine kurulumunu gerçekleştirelim.

ben kuramadım ya yardım eden var mı

hata vb bilgi verebilir misiniz?

Evde wine çalışıyordu. Bahsettiğiniz gibi evde denedim oldu. Ancak okuldaki bilgisayarda şu hatayı aldım: Acaba bu durum MEB filitresi ile mi ilgili?

ogretmen@pardus:~/Masaüstü$ wget -nc https://dl.winehq.org/wine-builds/Release.key && sudo apt-key add Release.key
–2018-09-27 13:44:38-- https://dl.winehq.org/wine-builds/Release.key
dl.winehq.org (dl.winehq.org) çözümleniyor… 151.101.38.217
dl.winehq.org (dl.winehq.org)[151.101.38.217]:443 bağlanılıyor… bağlantı kuruldu.
> HATA: dl.winehq.org' sertifikası güvenilir değil.** **> HATA: dl.winehq.org’ sertifikası bilinen bir yayımcıya ait değil.
ogretmen@pardus:~/Masaüstü$

--no-check-certificate parametresini ekleyin. Yani şu şekilde komutun tam hali şu şekilde olmalı.

wget -nc --no-check-certificate https://dl.winehq.org/wine-builds/Release.key && sudo apt-key add Release.key

1 Beğeni

Buraya kadar tamam. Ancak bundan sonrası yine hata (Evdeki bilgisayarda olmuştu, okuldakinde hata veriyor):

> root@pardus:/home/ogretmen/Masaüstü# sudo apt-get update
> Aynı:  1 http://depo.pardus.org.tr/pardus onyedi InRelease
> Aynı:  2 http://depo.pardus.org.tr/guvenlik onyedi InRelease
> Yoksay:3 https://dl.winehq.org/wine-builds/debian stretch InRelease
> Yoksay:4 https://dl.winehq.org/wine-builds/debian stretch Release
> Yoksay:5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Yoksay:5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Yoksay:5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Yoksay:5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Yoksay:5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Hata:  5 https://dl.winehq.org/wine-builds/debian stretch/main amd64 Packages
>   server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
> Yoksay:6 https://dl.winehq.org/wine-builds/debian stretch/main all Packages
> Yoksay:7 https://dl.winehq.org/wine-builds/debian stretch/main i386 Packages
> Yoksay:8 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr_TR
> Yoksay:9 https://dl.winehq.org/wine-builds/debian stretch/main Translation-tr
> Yoksay:10 https://dl.winehq.org/wine-builds/debian stretch/main Translation-en
> Paket listeleri okunuyor... Bitti
> W: 'https://dl.winehq.org/wine-builds/debian stretch Release' deposunda Release dosyası yok.
> N: Böyle bir depodan gelen verilerin kaynağı doğrulanamayacağı için bu deponun kullanımı olası tehlike arz etmektedir.
> N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
> E: https://dl.winehq.org/wine-builds/debian/dists/stretch/main/binary-amd64/Packages alınamadı server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
> E: Bazı indeks dosyaları indirilemedi. Bu dosyalar yok sayıldılar ya da önceki sürümleri kullanıldı.
> root@pardus:/home/ogretmen/Masaüstü# sudo apt-get install --install-recommends winehq-stable
> Paket listeleri okunuyor... Bitti
> Bağımlılık ağacı oluşturuluyor       
> Durum bilgisi okunuyor... Bitti      
> E: winehq-stable paketi bulunamadı
> root@pardus:/home/ogretmen/Masaüstü#