Xfce yeni sürümü yükleme

Xfce 4.16 yı Parduse yüklemenin bir yolu var mı?

Ayni durumdan bende muzdaribim, xfce whisker menüyü guncelleyeyim dedim bağlılık paketlerini yukle yukle bitmedi ve sonuc hasarisiz oldum.

Pardus xfce, dde, kde ve gnome arayuzlerini kullanmak yerine kendi masaüstü arayüzünü yapsa cok güzel olur demek isterdim ama öyle bir hayale kapılmak istemiyorum çünkü sistem içinde kullandığı tema paketleri bile kopyala yapıştır.

Pardus ile yolumuza xfce, dde ve gnome arayuzleri ile devam edeceksek en azindan bunlarin en guncel versiyonlarını kullanalim…

https://www.google.com/search?client=firefox-b-e&q=how+to+download+xfce+4.16+debian

1-2 link çıkıyor ama bilemiyorum, ppa eklemek gerekiyor. Güvenilir mi güvenilmez mi. Pardus deneysel deposu vardı bi aralar duruyorsa oradan yüklenir belki.

Depo dışından masaüstü yöneticisi yüklemenizi önermem.
Çünkü Pardus içinde kullanılan masaüstleri ham değil. Yani dışardan güncelleme yaparsanız sisteminiz sorunlarla karşılaşabilir. Belki Pardusun deneysel, test depolarında vardır.

Deneysel depodan paket cekerek zaten kullanıyorum. Önce deneysel depodaki xfce4 paketlerini kurup daha sonra pardus-xfce-desktop kurunca 4.12 sürümü full kurulabiliyor. Son sürüm olan 4.16 yı kurabilmenin bir yolu var mı onu araştırıyorum. Gerçi Pardus Gnome üstüne cinnamon son sürümü bir şekilde kurmustum ama gdm ye hasar verdi sonra bir daha ilgilenemedim. Xfce son sürüm de hallolur gibi geliyor. Bakacaz artık.

Xfce 4.16 henüz kararlı sürüm olmadığı için depolarda yer almıyor.

http://www.linuxfromscratch.org/blfs/view/svn/xfce/xfce.html Şuradan yararlanarak kendiniz derleyebilirsiniz. Bunun dışında debian testing veya unstable depolarını pardusa ekleyip kurabilirsiniz ama sisteme ciddi zarar verme ihtimali söz konusudur. (Tavsiye etmem.)

bağımlılıklar insanda heves mi bırakıyor. o paket bunu istiyor şu paket onu istiyor. tam nasreddin hoca fıkrası halimiz. hoca, köylüsüne demiş adam akıllı bir helva yiyemedim şu fani dünyada. unu bulsalar şeker olmuyor , şekeri bulsalar yağ olmuyor. köylüsü de hocam ya hepsi bulunursa deyince, hoca o zamanda beni bulamıyorlar demiş. (biraz da gülelim :slight_smile: )

6 Beğeni

peki ekran kilitleme neden çalışmaz? bilmem işe yarar mı ama xflock4 içeriği böyle:

light-locker kullanıyorsanız onu da eklemelisiniz buraya

light-locker-command --lock

Peki lightdm değil de gdm aktifken neden çalışmıyor ekran kilitleme? Xfce yi gdm ile kullanıp ekran kilidi kullanabilmenin yolu var mı?

Pardus Debian (stabil) tabanlı olduğu için, internette Debian’a Xfce 4.16 sürümü yüklenmesi ile ilgili İngilizce arama yaptım, fakat herhangi bir anlatım çıkmadı. O yüzden Debian (stabil) tabanına yüklemenin mümkün olduğunu pek düşünmüyorum. Fakat aklıma gelen bir yöntem var, denemek isterseniz okumaya devam edin.

Ubuntu’da, Xubuntu (Xfce) takımının resmi PPA’sını kullanarak Xfce 4.16 sürümü yüklenebiliyor. PPA’lar Ubuntu sistemler için hazırlanmış kişisel yazılım depolarıdır. Pardus da Ubuntu gibi Debian tabanlı olduğu için, PPA depolarını kullanmak bir yere kadar mümkün. Bağımlılık sorunları çıkabileceği gibi, şansınız yaver giderse direkt çalışadabilir.

Xfce 4.16’nın Xubuntu’ya PPA deposu ile yüklenmesi ile alakalı buradaki dökümandan yola çıkarak Pardus’a kurmak için alttaki komutları deneyebilirsiniz. Sistemim Pardus olmadığı için bu komutları kendim denemedim. Alttaki yöntemi denemeden önce Timeshift gibi bir yedekleme uygulaması ile sisteminizi yedekleyiniz.

Xfce 4.16 Kurulum:

sudo apt install software-properties-common
sudo apt update
sudo add-apt-repository -S deb http://ppa.launchpad.net/xubuntu-dev/staging/ubuntu focal main
sudo apt update
sudo apt full-upgrade

PC’nizi yeniden başlatın.

Xfce 4.16 kurulumunu geri almak isterseniz:

sudo apt install ppa-purge
sudo ppa-purge -d focal ppa:xubuntu-dev/staging

PC’nizi yeniden başlatın.

Debian unstable depoda mevcut. Ben kurdum 4.16 yı.

1 Beğeni

Evet, PPA yerine Debian unstable depodan yüklemek daha sağlıklı olur.

Ben iki türlü yol denedim. Birincisinde xfce 4.12 yüklü iken unstable depoları ekleyip yükseltme yaptım ama bazı lib dosyaları temelden değişmesi kaldırılması gerekti. Süreci tamamladım.ama bir süre sonra pardus mağaza bozuldu ve düzeltmeler işlemedi. İkinci yöntemde pardus 19.4.1 server ile yine unstable depoları ekleyerek önce xfce 4.16 paketleri çektim üzerine de pardus-xfxe-desktop paketini kurmaya çalışırken pardus mağaza başta olmak üzere bir çok paketin unstable uyarısı ile kurulamadığı hatası verdi. Ağzımızın tadıyla 4.16 kullanamadık :joy: sizde durum nasıldı pardus mağaza ya da diğer pardus uygulamaları stabil çalıştı mı?

Ben Pardus Backsport Xfce ye Debian unstable depoyu ekledim. sudo apt update ve upgrade yaptım. Ne var ne yok guncelledi. Kernel bile 5.10 oldu. :grinning:

Onun pardusla alakası kalmamış :smiley: Direkt olarak debian unstable kursaydın daha mantıklı olurdu senin için.

Başkan sen konuyu biliyorsun. Bunu AMDGPU driver için kurdum. Yoksa ne haddime benim unstable :grinning:

https://sulincix.github.io/sayfalar/html/debian-kurulumu.html

Debian unstable deposunu sisteme ekleyip sistemi güncellerseniz, artık o dağıtıma geçmiş olursunuz, sistemin stabilliğinden vazgeçmiş olursunuz.

Apt pinning yöntemi ile, eklediğiniz harici depodan sadece istediğiniz paketlerin yüklenmesini sağlayabilirsiniz. Şuradaki örnekteki gibi:
https://wiki.debian.org/AptConfiguration#Prevent.2Fselective_installation_from_third-party_a_repository

Türkçe kaynak:
https://www.debian.org/doc/manuals/apt-howto/ch-apt-get.tr.html#s-default-version

Kernel için