Yeni Donanımlar ile Pardus Kurulum Sorunu

Öncelikle merhabalar
Yaklaşık iki yıldır Pardus kullanıyordum. Bilgisayarımı yeni güncelledim. Yeni kullandığım
işlemci AMD Ryzen 7 3700X ve ekran kartı AMD RX5700 XT dir. Pardus 19’ u kurmak istedim ve siteden indirdim. Hatasız bir şekilde usb ye yazıldı. Boot ettim ve canlı da Pardus işletim sistemini açtım. Sonra yeniden başlatarak kurulum yapmak için tekrar seçim ekranına geldim. Burada Grafiksel Kurulumu seçerek devam ettim. Seçtiğimde grafikler birbirlerine girdi ve sanki yüklemede ki seçim penceresi yatay duruyormuş gibiydi. alt üst oklar ile seçim yapabiliyorsunuz fakat ekranda hangi pencerede olduğunuz hiç belli olmuyor. Bu hata ile karşılaşınca grafiksel olmayan kurulum ile tekrar deneyeyim dedim. Sonrasında önceden kurulum yaptığım 17.5 sürümünü deyeyim dedim ve aynı sıkıntı ile orada da karşılaştım. Kernelin yeni donanımları destekleyemeyebilir olduğunu söylendi. Belki de önceden karşılaşmış olan vardır. Bu hatayla karşılaşan ve çözebilen var mı acaba?

Sanırım uefi olarak değil legacy boot ettiniz. Legacy olarak boot etmeden önce menüde Grafik arayüzle kur seçeneğinin üzerindeyken tab tuşuna basıp ro vga=789 parametresini ekleyin ve enter veya f10 tuşuna basarak bu parametreyle açmaya çalışın. Karşınıza çözünürlüklere atanmış harfler şeklinde bir menü gelecek. Oradan da uygun çözünürlüğe denk gelen bir harfe basıp entera basarak ilerleyin. Bu şekilde kurulum yapabilirsiniz.

Bu adımlardan önce uefi kurulumu da denemenizi tavsiye ederim orada bu sorunu yaşamayabilirsiniz. Yeni donanım 4.19 kernel ile kurulumdan sonra siyah ekranda kalabilir. O aşamayı da kernel güncelleyerek aşabilirsiniz. 2019 model Amd işlemcim sebebiyle ben de yaşadım bu problemleri. Benim cihazımda bu yöntemlerle sorunu aşabildim.

2 Beğeni

Çok teşekkür ederim. Dediğiniz yöntemle kurulumu yaptım fakat siyah ekranda kalıyor. Sanırım kernel güncellemem gerekiyor. Peki bunu nasıl yapabilirim? Şimdiden çok teşekkür ederim.

Debian buster backports deposunu ekleyip oradan kerneli kuracağız.

Öncelikle sistemi açın siyah ekranda kaldığınız sırada ctrl+alt+f2 veya f3 kombinasyonunu uygulayın. Terminal ekranı açmış olacaksınız. Burda Pardus’u kurarken oluşturduğunuz kullanıcı adını yazıp enter ve ardından parolanızı yazıp yine enter tuşuna basın. Parolanızı yazarken ekranda bir şey belirmeyecek endişelenmeyin. parolanızı yazın ve enter a basın.

sudo nano /etc/apt/sources.list

Bu komutu yazın terminalde metin editörü açılmış olacak. Burada depo adreslerini göreceksiniz. Klavyedeki yön tuşlarını kullanarak deb ile başlayan bu adres satırlarının başına yani deb den önce diyez işareti # koyun ve sonrasında

deb http://deb.debian.org/debian buster-backports main

satırını ekleyin ama bunun başında # işareti olmasın bu şekilde yazın ve ctrl+o kombinasyonuyla yazın ve kaydedin ctrl+x kombinasyonuyla da editörü kapatın. sonra

sudo apt update

komutuyla yeni depoyu paket yöneticimize tanıtalım. Şimdi kernelimizi ve headerları aşağıdaki komutları uygulayarak kuralım. Bakarak yazacağınız için karakterlere dikkat edelim.

sudo apt install linux-image-5.5.0-0.bpo.2-amd64
sudo apt install linux-headers-5.5.0-0.bpo.2-amd64

Bağımlılıklarına da onay verip kurulumu gerçekleştirip

sudo reboot

komutuyla yeniden başlatalım. Bu şekilde Pardus’un açılması gerekmektedir.

2 Beğeni

Çok teşekkür ederim. Tarif ettiklerinizi uygulayarak sorunu çözdüm. Şimdide hdmi portundan bağlı ana monitörümü görmedi. Bununla ilgili bir bilginiz var mı acaba?
Şimdiden teşekkür ederim.

1 Beğeni

O konuda maalesef bilgim yok.

1 Beğeni

Selamün Aleyküm
xrandr komutunun çıktısını paylaşabilir misiniz acaba?

Aleyküm Selam

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1360 x 768, maximum 1360 x 768
default connected 1360x768+0+0 0mm x 0mm
   1360x768       0.00* 
   640x480        0.00 

Çıktının tamamı bu kadar mı?
Şu komutu çalıştırdıktan sonra sudo apt -y install inxi lshw aşağıdaki komutların çıktılarını da paylaşabilir misiniz acaba?
sudo lshw -c display
inxi -F

sudo lshw -c display
*-display UNCLAIMED
description: VGA compatible controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:0a:00.0
version: c1
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller cap_list
configuration: latency=0
resources: memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fcc00000-fcc7ffff memory:c0000-dffff

inxi -F
System:
Host: amcaHomePardus Kernel: 5.5.0-0.bpo.2-amd64 x86_64 bits: 64
Desktop: Xfce 4.12.4 Distro: Pardus GNU/Linux 19.2 (Ondokuz)
Machine:
Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x
serial: UEFI [Legacy]: American Megatrends v: 1405
date: 11/19/2019
CPU:
Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP
L2 cache: 4096 KiB
Speed: 2196 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2195 2: 2192
3: 2193 4: 2190 5: 2196 6: 2198 7: 2192 8: 2189 9: 2193 10: 2196 11: 2195
12: 2198 13: 2195 14: 2194 15: 2192 16: 2195
Graphics:
Device-1: AMD Navi 10 driver: N/A
Display: x11 server: X.Org 1.20.4 driver: ati,vesa
unloaded: fbdev,modesetting,radeon resolution: 1360x768~N/A
OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.5.0-0.bpo.2-amd64
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: d4:5d:64:45:e1:81
Drives:
Local Storage: total: 1.59 TiB used: 5.80 GiB (0.4%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB
ID-2: /dev/sda vendor: Samsung model: HD502IJ size: 465.76 GiB
ID-3: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
ID-4: /dev/sdc vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
Partition:
ID-1: / size: 441.79 GiB used: 5.80 GiB (1.3%) fs: ext4 dev: /dev/sdb1
ID-2: swap-1 size: 15.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb5
Sensors:
System Temperatures: cpu: 43.2 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 282 Uptime: 2m Memory: 15.61 GiB used: 1.48 GiB (9.5%)
Shell: bash inxi: 3.0.32

Çok teşekkür ederim. Bu yöntem ile çözüme ulaştım.

1 Beğeni

Bu konu son cevaptan 10 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

© 2020 TÜBİTAK