Yüklü .deb paketini kurarken indirmeye kalkışıyor

Ben depodan daha önce
apt download code
diyerek bir paket indirmiştim.
apt install ./paket_adi.deb
diyerek paketi kurabileceğimi öğrendim fakat bunu dediğimde paketi tekrar indirmeye çalışıyor.
Bu bir hata mı yoksa normalde böyle mi olmalı bana yardımcı olabilir misiniz?

Not: paket_adi.deb yerine indirdiğim .deb uzantılı dosyanın tam ismini yazdım.

Terminal çıktısı daha uygun olur cevap verebilmek için

Herhangi bir hata vermiyor.
Normal apt indirme çıktılarını veriyor.
apt install çıktılarını yani.

Hocam birde şöyle deneyin

sudo dpkg -i paket_adi.deb

Bildiğim kadarıyla o komut bağımlılıkları indirmiyor fakat deneyeceğim.

Evet o paketi kurdum fakat bağımlılıkları zaten bilgisayarımda yüklüydü.
Peki bağımlılıklarını da otomatik indirmesi için ne yapabilirim.
Ya da bağımlılıkların da terminalin çalıştığı klasörde olduğunu varsaysak.
Yani bağımlılıkları yüklerken öncelikli olarak bulunuşan veya belirtilen klasöre baksa. Yapamaz mıyız?
Buna göre bir komut var mıdır?

Emin değilim. Ben 17.5 XFCE kullanıyorum, bağımlılık indirmeme sorunu pek yaşamadım.

Bildiğim kadarıyla apt bağımlılıkları otomatik olarak indirirken dpkg sadece bağımlılıkların karşılanmadığını söylüyor ve kurulumu yapıp tetikleyicilere dokunmadan çıkıyor.

Tamam sanırım çözdüm.
apt bağımlılıkları indiriyor,
dpkg ise şöyle bir çıktı veriyor:
kurth4cker@parduspro:~/Genel$ sudo dpkg -i ./xterm_344-1_amd64.deb
Daha önce seçili olmayan xterm paketi seçiliyor.
(Veritabanı okunuyor … 493216 dosya veya dizin kurulu durumda.)
Paket açılacak: ./xterm_344-1_amd64.deb …
Paket açılıyor: xterm (344-1) …
dpkg: bağımlılık sorunları yüzünden xterm paketi yapılandırılamıyor:
xterm şuna bağımlı: xbitmaps, ama:
‘xbitmaps’ paketi kurulu değil.

    dpkg: xterm paketi işlenirken sorun yaşandı (--install):
     bağımlılık sorunları - yapılandırılmadan bırakılıyor
    Tetikleyiciler işleniyor: desktop-file-utils (0.23-4) ...
    Tetikleyiciler işleniyor: mime-support (3.62) ...
    Tetikleyiciler işleniyor: hicolor-icon-theme (0.17-2) ...
    Tetikleyiciler işleniyor: man-db (2.8.5-2) ...
    /usr/bin/mandb: iconv_open ("UTF-8//IGNORE", "LATIN-1"): Geçersiz argüman
    İşleme sırasında hatalarla karşılaşıldı:
     xterm

Fakat hala tek komutla aptnin bağımlılıklar için depo yerine belirtilen klasöre bakmasını nasıl sağlayacağımı bilmiyorum.

Paketi bulunduğumuz dizine indirme

sudo apt-get download paketadı

paketi ve bağımlılıklarını var/cache/apt altına indirme
sudo apt-get install -d paketadı

Bu konu son cevaptan 30 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

© 2020 TÜBİTAK