Pardus 19.1 Nvidia GTX 950M Driver Sorunu

Merhaba
Forumda ki hemen hemen tüm önerileri denedim, kernel değiştirdim diğer forumlardan denedim. NVidianın sitesinden güncel paketi inidirp kapalı kurulum yaptım, açık kurulum yaptım ama bi türlü driverı kullanılıyor hale getiremedim ve nvidia-settings i çalıştırmayı başaramadım. Ayrıca bumblebee kurduğum zaman bilgisayar kitleniyor capslock-numlock bile tepki vermiyor. Bilgisayarı düğmeden kapatıp tekrar açıp eski kerneldan girip bumblebee yi kaldırdıktan sonra sorun düzeliyor. Bilgiler aşağıda

ali@XPardus:~$ inxi -G
Graphics:
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
  Device-2: NVIDIA GM107M [GeForce GTX 950M] driver: nvidia v: 440.59 
  Display: x11 server: X.Org 1.20.4 driver: intel,modesetting 
  unloaded: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
  v: 4.5 Mesa 18.3.6 

ali@XPardus:~$ sudo lshw -C display
  *-display                 
   description: 3D controller
   product: GM107M [GeForce GTX 950M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:16 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
  *-display
   description: VGA compatible controller
   product: HD Graphics 530
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:126 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

glxinfo | grep "OpenGL"
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.3.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

ali@XPardus:~$ lspci | grep "VGA"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
1 Beğeni

Nvidia’ya yazın, her dağıtımda böyle :slight_smile:

1 Beğeni

Maalesef her dağıtımda böyle değil. Ubuntu tabanında nvidia-prime ile Nvidia sürücüsü kolayca kullanılabiliyor. Alternatif olarak Bumblebee’yi de kullanabiliyorsunuz. Şu an Linux Mint’de Bumblebee ile herhangi bir sorun yaşamıyorum. Aynı durum Nvidia Prime için de geçerli, ama ben biraz daha düşük performans vermesine rağmen Bumblebee’yi tercih ediyorum.

Aslında sorun dağıtımla ya da tabanla da ilgili değil, düzgün bir kurulum rehberine ihtiyaç var sadece. Mesela LM TR forumundaki PPA deposu bile hazırlamışlar, kolayca kurdum.

Nvidia ya yazdım. Nvidia tarafından pek umudum yok ama hayırlısı.

1 Beğeni

Sorun şu ki düzgün bir kurulum rehberine ihtiyaç olmaması lazım :slight_smile:

Ubuntu forumlarına veya soru sorulan herhangi bir platforma bakın, AMD ekran kartıyla sorun yaşayanların(var mı ki öyle bir şey onu da görmedim hiç) sayısı ile Nvidia ekran kartıyla sorun yaşayanların sayısı arasında nasıl bir uçurum var diye.

Nvidia’nın sürücüsü düzgün çalışsın diye birileri githubda repolar oluşturuyor, uygulamalar yazıyor, forumlarda rehberler oluşturuyor. Niye? Çünkü Nvidia’nın sistem çökertmek dışında hiçbir işe yaramayan sürücüleri yüzünden.

Driver performansını konuşmuyorum bile çünkü daha “kurabilmiş” değiliz. (Windows’ta tek tıkla yaptığınız iş…)

2 Beğeni

Hocam Radeon 530… Laptop alırken AMD Linux’ta sıkıntı çıkarmıyor diye aldım meğer Radeon 530’un sürücüsü yok ve çipset de AMD, kernel seçiyor. 4.19 ile açılmıyor 5.3 ile açılıyor ama 5.4 ile de açılmıyor. Nvidia ilk kullandığım bilgisayardı hala daha o bilgisayar var 2011 Pardus’ta özgür olmayan sürücüleri kullan diyordum tek tıkla kuruluyor kullanıyordum, güncel olarak da Linux Mint bu imkanı verenlerden biri. Ama o eski cihazda Debian tabanlı güncel bir Pardus sürümü kullanmak istediğimde aylarımı alan şöyle bir çözüm bulabildim ve bu konuda bir rehber hazırlamak zorunda kaldım. Maalesef üreticinin AMD veya Nvidia olması pek fark etmiyor. Bazen sahip olduğunuz ürünün spesifik olarak Linux desteği yok, bazen sürücü olsa dahi kurmak için çok uğraşıyorsunuz oysa başka distrolarda bu iş çok da kolay halledilebiliyorken.

Saygılar.

1 Beğeni

Radeon 530’un sürücü desteği yok. (Linuxta)

Desteklenen sürücüler belli ve onlar da cayır cayır çalışıyor, R9 280 ile bundan 5-6 sene önce Linux’taki AMD driveri ile Windows’tan daha fazla fps alıyordum.
https://www.amd.com/en/support/kb/release-notes/rn-prorad-lin-18-20

Her model için Linux’a driver çıkarmaması tartışılır ama sürücünün çalışması bambaşka çok temel bir sorun. Nvidia mesela, driver ilgili gpu modelini destekliyor da ne oluyor :))))

4 Beğeni

Performans konusu daha geniş bir konu ama kullanıcı tarafında ilk ilgilendiğimiz taraf henüz sürücüyü kurmaya çalışırken karşı karşıya kaldığımız zorluklar. Bu da dağıtımdan dağıtıma değişiklik gösteriyor. Debian’da bu işler daha zor oluyor gördüğüm kadarıyla ve bu da doğal olarak Pardus’a etki ediyor. Sürücü yöneticisinden üreticinin sağladığı yazılımı birkaç tıkla kurabilmek bir yana onlarca yöntem deneyip tty ekranından ileriye gidememek bir yana.

Ben de isterim Linux’un her üretici tarafından dikkate alınıp sürücü desteğinin sunulmasını ama şu da bir gerçek ki kişisel bilgisayar pazarında yüzde üçlük bir payı olan işletim sistemine sürücü desteğinin sunulmaması mevcut ekonomik sistemin doğrularıyla örtüşüyor. O yüzden gerekirse repo da kurulacak uygulama da yapılacak.

Dağıtımın geliştiricilerinin konuya nasıl baktığı da önemli.

Saygılar.

1 Beğeni

Ubuntu tabanında tek tıkla nvidia sürücüsünü kurabiliyorsun işte. Nvidia sürücüyü hazırlıyor, dağıtımlar bunu sistemlerine uyarlıyor. İşin karışık kısmı hibrit sistemlerdeki xorg’dan kaynaklı nvidia sürücüsü kısıtı. Ubuntu’daki nvidia-prime, uyarlanarak şu an Fedora ve Mageia’da da kullanılabiliyor. Bazı basit betikler Pardus’a uyarlanarak depoya eklenebilir. Mesela şu betiğin Debian’a uyarlanması çok kolay görünüyor. Geliştiricisi kolay kullanım için pkexec dosyalarını bile hazırlamış, sadece bir kaç dokunuşa ihtiyacı var. https://github.com/wildtruc/nvidia-prime-select

Bumblebee için de durum aynı, depodaki Bumbleebee paketi düzenlenip, GLVND ve Debian’daki nvidia modalias ile uyumlu hale getirilse, sorunsuzca kullanılabilir.

Bununla birlikte AMD’nin açık kaynak sürücülere destek vermesi, Linux üstünde bir avantaj. Bununla birlikte bazı aygıtlarda güç yönetimi ve senkron sorunları olabiliyor. Nvidia sürücüsünü kurabildiğinizde genellikle bu sorunları yaşamıyorsunuz.

Not: Radeon 530 kartların amdgpu açık kaynak sürücüsü ile desteği bulunuyor.

1 Beğeni

Bu konu son cevaptan 10 gün sonra otomatik olarak kapatıldı. Yeni cevap girilmesine izin verilmiyor.

© 2019 TÜBİTAK